LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2009, 04:44 PM   #1
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Rep: Reputation: 0
Question problem logging into root account


i recently change my root password (because ppl i dont trust found it out) i logged out after the change and now everytime i try to log back in. my teacher tells me i need to reset the password because i didnt change it correctly. i know how to acces root. when i type in the new password it works. but not in graphical mode. my teacher told me to reset the password but i dont know how.
 
Old 05-08-2009, 04:48 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Well how DID you change it? You only need to run "passwd" and change away. If that doesn't work then it sounds like you've got something else funky going on your system we aren't aware of.
 
Old 05-10-2009, 09:40 PM   #3
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
um... ysee i went to change my password and i think i changed my password but not my root password. problems only started after i changed my password this way. so if i type passwd in root itll allow me to change the password?
 
Old 05-11-2009, 07:22 PM   #4
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
well i changed my password but nothing has changed. when ever i log in it tels me cannot login using /. and then it says could not run kstartupconfig 4. check your installation.

these are not direct quotes from my computer. this is just what im pretty sure it said from my memory
 
Old 05-11-2009, 07:23 PM   #5
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
i only have a root account so i pretty much cant use my computer at all...
 
Old 05-11-2009, 08:48 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
You should add your distro & version to your profile so we can see what you've got.
You can try interrupting the boot process and adding '1' to then end of line containing the kernel. This should boot into level 1 which will allow you to run passwd as the root user.

Alternately, you should be able to use your installation media to boot into rescue mode

linux rescue

at the prompt.
The exact instructions depend on your distro for the next steps.
 
Old 05-12-2009, 07:54 AM   #7
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
hahaha. i have no clue what you just said. im new to kubuntu. but i think my version is 8.1 everytime it boots, thats what it says
 
Old 05-12-2009, 08:25 AM   #8
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
hahaha???

What he said was to boot into "single-user" mode. This gives you "root" privileges with no password required. You then run "passwd root" to reset the root password.

To boot into single-user mode, you have to put grub into edit mode and add "1" or "single" to the kernel line.

To do this:
When the GRUB menu appears, hit any key to stop the countdown.
Hit "e" for edit, select the kernel line, and hit "e" again
Add "1" or "single" at the end of the line and hit return.
Hit "b" to boot.
 
Old 05-13-2009, 08:48 PM   #9
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
lol... im totally new to linux and programming languages for operating systems.I dont get most of the stuff u guys tell me so be patient.
 
Old 05-13-2009, 08:55 PM   #10
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
wow... this operating is definitely not user friendly. if ur like me and trying to do stuff with it, you end up messing with stuff...
 
Old 05-13-2009, 08:56 PM   #11
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
i mean not user friendly if u dont know what ur doing. but the interface is confusing. just trying to change my password is difficult. and i ended up messing with stuff like i did now
 
Old 05-13-2009, 09:16 PM   #12
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
uummm... whats a grub menu?
 
Old 05-13-2009, 10:11 PM   #13
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
grub menu is basically a list of options give to you by your boot loader. If you had windows xp install next to kubuntu then it would give you the chance to boot into kubuntu or windows xp.

Grub is nothing more than the boot manager. This is what boots the linux kernel up and running so it can start all the processes that gets linux up and running.

What they are having you do is allow the system to boot up into (the best analogy would be the windows rescue shell) so that you can reset your password. However in kubuntu root does not have a password. your user does. so when you boot system into this mode you will need to do the following
Code:
passwd <your user name here>
and that should change your password.

* edit *
Also the grub menu is the first black screen that you see. It normally has a timer that counts down. should look something like

Grub Loading Stage1.5

Grub Menu
Hit any key to stop count down

Last edited by jstephens84; 05-13-2009 at 10:14 PM.
 
Old 05-14-2009, 01:16 AM   #14
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
GRUB = GRand Unified Bootloader : http://en.wikipedia.org/wiki/GNU_GRUB
 
Old 05-15-2009, 10:11 AM   #15
pcdsi
LQ Newbie
 
Registered: Apr 2009
Posts: 15

Original Poster
Rep: Reputation: 0
um... i dont have windows on this computer. just linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is my common account can't open Terminal in XFCE4 but root account? notsay Slackware 4 08-19-2007 12:29 AM
Prevent user account from logging in but allow su to account DejaCpp Linux - General 4 07-26-2006 12:44 PM
is it legitimate and allowed and can be done to make another user account set uid and gid to null 0 to make another root account with different name and possibly not damage the debian system creating and using that new account BenJoBoy Linux - Newbie 12 01-29-2006 11:02 AM
problem logging in as root apant Linux - Newbie 3 07-03-2005 11:06 AM
Logging in as root after ¨normal" account created Xalies Linux - Newbie 2 08-02-2004 02:36 AM


All times are GMT -5. The time now is 11:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration