LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-29-2004, 09:13 AM   #16
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52

if you wrote a script, you must make it executable : " #chmod +x <scriptname>

and you posted " PING 134.128.124.31 " ; is that your router-adress ?
if so, i think you should put it in " resolve.conf " as nameserver-adress.

egag
 
Old 12-29-2004, 02:17 PM   #17
GnaM
Member
 
Registered: Dec 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Is my IP 134.184.124.31 a router address ?

Dear egag,

Thank you for your reply and your advice that I should make my script executable.
So since I didn't know this, this kind of information was very precious indeed.

Regarding your question if my IP 134.184.124.31 is a router address, I am not certain.
I don't know exactly what it means. What I do know is that this IP is needed to configure
my Internet access.

If you read the previous posts well, then you can see that iZvi already informed me
to keep my resolv.conf. So in reply to your statement, this IP 134.184.124.31 is present
in my resolv.conf.

Thank you very much for your contribution,

regards.
 
Old 12-29-2004, 04:43 PM   #18
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Rep: Reputation: 35
Hi GnaM,

134.128.124.31 is your own IP (wasn't it???) and it mustn't be
in etc/resolv.conf !!!
Try adding 134.128.124.100 to your /etc/resolv.conf , after any other entries and try to ping it. Try also to ping some web sites. Do you have the command netwatch? If yes does it show any activity?(must be root to execute it)

Also egag already said that to execute file even as root you must make it executable first.
When everything works from the command line, you should try the automated toolz again.

Last edited by iZvi; 12-29-2004 at 04:45 PM.
 
Old 12-30-2004, 04:33 PM   #19
GnaM
Member
 
Registered: Dec 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Nothing new so far.

Hi iZvi,

You were right, my IP 134.184.124.31 wasn't present in the resolv.conf .
As you advised me, I put the gateway into the resolv.conf like this :
PHP Code:

nameserver 134.184.250.7
nameserver 134.184.15.13
nameserver 134.184.124.100
search vub
.ac.be ulb.ac.be 
and like this .

PHP Code:

nameserver 134.184.250.7
nameserver 134.184.15.13
search vub
.ac.be ulb.ac.be
nameserver 134.184.124.100 
In both cases ---ping 134.184.124.100---- gave me something like this :

PHP Code:
PING 134.184.124.100 (134.184.124.10056(84bytes of data.
64 bytes from 134.184.124.100icmp_seq=1 ttl=255 time=0.670 ms
64 bytes from 134.184.124.100
icmp_seq=2 ttl=255 time=0.646 ms
64 bytes from 134.184.124.100
icmp_seq=3 ttl=255 time=0.598 ms
64 bytes from 134.184.124.100
icmp_seq=4 ttl=255 time=0.651 ms
64 bytes from 134.184.124.100
icmp_seq=5 ttl=255 time=0.659 ms
64 bytes from 134.184.124.100
icmp_seq=6 ttl=255 time=0.687 ms
64 bytes from 134.184.124.100
icmp_seq=7 ttl=255 time=0.662 ms
64 bytes from 134.184.124.100
icmp_seq=8 ttl=255 time=0.622 ms
64 bytes from 134.184.124.100
icmp_seq=9 ttl=255 time=0.661 ms
64 bytes from 134.184.124.100
icmp_seq=10 ttl=255 time=0.640 ms
64 bytes from 134.184.124.100
icmp_seq=11 ttl=255 time=0.621 ms
64 bytes from 134.184.124.100
icmp_seq=12 ttl=255 time=0.660 ms

--- 134.184.124.100 ping statistics ---
12 packets transmitted12 received0packet losstime 10999ms
rtt min
/avg/max/mdev 0.598/0.648/0.687/0.025 ms 
pinging websites doesn't work at all.

I do not have the command netwatch, but I do have the command netstat.
It have some data but it is rather a lot and because I don't know it relevance
to my problem I will post it upon your request.

Also, regarding the advice of egag, to make my script executable, it doesn't work out.
I did some thing like this in the file script.bat :

'# /etc/sh
modprobe 8139too
ifconfig eth0 134.184.124.31
route add default gw 134.184.124.100

Then I tried to make it executable as you suggested, but still when I do ./script.bat i get permission denied.

Anyway, Thank you a lot for your time in solving my problem.



Regards.

Last edited by GnaM; 12-30-2004 at 06:10 PM.
 
Old 12-30-2004, 06:17 PM   #20
GnaM
Member
 
Registered: Dec 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Thumbs up Writing you a post from Linux instead of windows. :)

Dear iZvi,

I am happy to announce to thee that my internet problem is partially solved.

When I was looking on the net regarding configuring your network card, I saw that
they were allways using those same commandline tools as you learned me.
However there is this small difference :
Mostly I saw(applied to my situation though) :
ipconfig eth0 134.184.124.31 netmask 255.255.255.0

When I did that I could ping some websites (except for google) and when I opened
Konquerer, I saw to my amazement that I had access to the Internet.

I am very happy,
Thank you all for your time investments, I couldn't have done it so quickly without your advise.
May God reward you.

Regards.
 
Old 12-30-2004, 06:43 PM   #21
GnaM
Member
 
Registered: Dec 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Some problems remain.

Hi,

As iZvi stated in one of his recent posts, these commandline tools were just some
temporary aids, used in configuring my network card.
Afterwards Yast had to be used again to set everything up.
This would be good, because then I won't have to configure my network card again and again
when rebooting.

Since Yast did a poor job in my access to the Internet I really don't see how I could use it again
inorder to get my network card configured properly. It is very strange that it works through commandline
but not through Yast, despite the same values being filled in.........

Also, if I am not mistaken, Internet seems to be a bit on the slow side.
When I want to download some stuff, it goes rather slow.
I just made a test and I got about 5.0 KB/s to 25.0 KB/s, yet normally
I have about 300KB/s to 800KB/s .

As iZvi already remarked,
Quote:
Now on the problem, your /etc/resolv.conf is OK. ethtool results are also OK (the speed is only 10 MB, but still not an error).
I tried to do something like ethtool -s eth0 speed 100 and it just executes without giving any message of success or not.
When I inquire ethtool eth0 nothing has changed.

In my ignorance, what am I overlooking here ?

Regards.

Last edited by GnaM; 12-30-2004 at 06:47 PM.
 
Old 12-31-2004, 03:59 AM   #22
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Rep: Reputation: 35
Congratulations, very happy for you!

The netmask shows how much of your IP should be used as a network number part and how much as your number in the network. When you don't specify it, ifconfig just assumes the default for your class network (it knows the class by the IP). I just thought that ifconfig will assume the right value, but I've been wrong.

And the command line tools are the most powerful in linux, your GUI-accessories are just using them in the background . however, you should try yast to make your life easier - just specify the correct values, you already learned using cmdline tools, and don't switch on IP forwarding

Even 10 Mbits/s are still enough to have full speed internet - that's probably not the problem, maybe this time the problem is the ISP?
My NIC sometimes shows also 10 Mbits/half duplex, but nothing different happens (Nobody shares files trough windows, so no high-speed downloads are needed). It solves automatically after some day. And maybe your network isn't capable of higher speed?
 
Old 12-31-2004, 04:05 AM   #23
GnaM
Member
 
Registered: Dec 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Network ROCKS

Dear iZvi,

Here at the university we have got one of the best internet connections available.
Download speeds at 300 to 800 KB/s are very common here.
In windows I have this download speed, but here in Linux, even this forum takes a sec. or two
do get set up. This is really NOT normal.

Is there a way to speed up things ?

Regards.
 
Old 01-02-2005, 04:48 AM   #24
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Rep: Reputation: 35
Sorry, but I don't have idea whY is the speed so low. Your net is really good. I have 100 KB/s. It's still good, If I don't compare to yours.
 
Old 01-02-2005, 09:09 AM   #25
GnaM
Member
 
Registered: Dec 2004
Posts: 33

Original Poster
Rep: Reputation: 15
To Conclude.

Hi,

I would like to thank iZvi for his numerous contributions in helping solving my problem.

Though I have access to Internet from linux, there are still a few optimization issues left which
I will take to to the networking section.

For future reference, all I had to do to solve the Internet problem(even though Yast was correctly set)
was to configure my network card manually.
This should be done as follows :
-Delete your card from yast, making it clean.
-modprobe 8139too (8193too is the module name for Realtek)
-ifconfig eth0 *YOUR-IP-ADDRESS* netmask *YOUR-NET-MASK* (mostly 255.255.255.0)
-route add default gw *YOUR-DEFAULT-GATEWAY* (looks very similar to *YOUR-IP-ADDRESS*)

To test you simply do : ping *YOUR-IP-ADDRESS*
ping wwww.google.com

If you would reboot then all your settings will get lost, therefor, if Internet works,
you must set up Yast again and for some bizarre reason things will work all of the sudden.

Thank you all for your help.

Regards.
 
Old 01-02-2005, 08:26 PM   #26
RobertP
Member
 
Registered: Jan 2004
Location: Manitoba, Canada
Distribution: Debian
Posts: 454

Rep: Reputation: 32
According to your Windows settings, the netmask should have three "255"s >255.255.255.0

Usually, this stuff is set up by the ISP by DHCP and you have that option turned off. In that other OS, was there a box checked, "obtrain IP address automatically" or so forth? That "automatically" is DHCP.

Try asking your ISP if they use DHCP, re-check the settings in that other OS, or try YAST with DHCP client enabled.

If you must use manually configured network configuration, be sure to put in the gateway , netmask and IP correctly.

Once this works, you will be OK
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
realtek8139/810x family PCI fast Internet nic-how to configure lngmn7 Linux - Networking 3 04-16-2005 08:44 PM
SLOW INTERNET REALTEK8139(Genius LAN GF100TXRII) GnaM Linux - Networking 17 02-12-2005 07:47 AM
LAN / Internet setup problem Tony Townshend Linux - Networking 9 01-01-2005 03:05 PM
Internet and LAN access is unstable-is this a hardware problem or a software problem? soren625 Linux - Networking 1 06-07-2004 07:43 AM
Realtek8139 problem johnx Linux - Networking 6 08-22-2002 02:08 PM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration