LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2004, 01:14 AM   #1
rjite
LQ Newbie
 
Registered: Mar 2004
Distribution: redhat 8
Posts: 1

Rep: Reputation: 0
problem installing xine in redhat 8


I just installed Linux yesterday (Redhat 8) and am trying to figure out how to install different programs. I tried installing xine (I heard it was a good movie player). I downloaded the rpm files and typed in the command. From what I can make of it the program needs the libraries before it will install and I can't install the libraries without the program. If anyone knows how to fix this or what I'm doing wrong, please let me know. Thanks.

[Rob@dhcp80ffc12d Rob]$ rpm -i xine-0.9.20-fr1.i386.rpm
warning: xine-0.9.20-fr1.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
xine-lib >= 1.0.0 is needed by xine-0.9.20-fr1
libaa.so.1 is needed by xine-0.9.20-fr1
libpthread.so.0(GLIBC_2.3.2) is needed by xine-0.9.20-fr1
libxine.so.1 is needed by xine-0.9.20-fr1
[Rob@dhcp80ffc12d Rob]$ rpm -i xine-lib-1.0.0-fr0.beta9.1.i386.rpm
warning: xine-lib-1.0.0-fr0.beta9.1.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
SDL is needed by xine-lib-1.0.0-fr0.beta9.1
glut is needed by xine-lib-1.0.0-fr0.beta9.1
alsa-lib is needed by xine-lib-1.0.0-fr0.beta9.1
aalib is needed by xine-lib-1.0.0-fr0.beta9.1
libfame is needed by xine-lib-1.0.0-fr0.beta9.1
flac is needed by xine-lib-1.0.0-fr0.beta9.1
xvidcore is needed by xine-lib-1.0.0-fr0.beta9.1
libFLAC.so.4 is needed by xine-lib-1.0.0-fr0.beta9.1
libSDL-1.2.so.0 is needed by xine-lib-1.0.0-fr0.beta9.1
libaa.so.1 is needed by xine-lib-1.0.0-fr0.beta9.1
libasound.so.2 is needed by xine-lib-1.0.0-fr0.beta9.1
libc.so.6(GLIBC_2.3.2) is needed by xine-lib-1.0.0-fr0.beta9.1
libfame-0.9.so.0 is needed by xine-lib-1.0.0-fr0.beta9.1
libpthread.so.0(GLIBC_2.3.2) is needed by xine-lib-1.0.0-fr0.beta9.1
[Rob@dhcp80ffc12d Rob]$
 
Old 03-30-2004, 01:38 AM   #2
Ice9
Member
 
Registered: Jun 2002
Location: Belgium
Distribution: Sidux
Posts: 313

Rep: Reputation: 30
apt4rpm

This is really the only tool you need, just select what you want to have installed and it will take care of all the dependencies for you.
If you need help setting it up ask here or search the forums, there have been many posts about apt-get and synaptic (the front-end).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a problem in installing xine... Help, please.. regnox Linux - Software 4 07-16-2005 02:08 AM
Installing xine problem.... Novice_manu Linux - Software 3 05-29-2005 11:32 AM
Problem in installing xine cool_ashwin22 Red Hat 1 07-31-2004 06:13 AM
problem installing xine lib tylerb Linux - Software 15 02-26-2004 04:29 AM
problem installing tarball xine annehoog Linux - Software 0 05-12-2002 11:08 AM


All times are GMT -5. The time now is 03:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration