LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2013, 05:49 AM   #31
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled

I'm sorry Sir because I'm not specific about it earlier and many thanks for the quick reply.
I downloaded this package, (lwx_v0.1_r78-ns2.33.zip) and yes it is for ns2.33. Does it means that I can't install it with ns2.35?
Can you please advise me Sir what is the best thing to do to solve these problems.

Thank you Sir.
 
Old 01-30-2013, 06:07 AM   #32
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 31.

OK, "Light WiMAX Simulator".
> Installation > http://code.google.com/p/lwx/wiki/Installation

You can also get the code from "The LWX project repository"
http://code.google.com/p/lwx/source/checkout

$ svn checkout http://lwx.googlecode.com/svn/trunk/ lwx-read-only

I will make a test install ... later.
To find out how the "lwx" behaves on ns-2.35 .

-

Last edited by knudfl; 01-31-2013 at 04:38 AM.
 
Old 01-31-2013, 03:59 AM   #33
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled
Dear Sir, does the mistake happened because the module is not compatible with the ns version ? Thank you so much Sir.
 
Old 01-31-2013, 05:19 AM   #34
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Ns-2.35 : No luck with any of the three lwx versions.
Ns-2.33 : OK, but not when the build OS is Ubuntu 12.10.
( $ ns : Looks like it is OK when executed with no file,
but all examples failed : $ ./ns case_* : Segmentation fault.)

Building lwx :
A new patch with a Makefile.in was created : wimax_lwx0.1r78-ns-2.33.tar.gz
https://docs.google.com/file/d/0B7S2...liUTdKODg/edit
cd ns-allinone-2.33/ && tar xvf wimax_lwx0.1r78-ns-2.33.tar.gz
export CC=gcc41 CXX=g++41 && ./install

I did the successful build on Ubuntu 10.10.
A package has been uploaded, lwx-ns-2.33-ubuntu10_i386.deb (4.6 MB)
https://docs.google.com/file/d/0B7S2...hJS1V2bGM/edit
Can be installed with : $ sudo dpkg -i lwx-ns-2.33-ubuntu10_i386.deb
.. And works perfect on Ubuntu 12.10

The package provides : /usr/local/bin/ns-lwx
/usr/local/lib/wimax-lwx/ns-allinone-2.33/bin/**
/usr/local/lib/wimax-lwx/ns-allinone-2.33/lib/**
/usr/local/lib/wimax-lwx/script/**

Using : cd <path-to>/script/
$ ns-lwx case_one_ss.tcl
$ ns-lwx case_multi_ss.tcl
$ ns-lwx case_with_rs.tcl
$ ns-lwx case_without_rs.tcl
......

More info : the file FAQ.txt, and https://sites.google.com/site/lwxns2/

......

Last edited by knudfl; 01-31-2013 at 05:41 AM.
 
Old 01-31-2013, 05:32 AM   #35
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled
Thank you for your reply Sir and I really appreciate it. However there a few things I don't understand:

A package has been uploaded, lwx-ns-2.33-ubuntu10_i386.deb (4.6 MB)
https://docs.google.com/file/d/0B7S2...hJS1V2bGM/edit
Can be installed with : $ sudo dpkg -i lwx-ns-2.33-ubuntu10_i386.deb
.. And works perfect on Ubuntu 12.10

Does it means that I can use the code above to install the module in ns2.35? Please do advise me Sir. Thank you so much again.
 
Old 01-31-2013, 06:02 AM   #36
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled
Sir,
this is what I got when tried to use the code above:

zana@zana-VirtualBox:~/ns-allinone-2.35/ns-2.35$ sudo dpkg -i lwx-ns-2.33-ubuntu10_i386.deb
dpkg: error processing lwx-ns-2.33-ubuntu10_i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
lwx-ns-2.33-ubuntu10_i386.deb

Can you please advise me Sir. Thank you.
 
Old 01-31-2013, 06:03 AM   #37
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 35 : Please see line 1, post # 34 : ns-2.35 cannot be used.

The package 'lwx-ns-2.33-ubuntu10_i386.deb' is a stand alone "ns",
and no ns-2.33 (or ns-2.35) is required.

All executable 'ns' are hard coded to know their dependencies, and :
'ns-lwx' will use /usr/local/lib/wimax-lwx/ns-allinone-2.33/bin/tcsh*,
/usr/local/lib/wimax-lwx/ns-allinone-2.33/lib/**.
Nothing else is required : When the .deb package is installed,
you can run your simulations with $ ns-lwx <file>.tcl

-
 
Old 01-31-2013, 06:10 AM   #38
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled
Sir,

many thanks for your help and your guidelines Sir.
 
Old 01-31-2013, 06:16 AM   #39
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 36.

The first command is always : pwd
( To know your location )

If your location is /home/zana/, and the package is in /home/zana/Downloads/,
please do : 1) cd Downloads/
2) sudo dpkg -i lwx-ns-2.33-ubuntu10_i386.deb

Or : sudo dpkg -i Downloads/lwx-ns-2.33-ubuntu10_i386.deb

-
 
Old 01-31-2013, 06:26 AM   #40
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled
Dear Sir,

thank you so much Sir. It is working, the result shows:
zana@zana-VirtualBox:~/Downloads$ sudo dpkg -i lwx-ns-2.33-ubuntu10_i386.deb[sudo] password for zana:
Selecting previously unselected package lwx-ns.
(Reading database ... 183539 files and directories currently installed.)
Unpacking lwx-ns (from lwx-ns-2.33-ubuntu10_i386.deb) ...
Setting up lwx-ns (2.33-ubuntu10) ...

Errmm..does it means that the modules are succesfully installed?
 
Old 01-31-2013, 06:31 AM   #41
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 40
Quote:
Setting up lwx-ns (2.33-ubuntu10) ...
"Setting up <package-name>" : Means a successful package install.

File list : $ dpkg -L lwx-ns
... Then you can see, what's installed, and where.

$ dpkg -L lwx-ns > files_lwx-ns.txt
... Will save the file list to the current directory.

-
 
Old 01-31-2013, 06:48 AM   #42
zana
LQ Newbie
 
Registered: Jan 2013
Posts: 24

Original Poster
Rep: Reputation: Disabled
Smile

Dear Sir,

thank you so much again for your help. I really appreciate it!!
 
Old 04-03-2014, 05:02 AM   #43
kirejak
LQ Newbie
 
Registered: Feb 2014
Posts: 15

Rep: Reputation: Disabled
WiMAX simulator and 802.21 simulator

If anybody need the whole simulator for wimax in ns-2.33 with all five service classes or the whole simulator in ns-2.29 for 802.21 vertical handovers with many scripts that make vertical handovers of many users between wlan, wimax, umts, write me on kire_jakimoski@yahoo.com.
 
  


Reply

Tags
ns2, wimax, wimax-lwx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't find file to patch at input line n problem, Installing WiMax module on ns2-29 Narges Linux - Newbie 14 12-15-2012 05:41 AM
WiMax QoS example problem in ns2 Narges Linux - Newbie 0 09-04-2012 11:35 AM
A problem with installing Wimax model in ns2 maha.ahmed Linux - Newbie 4 08-04-2012 04:39 AM
NS2 simulator for Handover in wimax priya12 Linux - Software 0 09-14-2011 06:34 AM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration