LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-18-2003, 02:23 AM   #1
chokecherry
LQ Newbie
 
Registered: Nov 2003
Location: Lhr
Posts: 18

Rep: Reputation: 0
problem installing usb scanner


I have a benq usb scanner model-3300U, i seached for a scanner in mandrake control center , but it didnt detect anything , i used to select manually and find 3300 in its driver database , but it still didnt detect it . I have pluged it in usb2 , my hp printer is working fine of the same usb 2 port , so there is something else except usb controller

Help Please!!
 
Old 11-18-2003, 08:03 AM   #2
8nasmith
Member
 
Registered: Oct 2003
Location: Cornwall, UK
Distribution: Fedora Core 4
Posts: 268

Rep: Reputation: 30
i also need heklp i have a visoneer scnner but there is not dfriver support and icannot find a site to download the drivers
 
Old 11-18-2003, 08:03 AM   #3
8nasmith
Member
 
Registered: Oct 2003
Location: Cornwall, UK
Distribution: Fedora Core 4
Posts: 268

Rep: Reputation: 30
oh yes and my HP PSC 2210
 
Old 11-18-2003, 09:02 AM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
You should start by checking out the http://www.xsane.org/ homepage to see if it has your scanner listed if the supported scanners.

8nasmith,

If you have questions yourself, you should start your own thread instead of hijacking others. Unless your actually giving them an answer, don't hijack their thread. Its rude and unecessary.

Regards.
 
Old 11-21-2003, 04:39 AM   #5
chokecherry
LQ Newbie
 
Registered: Nov 2003
Location: Lhr
Posts: 18

Original Poster
Rep: Reputation: 0
hey its okay by me :>

Yes it is supported as it did get installed itself on my first mandrake 9.1 installation
but not on the 2nd though the usb controller is working fine.


anything else you can suggest ?




Quote:
Originally posted by trickykid
You should start by checking out the http://www.xsane.org/ homepage to see if it has your scanner listed if the supported scanners.

8nasmith,

If you have questions yourself, you should start your own thread instead of hijacking others. Unless your actually giving them an answer, don't hijack their thread. Its rude and unecessary.

Regards.
 
Old 11-21-2003, 05:54 AM   #6
mdbarton
Member
 
Registered: Nov 2003
Location: Solihull, England
Distribution: Ubuntu
Posts: 38

Rep: Reputation: 15
chokecherry, if the 3300U is an Asus scanner these are the same as the Agfa snapscan scanners. I used an Agfa snapscan frontend on sane on my Asus and it works fine.
 
Old 11-21-2003, 08:20 AM   #7
mdbarton
Member
 
Registered: Nov 2003
Location: Solihull, England
Distribution: Ubuntu
Posts: 38

Rep: Reputation: 15
sorry, just noticed yours is a benq 3300u - mines a asus 3300u.
 
Old 11-21-2003, 06:42 PM   #8
chokecherry
LQ Newbie
 
Registered: Nov 2003
Location: Lhr
Posts: 18

Original Poster
Rep: Reputation: 0
oh ok

oh okay , i just sit back and wait for help :>

Quote:
Originally posted by mdbarton
sorry, just noticed yours is a benq 3300u - mines a asus 3300u.
 
Old 11-21-2003, 07:54 PM   #9
chup
Member
 
Registered: Aug 2003
Location: South Africa
Distribution: Ubuntu (Feisty)
Posts: 280

Rep: Reputation: 30
Quote:
Originally posted by 8nasmith
oh yes and my HP PSC 2210
did you run drakconfig and goto printer settings?
it autodetected my hp psc 2210
 
Old 11-22-2003, 12:25 PM   #10
chokecherry
LQ Newbie
 
Registered: Nov 2003
Location: Lhr
Posts: 18

Original Poster
Rep: Reputation: 0
yeah i did

yes i did that already but it didnt detect it


Quote:
Originally posted by chup
did you run drakconfig and goto printer settings?
it autodetected my hp psc 2210
 
Old 02-16-2004, 07:18 AM   #11
silburnl
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 7

Rep: Reputation: 0
Coming late to the party... sorry.

Does 'sane-find-scanners' spot the scanner when it's plugged into the USB port?

Does scanimage -L find the scanner?

Do you have a firmware entry in your backend configuration file that points to your scanner's driver?

Regards
Luke
 
Old 03-10-2004, 04:07 PM   #12
deleric
LQ Newbie
 
Registered: Jan 2004
Distribution: Slackware 10.1 || Debian Sarge
Posts: 10

Rep: Reputation: 0
I've got it working by typing "su - "
So, nevermind!


-------------------------------------------------






Hi Guys, i've got myself a problem too with te HP psc 2210:
Linux Fedora RC2 severn
Got sane and xsane installed.

But when i run xsane it gives me an error: no scanner found.

I can print though.

When i run as root:
#sane-find-scanner

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x2911 [PSC 2200 Ser ies]) at libusb:001:003
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Scanners connected to the parallel port or other proprietary ports can't be
# detected by this program.


--

in my /proc/bus/usb/devices it says:


S: SerialNumber=MY28LD802N0G
C:* #Ifs= 4 Cfg#= 1 Atr=c0 MxPwr= 2mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=cc Prot=00 Driver=(none)
E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=82(I) Atr=03(Int.) MxPS= 8 Ivl=10ms
I: If#= 1 Alt= 0 #EPs= 3 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E: Ad=03(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=84(I) Atr=03(Int.) MxPS= 8 Ivl=10ms
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=05(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=85(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=86(I) Atr=03(Int.) MxPS= 8 Ivl=10ms
I: If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E: Ad=07(O) Atr=02(Bulk) MxPS= 32 Ivl=0ms
E: Ad=87(I) Atr=02(Bulk) MxPS= 32 Ivl=0ms

when i run usbvieuw it gives me:
PSC 2200 Series
Manufacturer: Hewlett-Packard
Serial Number: MY28LD802N0G
Speed: 12Mb/s (full)
USB Version: 2.00
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 8
Number of Configurations: 1
Vendor Id: 03f0
Product Id: 2911
Revision Number: 1.00

Config Number: 1
Number of Interfaces: 4
Attributes: c0
MaxPower Needed: 2mA

Interface Number: 0
Name: (none)
Alternate Number: 0
Class: ff(vend.)
Sub Class: 0
Protocol: 0
Number of Endpoints: 3

Endpoint Address: 01
Direction: out
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 81
Direction: in
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 82
Direction: in
Attribute: 3
Type: Int.
Max Packet Size: 8
Interval: 10ms

Interface Number: 1
Name: usblp
Alternate Number: 0
Class: 07(print)
Sub Class: 1
Protocol: 2
Number of Endpoints: 3

Endpoint Address: 03
Direction: out
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 83
Direction: in
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 84
Direction: in
Attribute: 3
Type: Int.
Max Packet Size: 8
Interval: 10ms

Interface Number: 2
Name: (none)
Alternate Number: 0
Class: ff(vend.)
Sub Class: 0
Protocol: 0
Number of Endpoints: 3

Endpoint Address: 05
Direction: out
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 85
Direction: in
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 86
Direction: in
Attribute: 3
Type: Int.
Max Packet Size: 8
Interval: 10ms

Interface Number: 3
Name: usb-storage
Alternate Number: 0
Class: 08(stor.)
Sub Class: 6
Protocol: 50
Number of Endpoints: 2

Endpoint Address: 07
Direction: out
Attribute: 2
Type: Bulk
Max Packet Size: 32
Interval: 0ms

Endpoint Address: 87
Direction: in
Attribute: 2
Type: Bulk
Max Packet Size: 32
Interval: 0ms

-----
I have been on the hpoj.sourceforge.net page and i have downloaded the packages provided by http://cyberelk.net/tim/hpoj.html (redhat rpm's) but to no effect.


Maybe you can give me some tips on solving this.... Thanks!


----

Last edited by deleric; 03-10-2004 at 04:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Scanner problem: usb 1-2: device not accepting address 3, error -71 lagartoflojo Slackware 1 11-13-2004 05:26 PM
USB, scanner problem. Likosin Linux - Hardware 1 05-22-2004 10:29 AM
USB Scanner problem again phil81 Linux - Hardware 5 04-09-2004 09:59 AM
Installing USB scanner CanonScan D646Uex iqbala Linux - Software 1 03-03-2004 08:16 AM
Scanner Artec e+ 48 U usb problem lazzarig Linux - Hardware 3 04-08-2003 10:39 AM


All times are GMT -5. The time now is 11:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration