LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2015, 02:25 PM   #1
Davdi
LQ Newbie
 
Registered: May 2013
Posts: 20

Rep: Reputation: Disabled
Problem installing/running Eclipse Luna on Mint17.1 LXDE


I've downloaded the latest eclipse (.tar.gz) and unpacked it to /usr/bin and created a launcher for it, but it doesn't launch.
I also created a shell script on the desktop called eclipse.sh, content :
cd /usr/bin/eclipse
./eclipse

and did a chmod 755 /Desktop/eclipse.sh in a terminal as root.
I did a chmod 775 on the eclipse executable as well, but it still won't launch

NB I followed the same procedure with Bluegriffon and that runs OK.

I bet I'm missing something obvious, but just can't think what.

Box is AMD Phenom ll x4 / 8GB DDR3 running Mint 17.1 LXDE.
 
Old 04-03-2015, 02:35 PM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Distribution: SLES 12
Posts: 1,682

Rep: Reputation: 116Reputation: 116
Is the file executable? (chmod +x ....)
 
Old 04-03-2015, 02:59 PM   #3
Davdi
LQ Newbie
 
Registered: May 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
chmod 755 makes it executable, I did that. - the 7 = R-W-X, the 5 = R-X
 
Old 04-03-2015, 03:04 PM   #4
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Distribution: SLES 12
Posts: 1,682

Rep: Reputation: 116Reputation: 116
Have you java installed?

Have you followed the install instructions here: https://wiki.eclipse.org/Eclipse/Ins...to_use_the_JVM

Last edited by Keruskerfuerst; 04-03-2015 at 03:05 PM.
 
Old 04-03-2015, 03:11 PM   #5
Davdi
LQ Newbie
 
Registered: May 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
It was something obvious - 64 bit version on a 32 bit distro - Doh!
 
  


Reply

Tags
eclipse, mint, shell script


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] eclipse luna on java8 looks wrong a4z Slackware 7 05-09-2015 03:35 PM
[SOLVED] Eclipse Luna under Debian Wheezy kdjantzen Linux - General 1 02-05-2015 01:35 AM
LXer: 7 Things I like about Elementary OS Luna | Luna Review LXer Syndicated Linux News 0 09-03-2013 10:31 AM
eclipse running problem Rohan_mk1 Linux - Software 0 10-27-2006 05:04 AM
Problem's running eclipse UmneyDurak Linux - Software 2 09-01-2004 09:29 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration