LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   problem installing ndiswrapper - Cannot find kernel version (http://www.linuxquestions.org/questions/linux-newbie-8/problem-installing-ndiswrapper-cannot-find-kernel-version-796056/)

shred_eng 03-17-2010 11:27 AM

problem installing ndiswrapper - Cannot find kernel version
 
hi, im trying to install ndiswrapper to get my belkin wireless g pci network card working, but have an error

makefile:34 Cannot find kernel version in /lib/modules/2.6.28-18-generic/build, is it configured?

i have apt-get installed build-essential linux-headers-server

this is on ubuntu server 9.04 32bit version.

thanks,

troop 03-17-2010 11:32 AM

http://ubuntuforums.org/showthread.php?t=953587

shred_eng 03-17-2010 04:01 PM

thanks for the link but there was nothing there to find a solution for me.

i have since tried to install the source but am not sure if i did the right thing , i tried :

apt-get source --only-source linux

something was installed but im not too sure what it was...

i also retried #make but got the same error.

what exactly does -makefile:34 Cannot find kernel version in /lib/modules/2.6.28-18-generic/build, is it configured? - actually mean? if i could go through the steps to "configure" whatever it is that needs configuring, then i might be able to solve it

any ideas.?


thx,

jefro 03-17-2010 07:36 PM

From here, might read this if you haven't already. https://help.ubuntu.com/community/Wi...er/Ndiswrapper


Ubuntu comes with the necessary ndiswrapper module pre-installed, but it needs the ndiswrapper-utils package to get it working. There is also a graphical interface for ndiswrapper that you can use called ndisgtk. This interface allows you to install, uninstall, and automatically start your ndiswrapper drivers very easily.

shred_eng 03-18-2010 05:45 AM

thanks for that info, i did - sudo do-release-upgrade , and upgraded to 9.01 and was able to install ndiswrapper. i didnt realise it was mostly pre-installed, it never gave any clues when i tried to install it.now lspci detects the wireless network card,however , /etc/init.d/networking restart gives errors and it says ath0 doesnt exist...but at least im a bit closer, i'll read the link you gave me and see if it helps,

thanks,


All times are GMT -5. The time now is 02:36 PM.