LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2007, 01:44 PM   #1
fsucsguy
LQ Newbie
 
Registered: Apr 2007
Posts: 9

Rep: Reputation: 0
Unhappy problem installing glibmm-2.13.3 library....


HI,

I'm trying to install glibmm-2.13.3 from sources and I get this error message from running the configure script ...

checking for GLIBMM... Requested 'glib-2.0 >= 2.9.0' but version of GLib is 2.4.7
configure: error: Package requirements (sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.9.0 gobject-2.0 >= 2.9.0 gmodule-2.0 >= 2.9.0) were not met:



Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIBMM_CFLAGS
and GLIBMM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
------------------

Looks to me like, it is not accepting glib-2.4.7 which is glib-2.0 >= 2.9... any guess, why it is giving that error message... ???

I have all those packages mentioned above and they are all in the standard directories and pkg-config is able to find the .pc files...

the tail part of config.log is

prefix='NONE'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define GLIBMM_MAJOR_VERSION 2
#define GLIBMM_MICRO_VERSION 3
#define GLIBMM_MINOR_VERSION 13
#define HAVE_DLFCN_H 1
#define HAVE_FLOCKFILE 1
#define HAVE_FUNLOCKFILE 1
#define HAVE_GETC_UNLOCKED 1
#define HAVE_INTTYPES_H 1
#define HAVE_MEMORY_H 1
#define HAVE_MKFIFO 1
#define HAVE_STDINT_H 1
#define HAVE_STDLIB_H 1
#define HAVE_STRINGS_H 1
#define HAVE_STRING_H 1
#define HAVE_SYS_STAT_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_UNISTD_H 1
#define PACKAGE "glibmm"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define STDC_HEADERS 1
#define VERSION "2.13.3"
#endif
#ifdef __cplusplus
extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 1

-----------
let me know if anyone needs more information.... any help is greatly appreciated.... thanks,.
 
Old 04-16-2007, 02:33 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Quote:
checking for GLIBMM... Requested 'glib-2.0 >= 2.9.0' but version of GLib is 2.4.7
You have version 2.4.7 of glib, gtkmm needs version 2.9.0 or greater. 2.4.7 is less than 2.9.0. Install a newer version of glib.

Last edited by weibullguy; 04-16-2007 at 02:35 PM.
 
Old 04-16-2007, 03:03 PM   #3
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 75
Quote:
Originally Posted by fsucsguy
Looks to me like, it is not accepting glib-2.4.7 which is glib-2.0 >= 2.9... any guess, why it is giving that error message... ???
That’s exactly the problem… Your version of glib2 is too old. Try upgrading to a version greater than glib-2.9 (the latest version at this time is 2.13).
Quote:
Originally Posted by fsucsguy
I have all those packages mentioned above and they are all in the standard directories and pkg-config is able to find the .pc files...
You do have a glib-2 with version greater than 2.9? Try typing “pkg-config glib-2.0 --modversion” into the console. If the version returned is not greater than 2.9, then either you don’t have such a version installed, or it is not “in the standard directories and pkg-config is unable to find the .pc files”.
 
Old 04-16-2007, 03:14 PM   #4
fsucsguy
LQ Newbie
 
Registered: Apr 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Wink

thanks arow... I thought that required version should be in between 2.0 and 2.9... but it was my misunderstanding...

looks like I got to install gobject and gmodule latest versions too,...

thanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glibmm - installation problem. fsucsguy Linux - Software 1 04-16-2007 02:08 PM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 03:32 PM
Got a problem compiling glibmm-2.4.0 Adan Linux - Software 2 09-02-2004 07:13 AM
problem installing glibmm-2.4.0 PierrePau Linux - Software 0 06-02-2004 06:41 PM
glibmm problem zmieff Linux - Newbie 1 05-10-2004 03:01 PM


All times are GMT -5. The time now is 05:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration