LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2012, 12:26 PM   #1
maknelly
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
Problem installing glibc-common


Hello,

I am trying to run CUDA applications and in order to do that I need the glut libraries which require the glibc-2.15 dependencies. I am running RHEL 6.1 which only has glibc-2.12.
I am trying to install glibc-common.2.15 but it is giving me the following errors.

Error: Package: glibc-common-2.15-21.fc18.x86_64 (/glibc-common-2.15-21.fc18.x86_64)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: glibc-common-2.15-21.fc18.x86_64 (/glibc-common-2.15-21.fc18.x86_64)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: glibc-common-2.15-21.fc18.x86_64 (/glibc-common-2.15-21.fc18.x86_64)
Requires: /usr/bin/bash
Error: Package: glibc-2.12-1.25.el6.i686 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
Requires: glibc-common = 2.12-1.25.el6
Removing: glibc-common-2.12-1.25.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
glibc-common = 2.12-1.25.el6
Updated By: glibc-common-2.15-21.fc18.x86_64 (/glibc-common-2.15-21.fc18.x86_64)
glibc-common = 2.15-21.fc18
Error: Package: glibc-2.12-1.25.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
Requires: glibc-common = 2.12-1.25.el6
Removing: glibc-common-2.12-1.25.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
glibc-common = 2.12-1.25.el6
Updated By: glibc-common-2.15-21.fc18.x86_64 (/glibc-common-2.15-21.fc18.x86_64)
glibc-common = 2.15-21.fc18
Error: Package: glibc-common-2.15-21.fc18.x86_64 (/glibc-common-2.15-21.fc18.x86_64)
Requires: glibc = 2.15-21.fc18
Installed: glibc-2.12-1.25.el6.i686 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
glibc = 2.12-1.25.el6

I tried creating a symlink between /usr/bin and /bin but it still does not work. I do not understand the other dependencies. Can anyone help?
 
Old 06-29-2012, 12:32 PM   #2
lykalagahit
LQ Newbie
 
Registered: Jun 2012
Posts: 4

Rep: Reputation: 0
why don't you ask at linuxquestions.org feel free to ask. there are lots of computer tech out there .

Last edited by Tinkster; 07-02-2012 at 07:03 PM. Reason: linkspam removal and grammar fix
 
Old 06-29-2012, 04:05 PM   #3
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,116

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Warning: Upgrading glibc can be catastrophic for your system. Kernel modules, programs, the whole shebang might break if you upgrade.

Just an FYI.
 
Old 06-29-2012, 06:26 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,990

Rep: Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448
yes i know i am swearing

Why the heck " BLEEP'ed OUT " are you trying to install a fedora 18 ALPHA TESTING ONLY
rpm on RHELL 6.1
they are TWO VERY different operating systems

and it YOU do get it installed
you have just KILLED your paid for RHEL6 install

Quote:
2.15-21.fc18.x86_64
that fc18
IS FOR THE IN TESTING FEDORA18 !!!!!

the current cuda 4 runs just fine on RHEL6.2
i have it right now running on Scientificlinux6.2 64 bit

Last edited by John VV; 06-29-2012 at 06:29 PM.
 
1 members found this post helpful.
Old 06-29-2012, 06:34 PM   #5
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,362

Rep: Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004Reputation: 2004
If you really need glibc-2.15, you could try setting up a virtual machine on your RHEL system, install the alpha F18 on it, use the F18 virtual machine to compile your application with static libraries, then copy it back to the RHEL host and run it.

I've never done this with CUDA applications, but I've done it with other applications that required libraries that weren't available on the host OS.
 
Old 06-30-2012, 08:07 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Quote:
I am trying to run CUDA applications and in order to do that
I need the glut libraries which require the glibc-2.15 dependencies
1) 'glibc' is your OS ( together with the kernel )
and cannot be changed. See post # 4.
( Changing glibc : Your OS will stop working.
Can be solved by reinstalling RHEL 6.x / CentOS 6.2 / SL 6.2 ).

2) glut : a) # yum search glut
b) # yum install freeglut

No RHEL license ? Then migrate to CentOS or Scientific Linux ..
Example : http://wiki.centos.org/HowTos/MigrationGuide

Packages : http://mirror.centos.org/centos/6.2/os/x86_64/Packages/
Updates : http://mirror.centos.org/centos/6.2/...6_64/Packages/

.

Last edited by knudfl; 06-30-2012 at 08:10 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 04:22 PM
RH 9.0 glibc rpm says it needs glibc-common, but glibc-common is installed whitshade Red Hat 2 04-28-2007 06:49 PM
FC6: Installer hangs at installing "glibc-common" mgmax Fedora - Installation 4 02-24-2007 12:40 AM
glibc-common tulip4heaven Linux - General 1 05-11-2005 07:01 AM
ncsd, glibc, and glibc-common conflicts during LAMP install beaker911 Linux - Software 0 12-30-2004 03:31 PM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration