LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2003, 03:36 PM   #16
J_Bone
Member
 
Registered: Aug 2003
Location: Vancouver, Canada
Distribution: Mandrake 9.1
Posts: 59

Original Poster
Rep: Reputation: 15

Uh, I ran through setup again, and when i ran "giftd" this time it did this:

Wrote /home/john/.giFT/ui/ui.conf.
2 module(s) successfully processed.
[john@a3h33829y42al bin]$ giftd
[12:28] *** GIFT-WARNING: deprecated configuration found at /home/john/.giFT/gift.conf: looking for giftd.conf...

It's been searching for 5 minutes; what should I do? I think it's stuck..... how can I safely exit without messing things up ?
 
Old 09-08-2003, 06:29 AM   #17
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
I think it's running OK, actually. giFT has a rather confusing setup process, giftd is a "server" to which you connect "frontends". That architecture is useful, but should generally not be exposed to the user.

Try running gifToxic or something, which is a gtk2 client i've heard good things about.
 
Old 09-08-2003, 02:51 PM   #18
J_Bone
Member
 
Registered: Aug 2003
Location: Vancouver, Canada
Distribution: Mandrake 9.1
Posts: 59

Original Poster
Rep: Reputation: 15
Thanks for the reply mhearn.

I tried downloading mhearn, but I keep getting the problems that are starting to look normal for me and Linux; giFToxic says it needs some files which are in gtk+ 2.0.0, when I try to install that it says it need atk, pango and glib; when i try to install atk it says it needs glib; after I insall glib, it still says it needs glib!!!

Think I'll go take a shower :-(
 
Old 09-08-2003, 04:29 PM   #19
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You should put what distro you are using in your user profile, it helps a lot.

GTK2 is a very common package. If you're using something mainstream, you almost certainly have it available, and all modern distros have dependency resolvers, so it should just be a case of issuing the magic command.
 
Old 09-10-2003, 03:42 AM   #20
J_Bone
Member
 
Registered: Aug 2003
Location: Vancouver, Canada
Distribution: Mandrake 9.1
Posts: 59

Original Poster
Rep: Reputation: 15
Yeah, OK, thanks for the tip,notice the revamped user profile

Here is the error I get when I try to configure giFToxic (the end part of the script):

extern size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
checking for nl_langinfo and CODESET... yes
checking for LC_MESSAGES... yes
checking for bison... no
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for GNU gettext in libc... yes
checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 >= 2.0.3 libgift >= 0.10.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

configure: error: Library requirements (gtk+-2.0 >= 2.0.3 libgift >= 0.10.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[john@a3h33829y42al giFToxic-0.0.9]$

So, that's why I thought I needed gtk+ 2.0, it may just be in the wrong directory

Thanks for the help man
 
Old 09-10-2003, 08:24 AM   #21
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You need gtk2-devel - when compiling from the source, you need not just the package but also the devel package.

I don't know the mandrake name for this package, sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gift problem after installing ICS mike8994 Linux - Newbie 3 11-08-2004 03:01 PM
Installing giFT ?? Seraph Linux - Newbie 1 09-03-2003 05:50 AM
Problem with installing giFT clients - Apollon and Kift eomerek Linux - Software 5 08-30-2003 03:36 PM
Problem Installing, "Gift" LinuZ Linux - Software 6 08-12-2003 03:07 PM
gift fastrack installing problem TweakerFD Linux - Software 4 08-07-2003 08:04 PM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration