LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-30-2004, 04:57 AM   #1
merlinsenger
LQ Newbie
 
Registered: Apr 2004
Location: Hamburg, Germany
Distribution: Fedora Core 2 T2
Posts: 16

Rep: Reputation: 0
Problem installing divx4linux


Hi,

I am quiet new to linux and I hadsome trouble installing the MPlayer (and some codecs) on my Fedora Core 2 Test 2 system. By the way MPlayer Version is "MPlayer-1.0pre4".

The install script of divx4linux copies the files but when calling ldconfig the following messages occur:

Code:
[root@localhost divx4linux-20030428]# ./install.sh
/sbin/ldconfig: Input file /usr/local/lib/libdivxdecore.so not found.
/sbin/ldconfig: Input file /usr/local/lib/libxvidcore.so.4.0 not found.
/sbin/ldconfig: Input file /usr/local/lib/libdivxencore.so not found.
/sbin/ldconfig: Input file /usr/local/lib/libdha.so.0.1 not found.
/sbin/ldconfig: Input file /usr/local/lib/libmp3lame.so.0.0.0 not found.
This is a little strange because those files exist!

Code:
[root@localhost divx4linux-20030428]# ls /usr/local/lib
libdha.so.0.1     libmp3lame.a   libmp3lame.so.0.0.0  mplayer
libdivxdecore.so  libmp3lame.la  libxvidcore.a        netscape
libdivxencore.so  libmp3lame.so  libxvidcore.so.4.0
I compiled the MPlayer anyway (configure, make, make install). When startig it it tells me:

Code:
[root@localhost merlin]# mplayer
mplayer: error while loading shared libraries: 
libdivxdecore.so.0: cannot open shared object file: 
No such file or directory

Any hints are very apreciated!

Last edited by merlinsenger; 04-30-2004 at 05:09 AM.
 
Old 04-30-2004, 08:16 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
This is just a guess, but are the files in /usr/local/lib actually files or links? A quick ls -l should tell you.
 
Old 05-01-2004, 06:23 AM   #3
merlinsenger
LQ Newbie
 
Registered: Apr 2004
Location: Hamburg, Germany
Distribution: Fedora Core 2 T2
Posts: 16

Original Poster
Rep: Reputation: 0
Hi Hangdog,

"ls" tells me:

Code:
[merlin@localhost merlin]$ ls -l /usr/local/lib
insgesamt 3176
-rwxr-xr-x  1 root root 224316 29. Apr 20:52 libdha.so.0.1
-rwxr-xr-x  1 root root 402584 30. Apr 10:50 libdivxdecore.so
-rwxr-xr-x  1 root root 865336 30. Apr 10:50 libdivxencore.so
-rw-r--r--  1 root root 372578 29. Apr 19:33 libmp3lame.a
-rwxr-xr-x  1 root root    804 29. Apr 19:33 libmp3lame.la
lrwxrwxrwx  1 root root     19 29. Apr 19:33 libmp3lame.so -> libmp3lame.so.0.0. 0
-rwxr-xr-x  1 root root 337127 29. Apr 19:33 libmp3lame.so.0.0.0
-rwxr-xr-x  1 root root 502688 29. Apr 21:42 libxvidcore.a
-rwxr-xr-x  1 root root 450510 29. Apr 21:42 libxvidcore.so.4.0
drwxr-xr-x  3 root root   4096 29. Apr 20:57 mplayer
drwxr-xr-x  2 root root   4096 29. Apr 19:49 netscape
Seems to me that there is only one link (to an existig file), right? As I said I am really quiet new to linux...
 
Old 05-01-2004, 02:49 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Hm. OK, how are you logged in when you run install.sh? Do you log in as root or do you log in as a normal user and then use su to be root? The reason I'm asking is if you use su, there can sometimes be a difference in behavior between su and su -

I usually use su - since I think that read's root's PATH and su doesn't.


The other thing to check is that the /usr/local/lib is in your /etc/ld.so.conf file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing module in Fedora Core 2 (2.6 kernel vs 2.4 problem?) Arodef Linux - Kernel 3 11-30-2007 03:55 PM
Problem installing new programs... KDE problem? seiyachan Mandriva 33 12-19-2005 10:18 AM
problem installing-hardware problem? LivinLarge Linux - General 3 04-28-2005 02:56 PM
Problem Installing Gentoo. (Partioning Problem) w33k Linux - Software 7 08-10-2004 11:06 PM
divx4linux clowns119 Linux - Software 5 07-27-2003 08:49 AM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration