LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2014, 05:56 AM   #1
zeeshanayub
Member
 
Registered: Jan 2014
Posts: 59

Rep: Reputation: Disabled
problem install the flash player


help me
ubuntu 12.04
install the flash player
error:
root@dabia-OptiPlex-745:~# apt-get install flash player
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package flash
E: Unable to locate package player
 
Old 02-15-2014, 05:59 AM   #2
nigelc
Member
 
Registered: Oct 2004
Location: Sydney, Australia
Distribution: Mageia 4
Posts: 347
Blog Entries: 4

Rep: Reputation: 63
This is what google says:

http://www.wikihow.com/Install-Flash-Player-on-Ubuntu
 
Old 02-15-2014, 06:42 AM   #3
zeeshanayub
Member
 
Registered: Jan 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
1-Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.


The following packages have unmet dependencies:
flashplugin-installer:
2-root@dabia-OptiPlex-745:/home/dabia# sudo apt-get install flashplugin-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
flashplugin-installer : Depends: libnss3-1d but it is not going to be installed
Depends: libnspr4-0d but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@dabia-OptiPlex-745:/home/dabia#


kindly solve
 
Old 02-15-2014, 10:13 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
The following packages have unmet dependencies:
flashplugin-installer : Depends: libnss3-1d but it is not going to be installed
Depends: libnspr4-0d but it is not going to be installed
Have you tried installing the libnss3-1d package as suggested?
jdk
 
Old 02-15-2014, 11:16 PM   #5
zeeshanayub
Member
 
Registered: Jan 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
install the libnss3-1d package but error display


Package dependencies cannot be resolved


The following packages have unmet dependencies:

libnss3-1d: Depends: libnss3 (= 3.13.1.with.ckbi.1.88-1ubuntu6) but 3.15.3.1-0ubuntu0.12.04.1 is to be installed
 
Old 02-16-2014, 12:26 AM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,470
Blog Entries: 10

Rep: Reputation: Disabled
This might help-

http://packages.ubuntu.com/precise-updates/libnss3-1d

Installing that unmet dependency (libnss3-1d) like jdkaye is asking you about is the way to go.

If it helps that pkg is in Synaptic Package Manager if your having trouble installin it.
Here it is on my system-
http://s1052.photobucket.com/user/Ul...ss3-d.png.html
 
Old 02-16-2014, 01:03 AM   #7
zeeshanayub
Member
 
Registered: Jan 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
thank Ztcoracat but problem libnss3 install

install the libnss3 but error in display on the screen

use command:
root@dabia-OptiPlex-745:~# apt-get install libnss3-1d_3.15.4-0ubuntu0.12.04.1_i386.deb
display error:
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?




libnss3 open the software center but error
Dependency is not satisfiable: libnss3 (=3.15.4-0ubuntu0.12.04.1)




Synaptic Package Manager show the libnss3 same you link
http://s1052.photobucket.com/user/Ul...ss3-d.png.html
but install the libnss3 problem

Last edited by zeeshanayub; 02-16-2014 at 01:08 AM.
 
Old 02-16-2014, 04:03 AM   #8
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,753

Rep: Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933
Quote:
Originally Posted by zeeshanayub View Post
E: Unable to correct problems, you have held broken packages.
apt-get install -f

If that doesnt work, try using-

apt-get update
apt-get clean
apt-get autoclean
apt-get autoremove

then run 'apt-get install -f' again.

Oh, yeah, because its *buntu you'll need to put 'sudo' before every command. Or use one of the workaround tricks.
 
Old 02-16-2014, 05:18 AM   #9
zeeshanayub
Member
 
Registered: Jan 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
not install of the use apt-get install -f and sudo apt-get install -f command
but error
root@dabia-OptiPlex-745:/home/dabia# sudo apt-get install -f install_flash_player_11_linux.i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package install_flash_player_11_linux.i386
E: Couldn't find any package by regex 'install_flash_player_11_linux.i386'


and

how to hide files and folders in ubuntu 12.04
 
Old 02-16-2014, 05:23 AM   #10
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,753

Rep: Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933
No, not 'sudo apt-get install -f install_flash_player_11_linux.i386', just 'sudo apt-get install -f'.

If you have broken packages, it stuffs apt/aptitude so you need to fix it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install flash player 11.1 zoedooner Linux - Newbie 2 10-19-2013 11:05 PM
Problem w/IE4 Linux-can't install flash player. Forrest Charnock Linux - Newbie 1 10-15-2009 03:35 AM
flash player to install giraf Ubuntu 4 08-18-2009 08:16 AM
How to install flash player shariefbe Linux - Software 5 04-09-2009 05:57 AM
Can't install Flash Player redriverd Linux - Newbie 9 10-18-2008 08:32 PM


All times are GMT -5. The time now is 12:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration