LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2008, 01:38 AM   #1
vikram8jp
LQ Newbie
 
Registered: Oct 2008
Location: Tokyo
Distribution: CentOS
Posts: 27

Rep: Reputation: 15
Problem in setting ftp on CentOS 4.6


Hello all,
I just started with CentOS and Linux two days ago. I need to setup a ftp host on my server. I have read the Wikis HowTos about vsftpd. I installed the package vsftpd. I am done editing vsftpd.conf file. I started the vsftpd service on boot. But still my FTP client(FFFTP) does not connect to my server (in PASV mode), when I provide with the host IP address. Can anybody help me out?

I did all this from root. Has there got to be some setting made from the account <username> I am writing in user_list file, eg. "vikram" in this case. It is a VNC account name.

Here's my vsftpd.conf content

Code:
# Example config file /etc/vsftpd/vsftpd.conf
listen=YES
tcp_wrappers=YES
use_localtime=YES
listen_port=21
listen_address=192.168.1.12
background=YES
ftpd_banner=Welcome to Test FTP Server
check_shell=NO
anonymous_enable=NO
no_anon_password=NO
guest_enable=NO
ascii_download_enable=YES
ascii_upload_enable=YES
chmod_enable=YES
local_root=/var/ftp/html
local_umask=022
chroot_list_enable=YES
chroot_local_user=YES
chroot_list_file=/etc/csftpd/vsftpd.chroot_list
pam_service_name=vsftpd
connect_from_port_20=NO
ftp_data_port=20
dirlist_enable=YES
dirmessage_enable=YES
message_file=.message
download_enable=YES
force_dot_files=YES
hide_ids=YES
local_enable=YES
ls_recurse_enable=NO
pasv_enable=YES
pasv_min_port=33201
pasv_max_port=33210
setproctitle_enable=YES
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd/vsftpd.user_list
write_enable=YES
xferlog_enable=YES
xferlog_std_format=YES
data_connection_timeout=300
idle_session_timeout=600
accept_timeout=60
file_open_mode=0460
max_clients=5
max_per_ip=2
Here is my /etc/vsftpd/user_list file.
Code:
vikram
Thanks for any help
Vik

Last edited by vikram8jp; 10-16-2008 at 01:57 AM. Reason: Previous one was not complete
 
Old 10-16-2008, 02:51 AM   #2
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,036

Rep: Reputation: 96
Are you running a firewall on this machine?
 
Old 10-16-2008, 03:35 AM   #3
vikram8jp
LQ Newbie
 
Registered: Oct 2008
Location: Tokyo
Distribution: CentOS
Posts: 27

Original Poster
Rep: Reputation: 15
Hey there

I checked in my System Settings > Security Level. Firewall is there but only on HTTP. not on FTP.
 
Old 10-16-2008, 02:36 PM   #4
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,036

Rep: Reputation: 96
Do you mean that only HTTP is selected as a trusted service?

If so, you need to add FTP to the list of trusted services and apply changes.
 
Old 10-16-2008, 02:56 PM   #5
DotHQ
Member
 
Registered: Mar 2006
Location: Ohio, USA
Distribution: Red Hat, Fedora, Knoppix,
Posts: 542

Rep: Reputation: 33
If you use putty/ssh to get to the server you might try an FTP alternative called WinSCP It's available for free to download and secure ....and much like FTP only everything is encrypted.
 
Old 10-16-2008, 04:35 PM   #6
arashi256
Member
 
Registered: Jan 2008
Location: Brighton, UK
Distribution: Ubuntu 12.04 / CentOS 6.5
Posts: 394

Rep: Reputation: 61
Quote:
Originally Posted by vikram8jp View Post
Hello all,
I just started with CentOS and Linux two days ago. I need to setup a ftp host on my server. I have read the Wikis HowTos about vsftpd. I installed the package vsftpd. I am done editing vsftpd.conf file. I started the vsftpd service on boot. But still my FTP client(FFFTP) does not connect to my server (in PASV mode), when I provide with the host IP address. Can anybody help me out?

I did all this from root. Has there got to be some setting made from the account <username> I am writing in user_list file, eg. "vikram" in this case. It is a VNC account name.

Here's my vsftpd.conf content

Code:
# Example config file /etc/vsftpd/vsftpd.conf
listen=YES
tcp_wrappers=YES
use_localtime=YES
listen_port=21
listen_address=192.168.1.12
background=YES
ftpd_banner=Welcome to Test FTP Server
check_shell=NO
anonymous_enable=NO
no_anon_password=NO
guest_enable=NO
ascii_download_enable=YES
ascii_upload_enable=YES
chmod_enable=YES
local_root=/var/ftp/html
local_umask=022
chroot_list_enable=YES
chroot_local_user=YES
chroot_list_file=/etc/csftpd/vsftpd.chroot_list
pam_service_name=vsftpd
connect_from_port_20=NO
ftp_data_port=20
dirlist_enable=YES
dirmessage_enable=YES
message_file=.message
download_enable=YES
force_dot_files=YES
hide_ids=YES
local_enable=YES
ls_recurse_enable=NO
pasv_enable=YES
pasv_min_port=33201
pasv_max_port=33210
setproctitle_enable=YES
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd/vsftpd.user_list
write_enable=YES
xferlog_enable=YES
xferlog_std_format=YES
data_connection_timeout=300
idle_session_timeout=600
accept_timeout=60
file_open_mode=0460
max_clients=5
max_per_ip=2
Here is my /etc/vsftpd/user_list file.
Code:
vikram
Thanks for any help
Vik
I've done this just fine on a Fedora 9 distro, which is essentially a RedHat-based system (we use all favours at work), so I can probably fix this if you've not already. Problem is, I'm drunk right now - PM me tomorrow if you're still stuck.
 
Old 10-16-2008, 10:37 PM   #7
vikram8jp
LQ Newbie
 
Registered: Oct 2008
Location: Tokyo
Distribution: CentOS
Posts: 27

Original Poster
Rep: Reputation: 15
Thumbs up Problem in setting ftp on CentOS 4.6 - SOLVED

Thanks a lot all of u. Thanks for your time. I have solved this problem now. The problem was the port 20 and 21 were not open in the iptables.
I opened the ports and it worked.

Regards
Vik
 
  


Reply

Tags
vsftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to setup ftp server in centos 5.0 melvinong Linux - Server 15 06-18-2012 01:55 AM
HELP! FTP server setting up. HD patitioning problem. gavin2u Linux - Server 2 01-02-2008 02:27 AM
setting up repositories for centos jCash Linux - Newbie 3 11-26-2007 06:17 PM
Keyboard Setting on CentOS viky Linux - Hardware 2 09-18-2007 03:50 AM
centos - firewall up - ftp no permissions sir-lancealot! Linux - Security 7 08-31-2006 05:40 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration