LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-05-2013, 07:38 AM   #1
roshani
LQ Newbie
 
Registered: Mar 2013
Posts: 2

Rep: Reputation: Disabled
problem in running parallel program in c


I have made a cluster of 4 nodes on centos5.9. i m using openmpi-1.6.3 and installed gcc-4.1.2-54. when i trying to run a simple hello program, i m getting the following error. plz help me with this.

[roshani@localhost gcc-4.1.2]$ mpicc hello.c -o hello
[roshani@localhost gcc-4.1.2]$ mpirun -np 4 hello
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.

i have also set the library path with the command

[roshani@localhost gcc-4.1.2]$ env LD_LIBRARY_PATH=/usr/cluster/openmpi/openmpi-1.6.3/omp/contrib/vt/vt/tools/opari
SSH_AGENT_PID=3802
HOSTNAME=localhost.localdomain
DESKTOP_STARTUP_ID=
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
KDE_NO_IPV6=1
GTK_RC_FILES=/etc/gtk/gtkrc:/home/roshani/.gtkrc-1.2-gnome2
WINDOWID=23092073
USER=roshani
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi= 01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00 ;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz =00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;3 5:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
GNOME_KEYRING_SOCKET=/tmp/keyring-RkVmfH/socket
SSH_AUTH_SOCK=/tmp/ssh-nctHEd3766/agent.3766
KDEDIR=/usr
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/3766
USERNAME=roshani
MAIL=/var/spool/mail/roshani
PATH=/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/roshani/bin
DESKTOP_SESSION=default
GDM_XSERVER_LOCATION=local
INPUTRC=/etc/inputrc
PWD=/usr/gcc-4.1.2
XMODIFIERS=@im=none
KDE_IS_PRELINKED=1
LANG=en_US.UTF-8
GDMSESSION=default
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SHLVL=2
HOME=/home/roshani
GNOME_DESKTOP_SESSION_ID=Default
LOGNAME=roshani
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-f1MZkwsCzP,guid=1cc51852d6cd9d6dd43a26005135d488
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=:0.0
G_BROKEN_FILENAMES=1
COLORTERM=gnome-terminal
XAUTHORITY=/tmp/.gdmIOYNTW
_=/usr/bin/env
OLDPWD=/usr
LD_LIBRARY_PATH=/usr/cluster/openmpi/openmpi-1.6.3/omp/contrib/vt/vt/tools/opari

Last edited by roshani; 03-05-2013 at 07:40 AM.
 
Old 03-05-2013, 07:39 AM   #2
roshani
LQ Newbie
 
Registered: Mar 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
I have made of 4 nodes on centos5.9. i m using openmpi-1.6.3 and installed gcc-4.1.2-54. when i trying to run a simple hello program, i m getting the following error. plz help me with this.

[roshani@localhost gcc-4.1.2]$ mpicc hello.c -o hello
[roshani@localhost gcc-4.1.2]$ mpirun -np 4 hello
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
hello: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory
--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.

i have also set the library path with the command

[roshani@localhost gcc-4.1.2]$ env LD_LIBRARY_PATH=/usr/cluster/openmpi/openmpi-1.6.3/omp/contrib/vt/vt/tools/opari
SSH_AGENT_PID=3802
HOSTNAME=localhost.localdomain
DESKTOP_STARTUP_ID=
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
KDE_NO_IPV6=1
GTK_RC_FILES=/etc/gtk/gtkrc:/home/roshani/.gtkrc-1.2-gnome2
WINDOWID=23092073
USER=roshani
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi= 01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00 ;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz =00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;3 5:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
GNOME_KEYRING_SOCKET=/tmp/keyring-RkVmfH/socket
SSH_AUTH_SOCK=/tmp/ssh-nctHEd3766/agent.3766
KDEDIR=/usr
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/3766
USERNAME=roshani
MAIL=/var/spool/mail/roshani
PATH=/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/roshani/bin
DESKTOP_SESSION=default
GDM_XSERVER_LOCATION=local
INPUTRC=/etc/inputrc
PWD=/usr/gcc-4.1.2
XMODIFIERS=@im=none
KDE_IS_PRELINKED=1
LANG=en_US.UTF-8
GDMSESSION=default
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SHLVL=2
HOME=/home/roshani
GNOME_DESKTOP_SESSION_ID=Default
LOGNAME=roshani
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-f1MZkwsCzP,guid=1cc51852d6cd9d6dd43a26005135d488
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=:0.0
G_BROKEN_FILENAMES=1
COLORTERM=gnome-terminal
XAUTHORITY=/tmp/.gdmIOYNTW
_=/usr/bin/env
OLDPWD=/usr
LD_LIBRARY_PATH=/usr/cluster/openmpi/openmpi-1.6.3/omp/contrib/vt/vt/tools/opari[/QUOTE]
 
Old 03-05-2013, 08:48 AM   #3
Rumata
LQ Newbie
 
Registered: Feb 2013
Location: USSR
Distribution: gentoo
Posts: 15

Rep: Reputation: 0
is libmpi so in the path?
 
Old 03-05-2013, 09:15 AM   #4
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 1,881

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
give more information, eg:

Code:
ldd ./hello
/sbin/ldconfig -v | grep mpi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem when running simple c program ryellamr Linux - Newbie 3 06-06-2009 03:38 PM
Problem with Running a Program linux_2007_ Linux - General 1 05-21-2007 08:06 PM
Having Problem with Running a Program in RH linux 8.0 cheenaik Linux - Software 18 06-03-2006 08:41 AM
Problem in a Parallel program for a 4 node CLUSTER nedian123 Linux - Networking 1 07-22-2004 04:05 AM
problem running program as user FlAWD Linux - General 1 10-15-2003 08:31 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration