LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2002, 09:31 PM   #1
pimo
LQ Newbie
 
Registered: Mar 2002
Posts: 7

Rep: Reputation: 0
Question problem in mounting HD & boot to win xp


I'm having a big trouble....

I'm using mandrake 8.1

I can't mount my /dev/hda1 (which contain my win xp)
when i want to mount it says :
"wrong fs type, bad option, bad superblock on /dev/hda1 or too many mounted file system"
can anybody PLEASE HELP me.......

and I still can't boot to win xp through LILO ...
there is always printed "01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01......" on the screen when I want to boot to win xp

is this caused by the unmounted of hda1 or there is another thing caused this... ????

THANX VERY MUCH for the HELP .....

=)
 
Old 03-15-2002, 11:59 PM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
How is your win xp partition formatted? Is it fat32 or ntfs? If it's ntfs, that's going to be a problem.
 
Old 03-16-2002, 02:37 AM   #3
pimo
LQ Newbie
 
Registered: Mar 2002
Posts: 7

Original Poster
Rep: Reputation: 0
i formatted my win xp as FAT32

and i can't mount my win xp partition (which is /dev/hda1)

but i can mount the other partition which doesn't have any OS (/dev/hda6)

can u help me???
 
Old 03-16-2002, 03:55 AM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
As root in a terminal window or a console screen, run this command
mount -t vfat /dev/hda1 /mnt/windows. But first make sure the directory /mnt/windows exists. Do a ls /mnt and see if the windows directory is there. If it isn't, run mkdir /mnt/windows. Then run the command and see if it will mount it.
 
Old 03-16-2002, 07:09 AM   #5
pimo
LQ Newbie
 
Registered: Mar 2002
Posts: 7

Original Poster
Rep: Reputation: 0
i've check it and the directory /mnt/windows was exist
but still i can't mount my /dev/hda1

what is going on ??

i still can't boot to my win xp, while i need to boot to win xp .....
 
Old 03-16-2002, 02:17 PM   #6
chrislip
LQ Newbie
 
Registered: Sep 2001
Location: Notts, UK
Distribution: Red Hat
Posts: 10

Rep: Reputation: 0
Have you got support for Fat32 in your kernel? AFAIK it is NOT compiled into the kernel in a standard build. Have you tried recompiling your kernel?
 
Old 03-16-2002, 11:41 PM   #7
pimo
LQ Newbie
 
Registered: Mar 2002
Posts: 7

Original Poster
Rep: Reputation: 0
i don't know anything about the kernel
but from mandrake i can read my /dev/hda6 which is formatted as FAT32.

maybe there's an error in my /dev/hda1 cause fdisk can't recognize what kind of partition that i use for /dev/hda1 just like they don't recognize the ext3 file system while the fdisk can detect my /dev/hda6

so i format my drive c and install a new win xp

now i want to boot mandrake 8.1 from floppy(i have made it).
can i do that ??
i mean without the installation of LILO into the MBR. (so everytime i want to boot to mandrake i use the boot disk and when i want to boot to win xp i just run the computer normally)
is it possible to do that ??
what is the command ??

i've tried also to use boot magic 7.0 but the screen freeze after i choose to boot to win xp. it says "preparing the machine to boot....." and it freeze.
what is the problem with that ??

wow i asked so many question cause it's my first time to use linux and double boot.

i hope u will help me

thanx
 
Old 03-17-2002, 10:11 PM   #8
pimo
LQ Newbie
 
Registered: Mar 2002
Posts: 7

Original Poster
Rep: Reputation: 0
.............
finally i made it to boot to mandrake and win xp
i made boot disk to mandrake and install my LILO there

Thanx alot for all of your help.......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot Linspire & Win XP - new master boot record? jimbo5454 Linux - Newbie 5 07-23-2006 01:06 AM
Triple boot problem Win XP,FC1 & FC3 Joe47 Fedora 1 12-21-2004 03:21 AM
Win Xp & Fedora Core 2 dual boot Problem jonfa Linux - General 1 10-02-2004 05:28 PM
Problem mounting Win XP partition with samba Aneb Linux - Software 2 03-09-2004 09:25 AM
Win Xp & Win 2000 & Mandrake 9.1 (ntoskrnl missing for xp) mcbaboon Linux - Newbie 8 10-14-2003 10:34 AM


All times are GMT -5. The time now is 04:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration