LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-24-2006, 11:58 AM   #1
yumener
Member
 
Registered: Oct 2005
Posts: 63

Rep: Reputation: 15
problem in mounting ext3 as rw to non-root users


I want to mount /dev/hdb2 to /mnt/d_lin as rw to non-root users

I tried the following three options

A:
#/dev/hdb2 /mnt/d_lin ext3 gid=100,umask=002,noexec,nosuid 0 0

B:
#/dev/hdb2 /mnt/d_lin ext3 defaults 2 0

C:
/dev/hdb2 /mnt/d_lin ext3 defaults,user,rw,umask=002,gid=100,auto 0 0

only B works, but I do not have write permission.
A,C do not work, errors are
EXT3-fs: Unrecognized mount option "umask=000" or missing value
kjournald starting. Commit interval 5 seconds
EXT3 FS on hdb2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3-fs: Unrecognized mount option "gid=100" or missing value
kjournald starting. Commit interval 5 seconds
EXT3 FS on hdb2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3-fs: Unrecognized mount option "umask=002" or missing value
EXT3-fs: Unrecognized mount option "umask=002" or missing value

I have change /mnt/d_lin to 777 mode.

any idea?

Thanks.
 
Old 03-24-2006, 01:04 PM   #2
jaykup
Member
 
Registered: Jan 2006
Location: Mukwonago, WI
Distribution: Slackware 12
Posts: 77

Rep: Reputation: 16
Your umask should look more like

umask=0222 to enable non-root users to use that.
 
Old 03-24-2006, 01:11 PM   #3
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
/dev/hdb2 /mnt/d_lin ext3 noauto,users,rw,exec,suid,dev 0 0

noauto - it needs to be (and can be ) manually mounted and unmounted
users - every user can do it
rw - mounted read/write
exec,dev,suid - if these are not given, mount sets the default options as: rw,noexec,nosuid,nodev

Last edited by jomen; 03-24-2006 at 01:13 PM. Reason: typo fixed and layout changed
 
Old 03-26-2006, 04:19 AM   #4
yumener
Member
 
Registered: Oct 2005
Posts: 63

Original Poster
Rep: Reputation: 15
Thanks for your detailed explanation, but i tried it,
I can mount/umount it as non-root user but I still
do not have writing permission.

Quote:
Originally Posted by jomen
/dev/hdb2 /mnt/d_lin ext3 noauto,users,rw,exec,suid,dev 0 0

noauto - it needs to be (and can be ) manually mounted and unmounted
users - every user can do it
rw - mounted read/write
exec,dev,suid - if these are not given, mount sets the default options as: rw,noexec,nosuid,nodev
 
Old 03-26-2006, 04:22 AM   #5
yumener
Member
 
Registered: Oct 2005
Posts: 63

Original Poster
Rep: Reputation: 15
the similar error happens.

kjournald starting. Commit interval 5 seconds
EXT3 FS on hdb2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
EXT3-fs: Unrecognized mount option "umask=0222" or missing value



Quote:
Originally Posted by jaykup
Your umask should look more like

umask=0222 to enable non-root users to use that.
 
Old 03-26-2006, 04:43 AM   #6
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
Option B is the only one that should work of the three you have listed because ext3 does not support the umask option. Once you have the drive mounted using option B, does it work if you create a sub-directory under /mnt/d_lin, for example /mnt/d_lin/data and give it permissions for a user. For example:
Code:
# mount -t ext3 /dev/hdb2 /mnt/d_lin && mkdir /mnt/d_lin/data && chown -Rc username:groupname /mnt/d_lin/data
 
Old 04-13-2006, 03:18 PM   #7
BenODen
LQ Newbie
 
Registered: Oct 2004
Location: Colorado
Distribution: Fedora Core 2, Red Hat
Posts: 18

Rep: Reputation: 0
I am having the same problem, and yes, I can create a subdirectory and change those permissions. I mount the drive with the following fstab entry:
Code:
/dev/hdb6               /scratch                ext3    user,exec            0 2
However, it seems like there should be an option to change the permissions of the filesystem base to something besides 700 (/scratch in my case). / and /boot are mounted as 0755 but the secondary ext3 partition I created gets mounted 0700.

Update: Oh oh, I got it! Hmmf, I tried that before. I was able to do
Code:
# chmod 777 /scratch
and the permissions changed. Seems to persist if you umount then mount the drive again, so I guess this is the solution. Coulda sworn I tried that first time out of the gate.

Last edited by BenODen; 04-13-2006 at 03:32 PM. Reason: Clear things up, this seems to be the answer to the original question.
 
  


Reply

Tags
ext3, mount, permissions


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting a fat drive for non-root users sadarax Linux - Hardware 2 05-17-2006 03:51 AM
RHEL3 Mounting USB after reboot and between reboots: root and non-root users Luis Nunes Linux - Hardware 0 07-20-2005 09:32 AM
Mounting ext3 partition with rw permissions for non-root user ilyushin Linux - Newbie 5 06-27-2005 08:58 AM
Mounting NTFS for users other than root Tarwedge Slackware 19 05-20-2004 03:59 PM
users other than root mounting drives general4172 Linux - Hardware 2 09-23-2003 09:02 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration