LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-29-2010, 03:45 AM   #1
godegisel
LQ Newbie
 
Registered: Nov 2010
Posts: 5

Rep: Reputation: 0
Question Problem in kernel updating from 2.4 to 2.6


I got a HP LH 3000.Current OS release is RH9 2.4.20,and I wanna update it to RH9 2.6.5 While updating,I met the problem followed:
VFS:Cannot open root device "hdxy" or unknow-block(0,0)
Followed are packages I used:
device-mapper-1.00.19-2.i386.rpm
linux-2.6.5.tar.bz2
mkinitrd-4.1.18-2.i386.rpm
lvm2-2.00.25-1.01.i386.rpm
module-init-tools-3.2.tar.bz2
Is there something wrong with my packages?
First I installed the mkinitrd-4.1.18-2.i386.rpm, then compiled the kernel and installed it.Generally speaking,how to solve this problem and what should I pay attention to during update?



Big thanks,
godegisel
 
Old 11-29-2010, 04:31 AM   #2
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 672

Rep: Reputation: 94
Try this: Don't use labels in fstab and use actual dev files for root disk entry (/dev/hda)
 
Old 11-29-2010, 06:58 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
May I ask why you run such an outdated OS?
 
Old 11-29-2010, 09:24 AM   #4
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by godegisel View Post
I got a HP LH 3000.Current OS release is RH9 2.4.20,and I wanna update it to RH9 2.6.5 While updating,I met the problem followed:
VFS:Cannot open root device "hdxy" or unknow-block(0,0)
Followed are packages I used:
device-mapper-1.00.19-2.i386.rpm
linux-2.6.5.tar.bz2
mkinitrd-4.1.18-2.i386.rpm
lvm2-2.00.25-1.01.i386.rpm
module-init-tools-3.2.tar.bz2
Is there something wrong with my packages?
First I installed the mkinitrd-4.1.18-2.i386.rpm, then compiled the kernel and installed it.Generally speaking,how to solve this problem and what should I pay attention to during update?
Big thanks,
godegisel
http://www.redhat.com/support/resour...ernel-upgrade/
 
Old 11-29-2010, 10:07 AM   #5
godegisel
LQ Newbie
 
Registered: Nov 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Question

Quote:
Originally Posted by TobiSGD View Post
May I ask why you run such an outdated OS?
When I got the mechine it already ran this OS,with a broken cd-rom,it`s not that easy to install a new system on it. In addition,I use it just for study,so I just tried to update it so that I can try running db2 the next step.I tried again today.I`m doubting whether the HP LH 3000 can support the new OS.


Kind Regards,
godegisel
 
Old 11-29-2010, 10:23 AM   #6
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
A PIII 500 or greater will run virtually any version of Linux. Ram is probably the only real concern, 512Mb is a realistic minium for most current distros. Ram for these machines is very cheap and if you ask nicely you can often get it for free from many sources(social networking). While RHEL(Red Hat Enterprise Linux) charges to get access to their repos(and for other support), Centos(a RHEL clone built from RHEL source rpms) is free(no $).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem after updating the kernel... sou.1234321 Linux - Hardware 1 09-28-2007 12:27 PM
Problem updating kernel... again DirkDiggler Linux - Software 5 05-30-2007 04:13 PM
Problem updating iptables, with 2.6.16 kernel. RavenOfOdin Linux - Kernel 9 06-02-2006 05:01 PM
problem updating kernel jsownz Fedora 13 04-14-2006 12:21 PM
problem updating kernel praveen_2003 Linux - Software 1 04-15-2003 07:02 AM


All times are GMT -5. The time now is 08:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration