LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2010, 11:45 PM   #1
neeraj.dwivedi
LQ Newbie
 
Registered: Sep 2009
Posts: 27

Rep: Reputation: 15
problem in installing "xgraph 12.1" in ubuntu 9.1 for ns 2.34


i have following problem in installing xgraph...

neeraj@ubuntu:~/ns-allinone-2.34/xgraph-12.1$ make
gcc -DHAVE_CONFIG_H -I. -I. -I. -g -c xgraph.c
xgraph.c: In function ‘Traverse’:
xgraph.c:460: warning: format not a string literal and no format arguments
xgraph.c:472: warning: format not a string literal and no format arguments
gcc -DHAVE_CONFIG_H -I. -I. -I. -g -c xgX.c
gcc -DHAVE_CONFIG_H -I. -I. -I. -g -c hard_devices.c
gcc -DHAVE_CONFIG_H -I. -I. -I. -g -c dialog.c
dialog.c: In function ‘make_msg_box’:
dialog.c:780: warning: passing argument 2 of ‘getline’ from incompatible pointer type
/usr/include/stdio.h:651: note: expected ‘size_t * __restrict__’ but argument is of type ‘char *’
dialog.c:780: error: too few arguments to function ‘getline’
dialog.c: In function ‘getline’:
dialog.c:899: error: argument ‘lptr’ doesn’t match prototype
/usr/include/stdio.h:651: error: prototype declaration
dialog.c:899: error: number of arguments doesn’t match prototype
/usr/include/stdio.h:651: error: prototype declaration
make: *** [dialog.o] Error 1
 
Old 02-23-2010, 02:34 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Xgraph is not considered important, that's why " ./install "
just ignores it by errors. ( xgraph files = 9 years old.)
It may be possible to compile it, by using the Ubuntu patch ?
http://packages.ubuntu.com/karmic/xgraph
[xgraph_12.1-11.diff.gz]

But much easier is :

sudo apt-get install xgraph ygraph

'ygraph' is a modern, more advanced tool ..
http://packages.ubuntu.com/karmic/ygraph
.....

Last edited by knudfl; 02-23-2010 at 02:23 PM.
 
1 members found this post helpful.
Old 02-23-2010, 10:10 AM   #3
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
use gnuplot, instead of xgraph. gnuplot works fine.
 
1 members found this post helpful.
Old 02-25-2010, 06:12 AM   #4
neeraj.dwivedi
LQ Newbie
 
Registered: Sep 2009
Posts: 27

Original Poster
Rep: Reputation: 15
problem in DSR ....

When i run AODV tcl script aodv.tcl then it runs quite successfully , it draws xgraph for packet drop and packet received as well , but when i run DSR script dsr.tcl then it will just run nam editor but not draws the xgraph b/w the same.

now when i use aodv code with change in one line that is :

"set val(rp) dsr" in place of "set val(rp) AODV" which is routing protocol

then again this does not draw that graph.

which means ... as i conclude problem is not in my code , problem is with the implementation of DSR routing protocol.

now anyone can help me out with that problem.???
 
Old 03-02-2010, 07:18 PM   #5
neeraj.dwivedi
LQ Newbie
 
Registered: Sep 2009
Posts: 27

Original Poster
Rep: Reputation: 15
Anyone is there to help me out ???
 
Old 03-10-2010, 09:01 AM   #6
ashwinn89
LQ Newbie
 
Registered: Mar 2010
Posts: 1

Rep: Reputation: 2
@neeraj.dwivedi

I doubt my rather late reply would help your cause. In any case, here's a solution to your problem.

On line numbers 780 and 899 of dialog.c, change getline to something else (say, newgetline) and try compiling again. It should work.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing vpn client on Ubuntu: Failed to make module "cisco_ipsec.ko" challysand Linux - Newbie 1 08-29-2009 03:12 PM
intrepid, PS3, update sources list from "ubuntu" to "ports-ubuntu" evdv Linux - Newbie 7 08-18-2009 11:52 AM
how to use "xgraph" in the scripts shells with ns2.33 in fc9 messy2010 Fedora 1 01-21-2009 04:56 AM
Installing ubuntu 6.06 LTS on vista machine gets stuck :"Installing Hardware drivers" anksphenomenon Linux - Newbie 1 12-16-2007 02:57 PM
The problem about "cairo" in installing of "GTK" :( zhuqlfeixia Linux - Hardware 1 01-28-2006 04:12 PM


All times are GMT -5. The time now is 02:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration