LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem in installing Broadcom wireless card in Lenovo G565 (http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-installing-broadcom-wireless-card-in-lenovo-g565-897816/)

theashishmishra 08-17-2011 07:34 AM

Problem in installing Broadcom wireless card in Lenovo G565
 
Hi
I am new to Fedora..just installed it yesterday and today when I was trying to install wireless card for my Lenovo 565 with the help of ndiswrapper,I was unable to go beyond this as I don't know what to do after getting this message...
[abhijeet@Illuminati Win7_32]$ sudo iwconfig
lo no wireless extensions.

p4p1 no wireless extensions.

usb0 no wireless extensions.

please help me out..thanks..
Oh..BTW my wireless card is Broadcom BCM4313 :)

sycamorex 08-17-2011 07:37 AM

Is there any particular tutorial that you've been following?
What wifi card have you got?
Can you post the output of lspci (if it's an internal PCI card) or lsusb (if it's a usb network card)?

theashishmishra 08-17-2011 07:43 AM

I was following mixed threads,not a particular thread..can't post the previous outputs as I have closed that terminal on which I was working initially but I can post this message when I was trying to repeat the installation process again
[abhijeet@Illuminati Win7_32]$ sudo ndiswrapper -i bcmwl6.inf
[sudo] password for abhijeet:
driver bcmwl6 is already installed
[abhijeet@Illuminati Win7_32]$ sudo ndiswrapper -l
bcmwl6 : driver installed
device (14E4:4727) present (alternate driver: bcma)
[abhijeet@Illuminati Win7_32]$ sudo modprobe ndiswrapper
[abhijeet@Illuminati Win7_32]$ sudi iwconfig
bash: sudi: command not found...
Similar command is: 'sudo'
[abhijeet@Illuminati Win7_32]$ sudo iwconfig
lo no wireless extensions.

p4p1 no wireless extensions.

usb0 no wireless extensions.

[abhijeet@Illuminati Win7_32]$ sudo ndiswrapper -m
[sudo] password for abhijeet:
module configuration already contains alias directive

[abhijeet@Illuminati Win7_32]$ lspci |
>

what after this :-(

sycamorex 08-17-2011 12:58 PM

Which version of Fedora are you using?

sycamorex 08-17-2011 01:06 PM

Ok, have you got access to a wired connection? If so, have a look at the following tutorial (particularly post 3). Getting it to work with wired connection seems quite straightforward. It looks like BCM4313 doesn't need ndiswrapper anymore.
http://fedoraforum.org/forum/showthread.php?t=239922

theashishmishra 08-17-2011 02:08 PM

yes I have wired connection..n I am using Fedora 15
and the output of lsusb is
[Invincible@localhost ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam
Bus 007 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 007 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
Bus 007 Device 004: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 007 Device 005: ID 0a5c:4503 Broadcom Corp.

---------- Post added 08-17-11 at 11:38 PM ----------

yes I have wired connection..n I am using Fedora 15
and the output of lsusb is
[Invincible@localhost ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam
Bus 007 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 007 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
Bus 007 Device 004: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 007 Device 005: ID 0a5c:4503 Broadcom Corp.

sycamorex 08-17-2011 02:12 PM

Try the tutorial I suggested and let us know the outcome.

theashishmishra 08-17-2011 02:30 PM

Wow..I can't thank you enough man..It worked..flawlessly :)

---------- Post added 08-18-11 at 12:00 AM ----------

Thanks a ton :)

sycamorex 08-17-2011 02:32 PM

No problem. Make sure you mark the thread as solved. You can find it in the Thread Tools.

theashishmishra 08-17-2011 03:35 PM

Sorry to bother you again..but the problem is that your tutorial helped me in solving the problem in my Dell Inspiron 1525 but my brother has Lenovo G565..and the problem still persists..I tried to install version 4 firmware for the b43 driver module and version 3 firmware for the b43 legacy driver module both but in both the cases all the efforts went into vain..then I tried this and got this message
[root@Illuminati abhijeet]# uname -r
2.6.40-4.fc15.i686.PAE
[root@Illuminati abhijeet]# rpm -qa | grep -e kernel -e broadcom-wl -e kmod-wl | sort
abrt-addon-kerneloops-2.0.3-1.fc15.i686
kernel-devel-2.6.40-4.fc15.i686
kernel-headers-2.6.40-4.fc15.i686
kernel-PAE-2.6.38.6-26.rc1.fc15.i686
kernel-PAE-2.6.40-4.fc15.i686
[root@Illuminati abhijeet]# lsmod | sort
ata_generic 2635 0
atl1c 26884 0
bcma 11014 0
bluetooth 165011 23 rfcomm,bnep,btusb
bnep 11740 2
btusb 12476 2
cdc_ether 6289 1 rndis_host
cfg80211 126267 1 rndis_wlan
cpufreq_ondemand 4782 2
drm 156465 5 radeon,ttm,drm_kms_helper
drm_kms_helper 23178 1 radeon
fuse 53547 3
i2c_algo_bit 4206 1 radeon
i2c_core 21548 6 videodev,i2c_piix4,radeon,drm_kms_helper,drm,i2c_algo_bit
i2c_piix4 9254 0
ideapad_laptop 3954 0
ip6table_filter 1215 1
ip6_tables 9828 1 ip6table_filter
ip6t_REJECT 3395 2
joydev 7219 0
k10temp 2511 0
media 9214 2 uvcvideo,videodev
microcode 11178 0
mii 3639 1 usbnet
Module Size Used by
mperf 1137 1 powernow_k8
nf_conntrack 56162 3 nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state
nf_conntrack_ipv4 6874 2
nf_conntrack_ipv6 6429 2
nf_defrag_ipv4 1093 1 nf_conntrack_ipv4
nf_defrag_ipv6 7174 1 nf_conntrack_ipv6
pata_acpi 2355 0
pata_atiixp 3016 0
powernow_k8 19162 0
radeon 624236 3
rfcomm 49712 4
rfkill 12939 5 cfg80211,ideapad_laptop,bluetooth
rndis_host 7223 1 rndis_wlan
rndis_wlan 36991 0
snd 48471 10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
snd_hda_codec 71160 2 snd_hda_codec_realtek,snd_hda_intel
snd_hda_codec_realtek 241838 1
snd_hda_intel 20651 1
snd_hwdep 4905 1 snd_hda_codec
snd_page_alloc 6099 2 snd_hda_intel,snd_pcm
snd_pcm 63577 2 snd_hda_intel,snd_hda_codec
snd_seq 43528 0
snd_seq_device 5033 1 snd_seq
snd_timer 15237 2 snd_seq,snd_pcm
soundcore 5027 1 snd
sp5100_tco 4373 0
sparse_keymap 2746 1 ideapad_laptop
sunrpc 168805 1
ttm 46038 1 radeon
usbnet 20204 3 rndis_wlan,rndis_host,cdc_ether
uvcvideo 51149 0
video 10684 0
videodev 64085 1 uvcvideo
xt_state 942 4
[root@Illuminati abhijeet]# modprobe wl
FATAL: Module wl not found.

Now what to do??

theashishmishra 08-17-2011 03:43 PM

lsusb reads like this in Lenovo G565
[root@Illuminati abhijeet]# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04f2:b1c1 Chicony Electronics Co., Ltd
Bus 005 Device 002: ID 0489:e00d Foxconn / Hon Hai

theashishmishra 08-17-2011 04:06 PM

And when I used ndiswrapper...I got this message
[abhijeet@Illuminati ~]$ ndiswrapper -l
bcmwl6 : driver installed
device (14E4:4727) present (alternate driver: bcma)

sycamorex 08-17-2011 05:11 PM

What's the output of lspci on Lenovo?

theashishmishra 08-17-2011 11:07 PM

this is the output of lspci
[abhijeet@Illuminati ~]$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
00:01.0 PCI bridge: Device 393e:9602
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 41)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller (rev 40)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:15.0 PCI bridge: ATI Technologies Inc Device 43a0
00:16.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8152 v1.1 Fast Ethernet (rev c1)

sycamorex 08-18-2011 06:50 AM

Ok, bcma seems to be blocking the wl module. Can you blacklist bcma:
Code:

su
echo "blacklist bcma" >> /etc/modprobe.d/blacklist.conf


Than restart the computer and post the output of (I assume that you're running a PAE kernel):

Code:

uname -r
su
yum install kmod-wl-PAE



All times are GMT -5. The time now is 04:38 PM.