LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-19-2006, 04:05 AM   #1
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Rep: Reputation: 0
Problem in activating eth0


Hi,
I am new to Linux. I am using Fedora4 and I was trying to bring up eth0 and I got the following error message.
SIOCSIFFLAGS:Invalid argument

I used the command: ifconfig eth0 up
and I got the error message.
I also tried /etc/init.d/network restart and I got the same error message.
Any solutions???
TIA
Gaurav
 
Old 04-19-2006, 04:16 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
FC4 aye?


you could try:
ifup eth0
dhclient eth0
Did you try Network Device Control ?

Now... post output of ifconfig -a

Please edit your profile to show your distro and some idea of your location. It will help folk answer your questions.

New to FC4 ... take a look at:
www.fedorafaq.org
www.mjmwired.net

Last edited by Simon Bridge; 04-19-2006 at 04:35 AM.
 
Old 04-19-2006, 10:26 AM   #3
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Hi Simon,
I tried those command but could not activate eth0.I have FC4 installed on HP pavilion dv1000.
ifup eth0 gave the same error SIOCSIFFLAGS:Invalid argument
dhclient eth0 gave no errors but eth0 was not activated as I was not able to connect to the net.

Following was the output of ifconfig-a:

eth0:Link encap:Ethernet HWaddr: .......
Broadcast multicast MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 frame:0 collision:0 txqueuelen:1000
Interrup:16 Base address:0x3000

lo:.......

sit0:.....
 
Old 04-19-2006, 10:57 AM   #4
towel401
Member
 
Registered: Apr 2005
Location: Ireland
Distribution: Mepis, mdk10
Posts: 39

Rep: Reputation: 15
i dunno but.. try ifconfig eth0 192.168.0.1

replace that with whatever IP you want it ot have
 
Old 04-19-2006, 11:29 AM   #5
lebabyg
Member
 
Registered: Mar 2006
Location: UK
Distribution: Ubuntu Feisty
Posts: 272

Rep: Reputation: 30
FC4 should automatically bring up your ethernet connection. Are you sure that your adapter is properly detected by fedora. If you're using gnome go the hardware browser and check that its listed properly. If not, go from there.
 
Old 04-19-2006, 09:10 PM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I see there is one question I asked not answered...
Quote:
Did you try Network Device Control ?
... Fedora likes you to use the NDC interface to manage network devices.

FC4 does not automatically bring the ethernet connection up... only if you were on a network when you first started. (At least - that's so with mine. I had to bring eth0 up in the ndc to get connected.)

Have you configured eth0 for your network?
Are you plugged in?
 
Old 04-19-2006, 11:13 PM   #7
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Thanx to everybody for responding.
I did use the Network configuration utility in Fedora, the one which u get on typing neat in the konsole. There again when I click on activate for eth0 I get the same error. SIOCSIFFLAGS:Invalid Argument.
One more thing, everytime I face a problem in Linux I have to boot windows and then google for the problem as I am not connected to the net on Linux. Is there any solution for this so that I dont restart everytime.
 
Old 04-19-2006, 11:17 PM   #8
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Original Poster
Rep: Reputation: 0
> FC4 should automatically bring up your ethernet connection.
Yes, during bootup it does try to bring up eth0 but the same error message appears there as well.
Bringing up eth0 [Failed]
SIOCSIFFLAGS:Invalid Argument.
 
Old 04-20-2006, 02:33 AM   #9
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
everytime I face a problem in Linux I have to boot windows and then google for the problem as I am not connected to the net on Linux. Is there any solution for this so that I dont restart everytime.
This is only an issue where the problem prevents internet access (or booting into linux). Generally these things are unusual. Booting into another OS, which can access the internet, is the usual method. For this reason, many people keep several kernels on their system... i.e. when they are recompiling a kernel, they keep a working version on standby.

Linux Rescue CDs can be useful here, as can live distributions like knoppix. (Knoppix in particular because of it's legendary hardware recognition.)

And, of course, there is always keeping several ways of accessing the internet. Keep a modem handy as well as an ethernet nic - that way one or the other is bound to be going. (Though, usually, ethernet is more reliable.)
 
Old 04-20-2006, 02:56 AM   #10
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
I did use the Network configuration utility in Fedora, the one which u get on typing neat in the konsole. There again when I click on activate for eth0 I get the same error.
Hmmm... you're using KDE?

I'm not sure what you mean by "typing neat" (typo?) but I get it from the main menue > system tools > network device control.

It is unusual for users to be able to activate eth0 from the NDC.
Anyway - ndc also ha a "configure" button? This takes you to the "network configuration" dialog - you get an option to start the service there too (worth a try but unlikely to work given past results).

In Network Configuration, you can check your hardware status to see what it can see.

You can also destroy the eth0 configuration - I am suggesting you do this, then use the internet configuration wizard (main > system tools > internet configuration wizard) to add a new ethernet connection.

This should probe for your card, detect it, and walk you through configuring it properly.

BTW: what is this card? (lspci) I take it this card works under <sigh> windows?
 
Old 04-20-2006, 07:39 AM   #11
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Hmmm... done some brainstormin with some more savvy folk than me.

I take it this card has not been used in linux before? And that this is a pretty new installation of FC4? Did you skip the network configuration in anaconda (when you installed)? (If got called localhost - then you probably skipped.)

You see, the serious money in on the driver being absent or wrong.

lsmod (to check drivers)
lspci (to tell us what card this is)
It may be a matter of just modprobe <driver>.

Some other things to check:
What does your /etc/sysconfig/network-scripts/ifcfg-eth0 say?
What is in /etc/sysconfig/networks?

If this is a pci card, try reseating it, or using it in another slot.

I found an article about sharing interrupts between SCSI and Ethernet being a no-no...
http://linuxmafia.com/faq/VALinux-kb...ags-error.html

Of course - removing the configuration and reinstalling would probably load the correct driver as well. It may end up as, conceptually, the simplest approach.

Last edited by Simon Bridge; 04-20-2006 at 07:40 AM.
 
Old 04-20-2006, 07:09 PM   #12
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
More:
http://linuxmafia.com/faq/VALinux-kb...ags-error.html


Quote:
Q: Ethernet networking is not working. I get the error message:

"SIOCSIFFLAGS: Try again"

from ifconfig.

A: This usually indicates a hardware conflict with your ethernet controller. Run "ifconfig -a" and check the IRQ and I/O addresses used by the controller. Also, look at the contents of the files /proc/interrupts and /proc/pci to determine what IRQ and I/O addresses are in use on your system. Many ethernet and SCSI drivers cannot share interrupts under Linux. Your system most likely has an IRQ conflict.

To fix IRQ conflicts on PCI bus systems, you can often go into the motherboard BIOS setup and mark the conflicting IRQ as "Used by an ISA Device". This will force the motherboard to reassign the IRQ, often eliminating the conflict.
This looks a lot like your problem right here.

Follow the advice above.
At this point I'd need feedback before continuing.
 
Old 04-21-2006, 01:00 AM   #13
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Hi Simon,
Thanx a lot for your continued help. The last link does look like my problem and I think it might fix it. Currently I am in my office and I would try it out tonight.
Thanx once again for your help.
 
Old 04-22-2006, 08:57 AM   #14
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Original Poster
Rep: Reputation: 0
ifconfig-a: gives this

eth0:Link encap:Ethernet HWaddr: .......
Broadcast multicast MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 frame:0 collision:0 txqueuelen:1000
Interrup:16 Base address:0x3000

and I checked /proc/pci and somewhere it contained the same address. I am not sure if that is causing the problem.
Following was the piece in proc/pci with the same address:

Bus6,device0,function0:
Class 0200:PCI device 10ec:8136(rev16)
IRQ16
Master Capable Latency=64 Min Gnt=32 Max Lat=64
I/O at 0x3000[0x30ff]

I tried to make the changes you suggested in the BIOS settings but I could not find the option. In any case I dont think it woul be safe to make changes to BIOS settings without being sure abt what I am doing. isnt there any other way out.
 
Old 04-22-2006, 09:18 AM   #15
gaurav1146
LQ Newbie
 
Registered: Apr 2006
Posts: 8

Original Poster
Rep: Reputation: 0
I also installed fedora again. During installation it gives two options for setting the hostname:
-> automatically via DHCP
-> Manually

In my earlier installation I had selected automatically via DHCP. This time I changed it to Manually and provided the IP address, subnet mask....
I thought this would solve the problem but again I got the same error:SIOCSIFFLAGS:Invalid argument
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem activating my pci isdn card ody1 Linux - Hardware 2 03-24-2004 06:30 PM
eth0 not activating during bootup nigma Linux - Networking 1 02-13-2004 05:23 AM
Problem activating network card with no IP address Olusegun Linux - Networking 1 12-30-2002 04:38 PM
Activating eth0 causes problems/delays in login... Why? And how to remediate? patapon Linux - Newbie 4 12-14-2001 07:18 AM
Activating eth0 causes problems/delays in login... Why? And how to remediate? patapon Linux - Networking 3 12-14-2001 06:39 AM


All times are GMT -5. The time now is 05:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration