LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2009, 12:47 PM   #1
Chriscrof
Member
 
Registered: Jul 2008
Location: France and UK
Distribution: 10.10
Posts: 86

Rep: Reputation: 15
Problem connecting to the internet


Could some kind person help me with this problem, please?

I recently upgraded Ubuntu 8.10 on my old desktop and also on a USB memory stick to Ubuntu 9.04 alpha 1. I realise that this is not the final release and that there could be problems, but I was curious to see what it is like.

My computer boots into Ubuntu 9.04 quite happily from the memory stick and Update Manager notifies me of any updates, so now it has alpha 4

However although my desktop (it is an old one that I use for this type of thing) boots quite normally and update manager notified me of updates it will not now connect to the internet. When it boots a green thing rotates for a while in the notification area and then there is the message "The network has been disconnected". I was able to connect to the internet until after upgrading to alpha 4

Clicking on the Network Manager icon shows that Ubuntu 'knows' that it should use 'eth0' but everything related to it is greyed out so that I can't edit it (even if I knew what to do)

It seems very strange that two identical versions of Ubuntu 9.04 behave differently in the same machine

The machine that I am using is a dual boot Windows XP/Ubuntu, with Ubuntu and Windows on separate drives, which normally defaults to Windows if I don't tell it otherwise and in order to save time I edited 'menu.lst' on the computer so that it would default to Ubuntu. I checked the 'menu.lst' on the memory stick to make sure that what I had edited was correct and found that on the memory stick 'menu.lst' referred to Ubuntu 9.04 but on the computer 'menu.lst' only referred to Ubuntu 8.10. I tried importing the lines relevant to Ubuntu 9.04 from the memory stick to the computer but now the computer won't boot properly. Fortunately I left the lines relating to Ubuntu 8.10 so I was able to boot it and remove my editing from 'menu.lst'

Is there any way out of this 'impasse'or is it a case for reformatting the hard disc? A corrupt file, perhaps?
 
Old 03-02-2009, 01:44 PM   #2
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
might try
Code:
$ ifup eth0
or
$ /etc/init.d/networking restart
to see if you can initialize your network.

Last edited by john test; 03-02-2009 at 01:47 PM.
 
Old 03-02-2009, 02:09 PM   #3
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,565

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
You might also disclose how you are connected to the Internet - Wifi, what network card, and compare /etc/host.conf and /etc/resolv.conf in both systems. you may need to install a kernel module if everything is gray.
 
Old 03-02-2009, 04:01 PM   #4
Chriscrof
Member
 
Registered: Jul 2008
Location: France and UK
Distribution: 10.10
Posts: 86

Original Poster
Rep: Reputation: 15
Hi john test, doing ifup eth0 produced "ignoring unknown interface eth0=eth0"

and

/etc/init.d/networking restart produced "reconfiguring network interfaces" followed by [OK]

but I still can't connect.

Hi business_kid

I connect via an NVIDIA (built in) ethernet card and cable connected to an ADSL modem. /etc/resolv.conf appears to be empty. It just says "# Generated by NetworkManager". The files are the same in both systems.

At some stage I tried to boot in recovery mode and at the end got this message "ALERT! /dev/desk/by-uuid/dec5558c-1a28-4c78-b59a-4ce00abbbfba does not exist. Dropping to a shell"

Booting stopped after that.

How can I find out if a module is missing and more importantly where to find it and how to install it.

I had thought of making an alternative install disc but it looks as if this will erase everything even though I read that it can be used as an updater.

Thanks both of you for your suggestions

Chris
 
Old 03-03-2009, 02:15 PM   #5
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,565

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
Your problem appears to be that the box isn't talking to the network card.
Try the command 'ifconfig'. Here's what mine looks like.

eth0 Link encap:Ethernet HWaddr 00:19:66:5D:81:72
inet addr:192.168.1.35 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::219:66ff:fe5d:8172/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1266 errors:0 dropped:0 overruns:0 frame:0
TX packets:1355 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:923254 (901.6 KiB) TX bytes:242739 (237.0 KiB)
Interrupt:20 Base address:0xd400

Key factors are The Interrupt & base address which means the hardware is talking. You should be able to ping your modem

ping 192.168.1.1
(or 192.168.0.1) usually should give you a time. This is good.

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=1.15 ms

I expect you do not have a kernel mo0dule loaded for your card. If one version works, get online, try the above, and also type

lsmod > somefile

Then boot the problem version and type

lsmod > anotherfile

You can then compare them with

diff -u anotherfile somefile
Somefile will have + signs. Every + line is a line the working version has that the other does not. use modprobe
modprobe some_module

loads some_module.ko
 
Old 03-03-2009, 02:20 PM   #6
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
could also look in the dmesg log to see if/how the system is identifying your network card.. maybe it switched to eth1. Wouldn't be the first time a network interface changed device id's.

cat /var/log/dmesg | grep -i eth
 
Old 03-03-2009, 04:04 PM   #7
Chriscrof
Member
 
Registered: Jul 2008
Location: France and UK
Distribution: 10.10
Posts: 86

Original Poster
Rep: Reputation: 15
Hi farslayer, thanks for your suggestion. I did 'cat /var/log/dmesg' etc. and it identified the ethernet card as a RealTek RTL 8139 and as eth0. It also mentioned that 'sd' and'sr' need updating but I don't know what these are, how to update them or how to use the 'bus type method' that it said to use.

It looks to me that the card is OK (?) and that the problem lies somewhere else
 
Old 03-03-2009, 04:34 PM   #8
Chriscrof
Member
 
Registered: Jul 2008
Location: France and UK
Distribution: 10.10
Posts: 86

Original Poster
Rep: Reputation: 15
Hi business kid,

I am not sure whether I understand the output from 'diff -u thisfile thatfile.

The modules from the system that works properly had a - in front of them and those from the one that won't connect to the internet have a + in front of them. I copied it to a file but I am doing this in Windows so as to leave the other machine free for Ubuntu and transferred the file to Windows but it is unreadable. I could shut down windows and send the file if you have the patience to look at it.

The output from ifconfig is very similar to yours but the interrupt is 18 and the base address is 0xec00 and the TX and RX packets were 57 and 47 in the system that works and 8 and 2 in the system that doesn't
.

If you could look at the file I could send it tomorrow as I am being nagged to "shut that b****y computer down asap"

Chris
 
Old 03-04-2009, 12:01 AM   #9
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
how about the following command on both machines ?
lsmod | grep -i 8139

I think it should be the 8139too module if I'm not mistaken


an interesting thread, might be related.. Don't know if you had/have Windows on that box as well....
http://www.linuxquestions.org/questi...-newer-593495/
https://bugs.launchpad.net/ubuntu/+s...ux/+bug/156496


This thread suggests a possible different driver module..
http://kerneltrap.org/node/16909
 
Old 03-04-2009, 07:10 AM   #10
muzzavitch
Member
 
Registered: Dec 2008
Location: Lismore, NSW Australia
Distribution: Ubuntu 9.10 Server 32Bit
Posts: 30

Rep: Reputation: 16
Hello Chriscrof, are you sure your router is working ok?
 
Old 03-04-2009, 09:46 AM   #11
Chriscrof
Member
 
Registered: Jul 2008
Location: France and UK
Distribution: 10.10
Posts: 86

Original Poster
Rep: Reputation: 15
Hi farslayer, thanks for getting back to me. I did lsmod | grep -i 8139* as you suggested, on the system that connects (i.e the one booted with the USB stick) and the one that won't (i.e. the same computer booting from its HD) and the output was identical on both occasions:-

Computer that connects using USB stick :
8139too 32128 0

8139cp 27776 0

mi i 13312 2 8139too, 8139cp

Same computer but booting from its HD exactly the same

The computer has two HDs; C: is devoted entirely to Windows XP SP2 and D: is devoted entirely to Ubuntu. I did it like that partly because I had a spare HD and partly because, not knowing much about partitions, I thought that there was less chance of losing data than if Ubuntu were installed on the C: drive.

I had a look at the link that you gave and found that "Wake on LAN after shutdown" was already enabled. I have had no problems like this with Ubuntu 8.10 or Ubuntu 9.04 alpha 1 to alpha 3. The problem only arose with alpha 4. I have downloaded the alternative install image for alpha 5 and burned it to a CD thinking that if it were installed it would correct any broken files but it won't install. It says that the system is already up to date. I don't know if it can be made to install in spite of that.

Last edited by Chriscrof; 03-04-2009 at 09:47 AM.
 
Old 03-04-2009, 10:10 AM   #12
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
OK so the same modules are loaded for each.. although I thought it should use either 8193too OR 8193cp I didn't think it was supposed to use both at the same time.


try this on the system that is NOT working.


rmmod 8139too
rmmod 8139cp
modprobe 8139too
ifup eth0


Does the interface come up and work now ?
Quote:
Sometimes it occurs that the card is detected as 8139 but there are different version of the 8139 available.

The 8139cp driver is for RealTek RTL-8139C+ series 10/100 PCI Ethernet driver

The 8139too driver is for RealTek RTL-8139 Fast Ethernet driver
So the proper module would depend on Which actual card you have.. if the system is trying to load both modules it could be causing a conflict.. lspci should help you determine which module is actually correct.

Last edited by farslayer; 03-04-2009 at 10:12 AM.
 
Old 03-04-2009, 11:36 AM   #13
Chriscrof
Member
 
Registered: Jul 2008
Location: France and UK
Distribution: 10.10
Posts: 86

Original Poster
Rep: Reputation: 15
hello again farslayer,

doing 'lspci' wasn't much help. It said:

Ethernet controller: RealTek Semiconductor Co. Ltd RTL-8139/8139C/8139C+ rev 10 and having done the commands (rmmod etc.), doing 'ifup eth0' returned "Ignoring unknown interface eth0=eth0". I tried 'ifup eth0' a couple of days ago and got the same answer

I have just done 'lsmod' on the system that connects to the internet and both 8139too and 8139cp are listed and 'mii' has 8139too,8139cp beside it; that is the same as the system that wont connect

It looks to me as though I am going to have to reinstall Ubuntu

Last edited by Chriscrof; 03-04-2009 at 11:56 AM. Reason: New information
 
Old 03-04-2009, 01:10 PM   #14
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,565

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
lspci was a great help - we know you have a Realtek card now!

I concur with farslayer.
8139cp is for Realtek 9139C+ Fast Ethernet cards and is recommended
8130too is for older cards, (8129/8130/early 8139)and they conflict.
If your card is ancient then this might be the one for you. I suspect 8139too may get in the way.

I had this bug a while back. try

cat /proc/interrupts

There are saved interrupt settings in those realtek cards, and my nic wanted irq 11. But some halfassed via chipset M/b had a broken interrupt controller and gave it irq 22 or summat. So the System Couldn't See It.
Check what irq works for it. You can assign an irq with ifconfig. Bring it down, then up.

ifconfig eth0 down
ifconfig eth0 irq (your irq) up

then run dhclient eth0 (or pppoe with it's options if appropriate.)
 
Old 03-04-2009, 08:00 PM   #15
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Ah ok now that we can see lspci it should be the 8139cp module not the 8139too try this

rmmod 8139too
rmmod 8139cp
modprobe 8139cp
ifup eth0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in connecting to internet niloofar Linux - Networking 3 09-03-2007 03:18 AM
Problem connecting to the internet sabaum Linux - Networking 10 05-16-2004 06:59 PM
Problem connecting internet.... neosap Linux - Newbie 2 03-07-2004 03:40 PM
Problem connecting to the internet akarmis Linux - Newbie 1 10-02-2003 04:21 PM
Problem connecting to the internet! Ghettozn Debian 4 07-24-2003 02:47 AM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration