LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2004, 03:50 PM   #1
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Rep: Reputation: 15
Problem connecting to internet [Slack]


I installed slackware 10 (fluxbox) and I can't connect to the internet. The network card is in my motherboard, which is an EPoX EP-8KDA3+ http://www.epox.org/products/mainboards/8kda3/ , and I'm using a router. ADSL connection.

my computer --> router --> modem --> internet

I've tried netconfig but nothing I've tried worked. So anyone know what I should choose? I don't really know what else I should say so just ask if you need to know more to help me.
 
Old 09-22-2004, 04:01 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Try from terminal;dhcpcd eth0
 
Old 09-22-2004, 04:17 PM   #3
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
Didn't fix it.
Also when I try to ping 192.168.0.1 (the router) it says "network is unreachable".
 
Old 09-22-2004, 08:42 PM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
See if there is anything here that can help you,its for gentoo using 64 bit,is there a driver for your card,it is pretty new?I will keep looking.http://www.gentoo.org/doc/en/handboo...?part=1&chap=3
 
Old 09-22-2004, 08:47 PM   #5
AAnarchYY
Member
 
Registered: Sep 2004
Location: Carlisle, MA
Distribution: Debian 8
Posts: 419

Rep: Reputation: 30
Quote:
Originally posted by NomDeGuerre
Didn't fix it.
Also when I try to ping 192.168.0.1 (the router) it says "network is unreachable".
That leads me to belive that the route isnt set.

first bring the device up: ifconfig eth0 up
next you may need to set the routing: route add default gw 192.168.0.1
after that, try to dhcp an ip: dhcpcd eth0

Last edited by AAnarchYY; 09-22-2004 at 08:48 PM.
 
Old 09-22-2004, 08:48 PM   #6
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
i was having the same issue with fedora and my own new router. try to set the ip, subnet and gateway to be static. Also, can you log into the router to change options? once i set the above i messed around with ifconfig eth0 up. To run netconfig in slack either su to root and then run netconfig, or if that doesn't work run pkgtool and run netconfig that way. Keep plugging away at it. You also might want to look at the documentation for your router.
 
Old 09-23-2004, 02:50 AM   #7
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
I tried with

ifconfig eth0 up

but got "no such devices".
 
Old 09-23-2004, 03:19 AM   #8
realjustin
Member
 
Registered: Aug 2004
Location: /dev/null
Distribution: Slack 10, Debian
Posts: 99

Rep: Reputation: 15
If you get "no such device" then your problem is that the device is not detected at all. Do
dmesg | grep eth0
And if nothing comes up, then your problem is that you need to get the drivers for your card, or enable it in the kernel if it's possible. Either way will require a bit of reading, so look up how to recompile a kernel and how to get your specific ethernet card to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting to the internet problem Detriamus Linux - Newbie 3 08-09-2004 02:51 PM
Problem connecting to the internet sabaum Linux - Networking 10 05-16-2004 05:59 PM
Problem connecting to the internet sabaum Linux - Newbie 4 04-12-2004 06:50 PM
Problem connecting internet.... neosap Linux - Newbie 2 03-07-2004 02:40 PM
connecting to Internet Problem+please help saurav_gohain Linux - Networking 5 07-14-2003 06:39 PM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration