LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2009, 11:19 AM   #1
Mistretul
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Rep: Reputation: 0
Question Problem connecting to a HDD connected to a router


Hello,

I am running a Kubuntu 8.04.2 and I have set up a HDD connected to a router to share files with my other computers in the house.

The router has a USB port and i can connect either a USB stick or an external USB HDD to share it with everybody in the network.

I set up the router to share the HDD (i have also tried this with my USB stick, the problem is the same) and I can successfully connect to it from the Windows computer my wife is running (and from any Windows VM i have set up). Both the router and the USB stick are formated FAT32 cause that is the only way the router will accept it.

On the router in the security section of the share i can set up "no security" or i can set up a password to be able to change the access the router. I have tried with both options and neither works (i set up the same password as the one on my kubuntu, if i should set it up another way tell me).

I can connect from my kubuntu to the router using it's ip (i connect to it like this smb://10.19.8.80/), i can see the partitions i have shared with their name, but when i try to enter a share i get a "The file or folder smb://10.19.8.80/partition1/ does not exist" error.

I do not have any problems connecting to the same devices if i share them from my wife's Windows computer.

Does anybody know how to set it up or what should I do so I may use the hdd on the router?

Thanks in advance.
 
Old 04-03-2009, 01:21 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Please tell us the model of your router.

For starters DON'T set a password, set it to "No security" (You can always unplug your internet connection - I have no idea what firewalls you have, or of your win machines are compromised, or if your data is "interesting").

I do not have NAS (Network Attached Storage) to play with (I need to get some), but I think you need to mount it before you can use it.
The commands might be (because I am guessing):
Code:
sudo -i         # To become root
mkdir /mnt/NAS  # Create a mountpoint directory
mount -t cifs //10.19.8.80/partition1   /mnt/NAS    # Attempt to mount the NAS partition
ls /mnt/NAS     # Can you see any files?
No need to type the bits after the # character, they're just comments.
If this works, don't unplug the drive without umount-ing it, or turning off your PC.

If you have trouble, these will be useful starting search terms to enter into http://google.com/linux
mount NAS smbfs cifs
Let us know how you get on, and Welcome to LQ!
 
Old 04-06-2009, 03:46 PM   #3
Mistretul
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Unhappy

Thank you very much about your answer. I have tried your solution and it does not work. I get the following error:
Quote:
mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
I have also tried the same command with smbfs and i have tried it with mount.cif and mount.smbfs (from what i understood they are actually the same command as the one above).

I have tried to include the workgroup in the command, I changed the smb.conf file so i am in the same workgroup with the router, i put a password on the router and i have tried to include it in the command. Nothing seams to work.

I have also tried other file managers, i thought it might be a dolphin problem (i know that mount does not have anything to do with dolphin but i tried it before I tried mount). The funny thing is that in MC i can connect to the router. The only program where i can actually see the files on the router, I still cannot do anything to the files but at least I can see them. It does work by connecting to a SMB share. What does MC do different to the other file managers? does it use a different shell or anything like that?

Thank you.
 
Old 04-08-2009, 06:12 AM   #4
Mistretul
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Angry

I have made some more tests, i still have no luck in connecting to the router hdd with anything except MC. With MC i cannot do anything but see the files, i cannot even copy them to my computer.

Any ideas?
 
Old 04-09-2009, 05:35 PM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Quote:
Any ideas?
Sorry for the late reply. I have been busy.

But I cannot help you help yourself if you do not answer the Q's I am asking you.

Eg (@Post #2): "Please tell us the model of your router."

Your post #3: "I have tried your solution and it does not work. I get the following error:"

Please copy and paste the exact commands you gave (and all the error messages). What command gave you the error "mount error 20 = Not a directory" ?

Your post #4: "I have made some more tests"
Doesn't help us at all. What "tests" ?
What did you do, what was the output, what happened ?
 
Old 04-10-2009, 05:32 AM   #6
Mistretul
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
The router is a Gigaset se551, i did not mention it because i had the same problem on a SMC wbr router (can't remember the exact number). The router i cannot configure too much and from what i see it is not the problem cause connecting from other non linux based computers works fine.

The tests i have made were with the mount.cifs, mount.smbfs, mount -t cifs, mount -t smbfs

all the commands were correct cause i copy pasted them from diffrent sources

I have tried the followings

Code:
sudo mount -t cifs //10.19.8.80/partition1 /media/share -o workgroup=WORKGROUP,password=,domain=WORKGROUP
Code:
sudo mount -t smbfs //10.19.8.80/partition1 /media/share -o workgroup=WORKGROUP,password=,domain=WORKGROUP
Code:
sudo mount -t cifs //10.19.8.80/partition1 /media/share -o sec=none,user=guest
Code:
sudo mount -t smbfs //10.19.8.80/partition1 /media/share
Code:
sudo mount -t cifs //10.19.8.80/partition1 /media/share
After setting a password on the router i tried:
Code:
sudo mount -t cifs //10.19.8.80/partition1 /media/share -o password=qwerty,domain=WORKGROUP
Code:
sudo mount -t smbfs //10.19.8.80/partition1 /media/share -o password=qwerty,domain=WORKGROUP
all of the above have returned with the
Code:
mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
i have also tried this
Code:
sudo echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled
as i have found on the net that it might work. It does not.


This guy seams to have solved the same problem for other people
http://forum.openwrt.org/viewtopic.php?pid=43186#p43186
but i am not sure how to do that on my kubuntu.

Any ideas?
 
Old 04-10-2009, 05:45 AM   #7
Mistretul
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
i tried running some commande
Code:
root@mp-desktop:~# smbtree
Password:
WORKGROUP
        \\FS                            Router
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine FS.  Error was ERRSRV - ERRsmbcmd (The server did not recognize the command received.)
                \\FS\IPC$               Remote Inter Process Communication
                \\FS\partition1         partition1
        \\ASUS-1396293760               asus-1396293760 server (Asus Eee PC)
                \\ASUS-1396293760\IPC$                  IPC Service (asus-1396293760 server (Asus Eee PC))
Code:
root@mp-desktop:~# smbclient -L 10.19.8.80
Password:

        Sharename       Type      Comment
        ---------       ----      -------
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine 10.19.8.80.  Error was ERRSRV - ERRsmbcmd (The server did not recognize the command received.)
        partition1      Disk      partition1
        IPC$            IPC       Remote Inter Process Communication

        Server               Comment
        ---------            -------
        FS                   Router

        Workgroup            Master
        ---------            -------
        FS                   Router
Maybe they tell you guys more info
 
Old 04-10-2009, 07:51 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Thanks for the update.
Because I don't use samba and don't have NAS, this is difficult for me....

Some things to think about:

Maybe your mount command is wrong.
From man mount
Code:
mount [−fnrsvw] [−t vfstype] [−o options] device dir
But you are doing it like this:
Code:
mount -t smbfs device dir -o workgroup=WORKGROUP,password=,domain=WORKGROUP
Which is in the wrong order. Just to confuse things, mount.cifs uses a different order.

But the fact that smbtree and smbclient give that error makes it look as though something is wrong with your smb.conf

In this thread http://www.linuxformat.co.uk/modules...ewtopic&t=7951
woofage got this to work:
Code:
sudo mount -t cifs //<server>/<share> /media/<mountpoint>/ -o user=myUserName
And here's another link for you:
http://www.linuxforums.org/forum/lin...tml#post480643

Otherwise, I'm stuck
 
Old 05-03-2009, 05:13 PM   #9
Mistretul
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I have tried putting the mount arguments in more then 1 place because I saw several commands that were different. Anyway no mount command works.

I have already tried changing the credentials, but it does not really apply here, because I do not have a username, I can only set a password. If I try connecting to a windows share then I have no problem, works perfectly from the command line and from fstab, the only problem I have is connecting the the hdd connected to the router.

Thank for you help , maybe somebody else has another idea.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in connecting to adsl router and internet nbalaji Linux - Newbie 7 12-26-2008 11:59 PM
Wifi connected to router, ping to router ok, no webaccess. what is wrong? deepcore Linux - Wireless Networking 5 01-07-2008 02:59 AM
booting machine with linux on an external HDD without HDD connected drsoum Linux - Newbie 2 07-22-2007 04:47 AM
Problem connecting using ethernet router RoughEdge Linux - Networking 8 04-30-2004 06:35 AM
Limit connected items connected to my router andersh3 Linux - Newbie 1 03-16-2004 12:10 PM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration