LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2006, 10:42 PM   #1
jojojo
Member
 
Registered: Feb 2005
Location: Kuala Lumpur, Malaysia
Distribution: Fedora Core 5
Posts: 121

Rep: Reputation: 15
Problem accessing the contents of windows


At last, i have successfully can access the ntfs partition. But other problem occur. After i have mount:

mount /dev/hdc1 /mnt/windows -t ntfs -r

the windows folder appear stating that i don't have the permissions necessary to view the contents of "windows". Why?
 
Old 05-24-2006, 10:55 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
try mount -t ntfs -o ro,umask=222 /dev/hdc1 /mnt/windows
 
Old 05-24-2006, 11:33 PM   #3
jojojo
Member
 
Registered: Feb 2005
Location: Kuala Lumpur, Malaysia
Distribution: Fedora Core 5
Posts: 121

Original Poster
Rep: Reputation: 15
Oh ok. Works fine now. May i know what does this command means:

-t ntfs -o ro,umask=222
 
Old 05-24-2006, 11:35 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
-t ntfs ==> fs type ntfs (I'm sure you figured that out)
-o ro,umask=222 ==> ro is read only and umask=222 means give every file permissions of 555 (read and execute)
 
Old 05-29-2006, 07:41 AM   #5
Unforgiven79
Member
 
Registered: May 2006
Location: Italy
Distribution: FC5, Suse 10
Posts: 70

Rep: Reputation: 15
Sorry, I had the same problem as jojojo, and I solved it the same way.
1) BUT, my intention is to have also permission to write, so I wrote the "-w" option. How does the "umask" syntax change?

2) Currently, I have to give the mounting command line explicitely at every startup. How can I set it to perform automatically?

Thanks
 
Old 05-29-2006, 08:44 AM   #6
jojojo
Member
 
Registered: Feb 2005
Location: Kuala Lumpur, Malaysia
Distribution: Fedora Core 5
Posts: 121

Original Poster
Rep: Reputation: 15
First of all you must download the ntfs kernel module that is same as your kernel. You may download the ntfs kernel here http://www.linux-ntfs.org/content/view/187/After that, to mount ntfs partition automatically during boot:

1) log in as root

2) Type:

Code:
gedit /etc/fstab
3) It will open a text editor. Then type:

Code:
/dev/hda1 /mnt/windows ntfs ro,umask=0222,user,gid=users 0 0
anywhere in a new line. You may want to create your own directory in the /mnt directory first. I've created mine as windows. You may also type: fdisk -l before this to see what type of device you have. If you have more than 1 partition or hard disk, then add another new line after the new line you have just created:

Code:
/dev/hdc1 /mnt/windows1 ntfs ro,umask=0222,user,gid=users 0 0
         /dev/hdc2 /mnt/windows2 ntfs ro,umask=0222,user,gid=users 0 0
4) Then type:

Code:
mount -at ntfs
5) If there's nothing happen, it means success. Try to reboot and access the /mnt/windows file to see whether you have successfully mounted your ntfs?

Last edited by jojojo; 05-29-2006 at 08:46 AM.
 
Old 05-30-2006, 03:38 PM   #7
Unforgiven79
Member
 
Registered: May 2006
Location: Italy
Distribution: FC5, Suse 10
Posts: 70

Rep: Reputation: 15
Thanx, I'm trying that.

Just one thing: you keep on suugesting the -ro option, while my intention would be to have writing permission on my NTFS partitions.
Is it because (as I have heard) these modules only allow you to read, or anything else?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem accessing windows files the1wraith Linux - Networking 19 11-02-2005 01:35 PM
Cd has different contents in Linux then in Windows sephiro499 Linux - Newbie 10 10-29-2004 09:39 AM
Problem accessing windows shares using samba Tinku Linux - Software 6 08-05-2004 08:47 PM
Accessing CD-RW contents in Mandrake 10 Cichlasoma Mandriva 0 06-08-2004 09:13 AM
Accessing Windows Machines Problem Help!! Sabeer Linux - Networking 1 10-29-2003 11:13 AM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration