LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2013, 08:42 AM   #1
Aule
LQ Newbie
 
Registered: Feb 2012
Distribution: Opensuse
Posts: 11

Rep: Reputation: Disabled
Print to CUPS server fails with "/usr/lib/cups/filter/foomatic-rip failed"


I have installed a HP Lj P1102w printer on OpenSUSE 12.3 as a local printer. After installing hplip and downloading the necessary proprietary plugin the printer works fine.

After this the printer was installed on a computer with OpenSUSE 12.2. Also works.

Then I left the printer on this later box and tried to use it from the OpenSUSE
12.3 one. For this I have only changed the printer from local USB to use CUPS server on the OpenSUSE 12.2 one with ipp. Nothing else was changed

And here the printing fails. The printer's CUPS page can be reached, so the problem is probably not because of access rights.

The error message is: /usr/lib/cups/filter/foomatic-rip failed

At the end of CUPS error_log the following is logged:

Code:
Starting renderer with command: "gs -sstdout=%stderr  -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792 -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="HP LaserJet 1018" -r600 -sIjsParams=Quality:Quality=0,Quality:ColorMode=0,Quality:PenSet=0,PS:MediaPosition=7 -dIjsUseOutputFD -sOutputFile=%stdout -_"
Starting process "kid3" (generation 1)

Closing renderer
Starting process "kid4" (generation 2)
Starting process "renderer" (generation 2)
JCL: %-12345X@PJL
<job data> 

Error: This module is designed to work with HP Printers only
prnt/hpijs/hpijs.cpp 269: unable to set device=HP LaserJet 1018, err=48
prnt/hpijs/hpijs.cpp 290: unable to set device=HP LaserJet 1018, err=48
**** Unable to open the initial device, quitting.
renderer exited with status 1
prnt/hpijs/hpijs.cpp 697: unable to read client data err=-2
Possible error on renderer command line or PostScript error. Check options.kid3 exited with status 3
Process is dying with "Error closing renderer
", exit stat 3
Cleaning up...
hrDeviceDesc="Unknown"
prtGeneralCurrentLocalization type is 0, expected 2!
backendWaitLoop(snmp_fd=5, addr=0x7fc3b4cb6ed8, side_cb=0x7fc3b42f7610)
End of messages
printer-state=3(idle)
printer-state-message="/usr/lib/cups/filter/foomatic-rip failed"
printer-state-reasons=none
What should I change, install, reinstall, etc. to have the printer work the desired way? Previously another HP printer (LJ 1150) was connected to the server and it worked flawlessly in the same setup.
 
Old 09-27-2013, 08:58 AM   #2
sachin.davra
Member
 
Registered: Jul 2013
Posts: 213

Rep: Reputation: Disabled
What should I change, install, reinstall, etc. to have the printer work the desired way? Previously another HP printer (LJ 1150) was connected to the server and it worked flawlessly in the same setup.[/QUOTE]



I dont think so that you should install or reinstall any thing.
you need to change one setting. i am not sure about how to do it in konsole. but graphical mode i know.
click on administration and then click on printing. give root password (if it prompts or if you are not root).
A window will come up then select your printer and then there should be three options. one of them is enabled. It must be checked.
Plz do it and revert back if your problem is resolved so that other users can take benefit from this.
 
Old 09-27-2013, 09:22 AM   #3
Aule
LQ Newbie
 
Registered: Feb 2012
Distribution: Opensuse
Posts: 11

Original Poster
Rep: Reputation: Disabled
Could you be more precise in what option should be checked?

I have opened OpenSUSE Administration, there opened Printers, it asked for root password. As this is the only printer it appeared immediately. There are indeed 3 options, and indeed only one is enabled, but it says reject jobs.
 
Old 09-27-2013, 10:01 AM   #4
sachin.davra
Member
 
Registered: Jul 2013
Posts: 213

Rep: Reputation: Disabled
Quote:
Originally Posted by Aule View Post
Could you be more precise in what option should be checked?

I have opened OpenSUSE Administration, there opened Printers, it asked for root password. As this is the only printer it appeared immediately. There are indeed 3 options, and indeed only one is enabled, but it says reject jobs.


There is one option which says "enabled" it must be cheked. then save it.
 
Old 09-27-2013, 10:01 AM   #5
Aule
LQ Newbie
 
Registered: Feb 2012
Distribution: Opensuse
Posts: 11

Original Poster
Rep: Reputation: Disabled
I have found a workaround to make the printer work, maybe it will help in the solution of the original problem.

I have added the printer as a remote printer using Yast printer config. Now it works, but I would prefer to have a local queue which prints to a cups ipp printer. If I try to setup the printer using the same Yast interface but as a local printer connected to an ipp address, it fails with the same error.

So the question is still open, and even modified:*why cannot I set the printer as a local printer printing to an ipp address?
 
Old 09-27-2013, 10:07 AM   #6
sachin.davra
Member
 
Registered: Jul 2013
Posts: 213

Rep: Reputation: Disabled
Quote:
Originally Posted by Aule View Post
I have found a workaround to make the printer work, maybe it will help in the solution of the original problem.

I have added the printer as a remote printer using Yast printer config. Now it works, but I would prefer to have a local queue which prints to a cups ipp printer. If I try to setup the printer using the same Yast interface but as a local printer connected to an ipp address, it fails with the same error.

So the question is still open, and even modified:*why cannot I set the printer as a local printer printing to an ipp address?


can you name those options which you can see after opening printing from administration?
 
Old 09-27-2013, 10:08 AM   #7
Aule
LQ Newbie
 
Registered: Feb 2012
Distribution: Opensuse
Posts: 11

Original Poster
Rep: Reputation: Disabled
set as default
share
reject jobs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS printing error: ="/usr/local/libexec/cups/filter/rastertosamsungspl failed ted_chou12 Linux - Software 0 08-04-2012 06:22 AM
Failure to print, Paused - "/usr/lib/cups/backend/hp failed" MadmanJack Linux - Newbie 3 04-15-2012 01:03 AM
"/usr/lib/cups/filter/foomatic-rip failed" newbiesforever Linux - Hardware 1 12-10-2010 10:37 AM
Freelink debian on Buffalo NAS cups not working /usr/lib/cups/filter/hpcups failed linuxmandrake Debian 0 03-23-2010 05:45 PM
[SOLVED] cups "/usr/lib/cups/filter/foomatic-rip failed" error wufo Slackware 4 01-31-2010 03:20 PM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration