LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2005, 06:34 AM   #1
blas
Member
 
Registered: Apr 2003
Distribution: fc5, ubuntu, rhel
Posts: 59

Rep: Reputation: 15
Print "special" characters


Hi,

How can I change the character set of my Red Hat Enterprise 3.0? The problem is that I have to print a Spanish text which has letters such as , , , and . This letters are not being printed correctly and I suppose this is because of the character set of the OS.

Any ideas?
Thanks in advance
Regards
 
Old 02-07-2005, 04:45 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,571

Rep: Reputation: 171Reputation: 171
You're vieving the document in an editor, right? Most Linux editors have an option to change character coding (in View menu, usually). It depends which encoding was used to create the document, but for Spanish try ISO-8859-1 and UTF-8. When you see the characters right they should be printed right.

The problem may be also that you don't have fonts with those characters. Then changing to a different font may help.
 
Old 02-08-2005, 10:47 AM   #3
blas
Member
 
Registered: Apr 2003
Distribution: fc5, ubuntu, rhel
Posts: 59

Original Poster
Rep: Reputation: 15
Hi Mara,

Thanks for your reply.

This happens in console, nothing related to X

Im trying to print a file which has some and letters from the console with
lp -d <DEVICE> <FILENAME>

The printer is configured with a RAW driver, its an Epson FX-80. I use CUPS.

My locale settings are all in spanish (es_ES.UTF-8), so I can create a file with on its name for example....

So.... dont know what else can I do, dont have more ideas....

Thanks
Regards
 
Old 02-09-2005, 03:40 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,571

Rep: Reputation: 171Reputation: 171
It should be in cupds.conf file. Search for option DefaultCharset and set it to utf-8.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone else receiving "special software discounts" emails? harken General 14 06-15-2005 12:52 AM
cdrom not recogonized/no hda/"special device" not found etc. thechao Debian 1 01-23-2005 04:42 PM
need help, on how to access quickly to special characters like "" or ""? Motaro Linux - Newbie 1 12-31-2003 11:53 AM
"Special" characters... Bjornkri Linux - Newbie 11 06-08-2003 07:40 AM
Ximian crashes when I enter "special chars" into message borbjo Linux - Software 0 01-28-2003 07:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration