LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Preventing Automount for USB Devices on Ubuntu (http://www.linuxquestions.org/questions/linux-newbie-8/preventing-automount-for-usb-devices-on-ubuntu-414935/)

phyx 02-13-2006 10:18 AM

Preventing Automount for USB Devices on Ubuntu
 
Hi,

How do you I prevent automounting for usb devices? Every time I plug in my usb stick device, it gets mounted as /media/usbdisk, /media/sdb1. However, I want it to only manually mount. Any thoughts? Here's my fstab. I tried doing things setting a mount point and using a "noauto" option, but it didn't work.

Tested lines to /etc/fstab
/dev/sdb1 /media/udb1 ext3 rw,noauto 0 0
/dev/usbdisk /media/usbdisk ext3 rw,noauto 0 0

Here's the original fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda4 / ext3 noatime,errors=remount-ro 0 1
/dev/sda2 /boot ext2 noatime 0 2
/dev/sda3 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

Flesym 02-13-2006 10:35 AM

Try to uninstall the usbmount-package:
Code:

sudo apt-get remove usbmount
Note: The "noauto"-option of 'mount' only indicates that this device will not be moumted when using the '-a'-option. See "man mount" for further details about this.

phyx 02-13-2006 06:01 PM

Uh, any help on just disabling the automount. I don't really want to permanently remove the automount feature.


All times are GMT -5. The time now is 12:45 AM.