LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2006, 12:14 PM   #1
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
Exclamation prblems with azureus getting nat error


i am having a problem with azureus i get only the yellow circle and it should be green also when downloading movies the fastest speed i have gotten was 14 kb/s and i should be getting around 600-700kb/s or (6-7 MB/s) does anyone know how to solve this problem??? i would appreciate the help......
 
Old 08-21-2006, 12:18 PM   #2
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: San Antonio, Texas
Distribution: Gentoo Hardened using OpenRC not Systemd
Posts: 1,452

Rep: Reputation: 85
You need to port forward some ports for azerus to use. Incase you do not know what I am talking about, see this website for your routers setup page http://192.168.1.1 or http://192.168.0.1 and if you need to, call the free tech support that should be provided by your router's manufacturer. I believe the that is the same for any bittorrent client. You might also want to check out bittornado for Linux. I've tried many, and it seems to be the best.
 
Old 08-21-2006, 12:44 PM   #3
mrkawphy
Member
 
Registered: Jun 2006
Location: Calgary, Alberta
Distribution: Fedora Core 6
Posts: 43

Rep: Reputation: 15
Also keep in mind that your share ratio can also impact your download speeds. People tend to set there clients to reject those who have a share ratio lower then 1.2 or something so until your sharing gets above this number alot of clients on the network will reject your connection. This is also recommended for you to do as well since you want to promote sharing and not leeching and by not setting your client up with these settings you will only have your bandwidth being pillaged by leeches when it should be going to others who also share! Hope this helps as well.
 
Old 08-21-2006, 02:49 PM   #4
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Original Poster
Rep: Reputation: 15
where can i get bittornado for suse linux 10.1???
 
Old 08-23-2006, 06:08 AM   #5
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: San Antonio, Texas
Distribution: Gentoo Hardened using OpenRC not Systemd
Posts: 1,452

Rep: Reputation: 85
I don't know about suse's package manager. Does suse compile all software from source code? If suse has a package manager, search it for bittornado. This is what I found from a google search. http://slackware.cs.utah.edu/slackwa...ra/bittornado/
If you want something different, you may get the most replies by asking in the suse part of the forum.
 
Old 08-23-2006, 06:39 AM   #6
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
Remember! there will be no different between the use of bittornado or whatever if you don't setup your router as fakie_flip described above.
 
Old 08-23-2006, 07:28 AM   #7
muddywaters
Member
 
Registered: May 2005
Location: Winnipeg, Canada
Distribution: mostly mepis
Posts: 427

Rep: Reputation: 30
Do you have any external hardware with port blocking ability? Router, modem/router etc?

If not, the problem is probably the Suse firewall. A simple (though possibly not 100% safe) test is to shut the firewall off temporarily.

In a terminal (as root):
rcSusefirewall2 stop

To restart:
rcSuSEfirewall2 start

Those are the commands as I remember them. If that doesn't work it can also done through YAST.

If shutting off the firewall cures the NAT error open the necessary ports in the firewall configuration. As best I remember (not using Suse at the moment):
yast->security->firewall->allowed services->external zone->advanced

In that window you should be able to match ports to an application.

edit/ Sorry for the typo, the first command should be;

rcSuSEfirewall2 stop

the uppercase letters are important

Last edited by muddywaters; 08-23-2006 at 06:32 PM.
 
Old 08-24-2006, 03:59 PM   #8
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Original Poster
Rep: Reputation: 15
im using a linksys wireless router , im using wireless internet
 
Old 08-25-2006, 01:07 AM   #9
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
Wink Did you already open the Ports?

Quote:
Originally Posted by .Alexandru.
im using a linksys wireless router , im using wireless internet
this is what fakie_ip told you already:
You need to port forward some ports for azerus to use. Incase you do not know what I am talking about, see this website for your routers setup page http://192.168.1.1 or http://192.168.0.1 and if you need to, call the free tech support that should be provided by your router's manufacturer. I believe the that is the same for any bittorrent client. You might also want to check out bittornado for Linux. I've tried many, and it seems to be the best.

Without Port Forward 6881 TCP in the NAT Options you will have also the NAT Problem in Azureus, Bittornado, Bt-Client, ABC Client, BT ++, Turbo BT, Bit Anarch, Bit Comet and so on...

I don't know if this link will work but it show a how to of the port forwarding.

http://linksys.custhelp.com/cgi-bin/linksys.cfg/php/enduser/std_adp.php?p_faqid=688&p_created=1084219690&p_sid=E_GGjXfi&p_accessibility=0&p_lva=&p_sp=cF9zcmNoPT EmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MTM1JnBfcHJvZHM9MCZwX2NhdHM9JnBfcHY9JnBfY3Y9JnBfc2Vhcm NoX3R5cGU9YW5zd2Vycy5zZWFyY2hfbmwmcF9zY2ZfbGFuZz0xJnBfcGFnZT0xJnBfc2VhcmNoX3RleHQ9cG9ydA**&p_li=&p_t opview=1"]LINK

Last edited by odcheck; 08-28-2006 at 06:53 AM.
 
Old 08-25-2006, 05:42 AM   #10
muddywaters
Member
 
Registered: May 2005
Location: Winnipeg, Canada
Distribution: mostly mepis
Posts: 427

Rep: Reputation: 30
See if your router is listed here;
http://www.portforward.com/
there is good general information there as well as advice for individual devices.

I'm not familiar with linksys or wireless, but chances are that device is a firewall as well as a router.
Configure one firewall at a time. First shutdown the firewall in SuSE while getting the linksys setup.

It is possible to use just the routers firewall and shutdown the software firewall permanently. However having
both running is no bad idea. It's how mine is setup, and azureus runs fine.

Edit/ Some isps have a nasty habit of throttling bittorrent traffic. If you have had better luck with bittorrent
in the past this possibility can probably be ruled out.

Last edited by muddywaters; 08-25-2006 at 05:50 AM.
 
Old 08-25-2006, 11:13 PM   #11
robgig1088
LQ Newbie
 
Registered: Aug 2006
Location: Louisiana
Distribution: Ubuntu Dapper
Posts: 23

Rep: Reputation: 15
as was stated, you need to log into your router and foreward the correct port (whichever one you chose) itll ask you for a username and password so look here for your router name =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Azureus Nat error DeltaFeegamma Linspire/Freespire 5 06-18-2006 08:06 PM
Azureus and NAT error :( Peleus Linux - Software 1 11-08-2005 07:53 AM
Azureus NAT Error... deac0ncho Mandriva 5 10-02-2005 04:11 AM
Nat error - azureus ceborame Linux - Newbie 1 09-03-2005 10:24 AM
nat error in azureus rosscopeeko Linux - Software 4 12-30-2004 11:04 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration