LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-02-2007, 10:18 AM   #1
vlholmes
LQ Newbie
 
Registered: May 2007
Distribution: Fedora core 6
Posts: 8

Rep: Reputation: 0
pppd dials, then quits


Trying to get FC6 to dial up my isp. I took the path of least resistance:
System -> Administration -> Network -> New ->
Modem connection...
hardware: Generic modem (mine is an Intel 536EP.)
...
System -> Administration -> Network
select the <ppp modem> line, and click activate. It dials, and the modems screech at each other, as usual. About 10 seconds after the modem sound goes off, my modem hangs up. Tail of /var/log/messages:

May 1 18:25:19 localhost wvdial[2563]: WvDial: Internet dialer version 1.54.0
May 1 18:25:19 localhost wvdial[2563]: Initializing modem.
May 1 18:25:19 localhost wvdial[2563]: Sending: ATZ
May 1 18:25:22 localhost wvdial[2563]: ATZ
May 1 18:25:26 localhost wvdial[2563]: OK
May 1 18:25:26 localhost wvdial[2563]: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
May 1 18:25:26 localhost wvdial[2563]: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
May 1 18:25:26 localhost wvdial[2563]: OK
May 1 18:25:26 localhost wvdial[2563]: Sending: ATM1L2
May 1 18:25:26 localhost wvdial[2563]: ATM1L2
May 1 18:25:26 localhost wvdial[2563]: OK
May 1 18:25:26 localhost wvdial[2563]: Modem initialized.
May 1 18:25:26 localhost wvdial[2563]: Sending: ATDT7200038
May 1 18:25:26 localhost wvdial[2563]: Waiting for carrier.
May 1 18:25:26 localhost wvdial[2563]: ATDT7200038
May 1 18:25:55 localhost wvdial[2563]: CONNECT 49333
May 1 18:25:55 localhost wvdial[2563]: Carrier detected. Chatmode finished.
May 1 18:25:55 localhost pppd[2510]: Serial connection established.
May 1 18:25:55 localhost pppd[2510]: Using interface ppp0
May 1 18:25:55 localhost pppd[2510]: Connect: ppp0 <--> /dev/modem
May 1 18:25:57 localhost pppd[2510]: Remote message: Unknown Client/Network
May 1 18:25:57 localhost pppd[2510]: PAP authentication failed
May 1 18:25:57 localhost pppd[2510]: Connection terminated.
May 1 18:25:58 localhost pppd[2510]: Exit.

I am using the same box with w98 to make this post, so I am relatively confident my hardware is OK. I am not sure which area would be most appropriate for this post. but newbee is me.
 
Old 05-02-2007, 11:06 AM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Are you sure PAP is the correct protocol? Have you tried PAP/CHAP or just CHAP? Looks like this is the problem, or an incorrect username/password.
I have the same modem, though I use Slackware, but if I can help with any /messages outputs or similar, or modem init-strings, feel free to ask.
 
Old 05-02-2007, 07:45 PM   #3
vlholmes
LQ Newbie
 
Registered: May 2007
Distribution: Fedora core 6
Posts: 8

Original Poster
Rep: Reputation: 0
pap v chap v pap/chap

I really appreciate your post. 'Fraid my original would get lost, they pile up so fast! But back to the subject.
I have the "let ppp negotiate authorization" box checked. I assumed it would sort out the alphabet soup for me. I did check papsecrets and chapsecrets. They both have correct login name and password entries. Generated by the wizard, I guess. I'm innocent.
I went back to the Intel web site today to look for a later version driver, but no luck with that. There are so many negative comments on the modem on linmodems.org that I am considering getting something else. Both @#$%^&%$ embedded serial ports on my mother board died, so I'm kinda stuck with using an internal.
Thanks again,
vern
 
Old 05-02-2007, 08:04 PM   #4
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Yup, these stupid PCI modems are for the most part useless.. But, when it's all you have, one must be determined.. If it's dialing and doing all it's doing chances are the driver is working. I would look into your init-lines. Misconfigured init lines can do this too, or just plain old 'wrong' stuff in the wvdial.conf file... Still looks to me like PAP isn't what it wants, but.. I dunno..
But if you want a brand new driver to try (I forget where I got it) I can email you mine.. Or if I find the link, I'll post it.

Last edited by GrapefruiTgirl; 05-02-2007 at 08:05 PM.
 
Old 05-02-2007, 08:17 PM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
http://linmodems.technion.ac.il/pack...lippe.Vouters/
http://linmodems.technion.ac.il/#archive

Found it.. The first link is where I got my driver, and the second is the main page, with lots of helpful stuff and links, including wvdial info.
 
Old 05-03-2007, 01:59 PM   #6
vlholmes
LQ Newbie
 
Registered: May 2007
Distribution: Fedora core 6
Posts: 8

Original Poster
Rep: Reputation: 0
wvdial config

1st: I like your windows definition
I saw a post on another group that ended: Computers are like air conditioners. they don't work well when you open windows.

Sorry 'bout the length of this one. I'll summarize here to save winnowing the chaff below.
My best guess at this point is that your suggestion that something more than pap is going to be required is correct. Tinkering with wvdial finally got me to a login and password prompt, but after wvdial sends the password the isp sends back 'unknown client/network'. (I assume this is coming back from the server. It isn't always easy (possible?) to tell.)
When I (finally) connected, the server sent:'** dial01.dllstx Terminal Server **'. Is this string something that should be in pap/chap-secrets? Wvdial and pppd both think vtisp or vtisp.com (I've tried it both ways) is my server, but the server never identifies itself that way. I haven't even figured out where to enable chap, if it isn't already. In fact chap implementation is a complete mystery to me, if you haven't already guessed.
Any additional ideas/suggestions would be greatly appreciated. I'm stumped. Thanks again.
vern

BTW, thanks for the links. I am using the driver you suggest. That link would have saved me a lot of time a couple of weeks ago. I should have started with the forums instead of ending with them.

the adventure continues...
Tried wvdial from root console:

[root@localhost ~]# wvdial vtisp
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: ATM1L2
ATM1L2
OK
--> Modem initialized.
--> Sending: ATDT7200038
--> Waiting for carrier.
ATDT7200038
CONNECT 49333
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Thu May 3 10:10:56 2007
--> pid of pppd: 3056
--> Using interface ppp0
--> pppd: sp
--> pppd: sp
--> pppd: sp
--> pppd: sp
--> pppd: sp
--> Disconnecting at Thu May 3 10:10:57 2007
--> The PPP daemon has died: Authentication error.
--> We failed to authenticate ourselves to the peer.
--> Maybe bad account or password? (exit code = 19)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 19)

No indication of any attempt at authentication.
My /etc/wvdial.conf looks like this:

[Modem0]
Modem = /dev/modem
Baud = 115200
SetVolume = 2
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM1L2
FlowControl = CRTSCTS
[Dialer vtisp]
Username = vlholmesjr@vtisp.com
Password = paranoia
Phone = 7200038
Stupid Mode = 1
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Inherits = Modem0

Tried 'Stupid Mode =0'. Omitting the repetitive stuff I got:

[root@localhost ~]# wvdial vtisp

--> Carrier detected. Waiting for prompt.
--> Connected, but carrier signal lost! Retrying...
--> Sending: ATDT7200038
--> Waiting for carrier.
** dial01.dllstx Terminal Server **
Login:
Login:
Login:
Login: ATDT7200038
Password:

--> Timed out while dialing. Trying again.
--> Sending: ATDT7200038
--> Waiting for carrier.

A login prompt looked promising, so I added 'Carrier Check = 0', and again without the repetitive stuff:

--> Carrier detected. Waiting for prompt.
** dial01.dllstx Terminal Server **
Login:
--> Looks like a login prompt.
--> Sending: vlholmesjr@vtisp.com
vlholmesjr@vtisp.com
Password:
--> Looks like a password prompt.
--> Sending: (password)
Unknown Client/Network
Login:
--> Looks like a login prompt.
--> Sending: vlholmesjr@vtisp.com
vlholmesjr@vtisp.com
Password:
--> Looks like a password prompt.
--> Sending: (password)
Unknown Client/Network
Login:
--> Looks like a login prompt.
--> Sending: vlholmesjr@vtisp.com
--> Don't know what to do! Starting pppd and hoping for the best.
--> Starting pppd at Thu May 3 10:47:30 2007
--> pid of pppd: 7622
--> Using interface ppp0
--> pppd: sp
--> pppd: sp
--> pppd: sp
--> pppd: sp
--> pppd: sp
--> Disconnecting at Thu May 3 10:47:34 2007
--> The PPP daemon has died: Authentication error.
--> We failed to authenticate ourselves to the peer.
--> Maybe bad account or password? (exit code = 19)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 19)

At least it tried to log in this time! Progress of a sort. Hashed the password line and added 'Ask Password = 1' line with same results as previous.
 
Old 05-03-2007, 02:08 PM   #7
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
OK, I'll thoroughly read your post, but first:

IF you have a GUI for PPP, Start PPP/Kppp/Gppp or whatever GUI you have, if you have one.
Select Configure ---> Accounts ---> highlight account --> edit --> Authentication: PAP/CHAP --> OK

And try this to see if it fixes the authentication thing.I'll go over your post and see if anything stands out..
 
Old 05-03-2007, 02:10 PM   #8
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
And you know, another thing I learned, when using PPP, was to look in /dev and see if you have a character device in there called 'ppp'. Because if it doesn't exist, pppd will die.
If you do NOT have a ppp in your /dev folder, let me know, Ill dig out the major/minor numbers for you so you can make one.

ALSO - Post us your wvdial.conf file?

Last edited by GrapefruiTgirl; 05-03-2007 at 02:14 PM.
 
Old 05-04-2007, 03:37 AM   #9
pilatus666
Member
 
Registered: Mar 2006
Location: cyprus
Distribution: Mandriva 2009.0;
Posts: 263

Rep: Reputation: 30
I don't know if this one works for you but in the last error message you've got this line: We failed to authenticate ourselves to the peer. I had the same message (using on adsl usb modem) for me it did the folowing trick: in the pap and chap secrets files use only your username whitout the @isp form and also in your vdial.conf file and everywhere you need to insert your username... so the form is: username and NOT username@isp
Try it maybe it will work for you to.... Good luck
 
Old 05-04-2007, 09:52 AM   #10
vlholmes
LQ Newbie
 
Registered: May 2007
Distribution: Fedora core 6
Posts: 8

Original Poster
Rep: Reputation: 0
more permutations eliminated

Words are not adequate to express my gratitude for the time and effort you have invested in my problem!

[root@localhost ~]# ls -l /dev/ppp
crw------- 1 root root 108, 0 May 4 09:18 /dev/ppp

Removing the "@vtisp" portion of the login name still results in an "unknown client/network" response from the server. Whenever I go through the GUI 'System -> Administration -> Network' to change anything it removes the 'Carrier Check = 0' line, and resets the 'Stupid Mode = ' to 1. Also, nowhere in the 'System -> Administration -> Network' area do I find mention of chap or pap/chap. I know it's there, somewhere, but I haven't stumbled across where Fedora put it, yet.
Follows a copy of wvdial.conf and as a bonus, chap-secrets too. The GUI admin adds lines at the bottom of pap and chap secrets with special characters escaped. I dont think this is a problem, but thought I'd let someone with more knowledge than myself see.

wvdial.conf:
[Modem0]
Modem = /dev/modem
Baud = 115200
SetVolume = 2
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM1L2
FlowControl = CRTSCTS
[Dialer vtisp]
Username = vlholmesjr
Password = paranoia
Phone = 7200038
Stupid Mode = 0
Carrier Check = 0
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Inherits = Modem0

chap-secrets:
# Secrets for authentication using CHAP
# client server secret IP addresses
####### redhat-config-network will overwrite this part!!! (begin) ##########
"vlholmesjr" "vtisp" "paranoia"
"vlholmesjr" * "paranoia"
####### redhat-config-network will overwrite this part!!! (end) ############
\'vlholmesjr\@vtisp\.com\' * \'paranoia\'
vlholmesjr\@vtisp\.com * paranoia
vlholmesjr\\\@vtisp\.com * paranoia
vlholmesjr * paranoia
 
Old 05-04-2007, 05:17 PM   #11
St.Jimmy
Member
 
Registered: Jun 2006
Location: Boaz,Alabama
Distribution: Ubuntu 10.10 / Windows 7 Pro 64-Bit / Snow Leopard 10.6.4 64-Bit
Posts: 152

Rep: Reputation: 30
I get these a lot when I set up my modem. set FlowControl = to "XONXOFF" try adding "VTISP/" or "vtisp/" to the uname and look in your inbox for the setup instructions they sent you.
 
Old 05-04-2007, 11:18 PM   #12
vlholmes
LQ Newbie
 
Registered: May 2007
Distribution: Fedora core 6
Posts: 8

Original Poster
Rep: Reputation: 0
chap & XON/XOFF

I tried software flow control, to no avail. Then tried 'require-chap' in ppp options. Also no success. This has almost become "fun".
Probably ought to mention I tried both suggestions and also tried 'require-pap' with and without the '@vtisp.com' suffix on the login name.

Last edited by vlholmes; 05-05-2007 at 09:32 AM.
 
Old 06-13-2007, 06:21 AM   #13
Sepero
Member
 
Registered: Jul 2004
Location: Tampa, Florida, USA
Distribution: Ubuntu
Posts: 734
Blog Entries: 1

Rep: Reputation: 32
This is most likely your wvdial problem:
Stupid Mode = 0

If you're still struggling with this, the following script should get you connected real fast. Just save it to the file /etc/wvdial.conf, and put in your info:
Code:
[Dialer Defaults]
#Modem = /dev/modem
Modem = /dev/536ep0
Baud = 115200
Init = ATZ
New PPPD = yes
Stupid Mode = 1
Auto Reconnect = off
#Carrier Check = no
Dial Attempts = 1

# MODIFY THE FOLLOWING 3 SECTIONS FOR YOUR CONNECTION
Phone = 1234567
Username = ExampleName
Password = ExamplePassword
For anyone that uses Ubuntu Feisty 7.04 with the 536ep, I have created a precompiled package for you here:
http://ubuntuforums.org/showthread.php?t=471503


sep
 
Old 06-14-2007, 08:49 AM   #14
vlholmes
LQ Newbie
 
Registered: May 2007
Distribution: Fedora core 6
Posts: 8

Original Poster
Rep: Reputation: 0
wvdial

To Serpero and all others: Thanks.
Yes stupid mode is required by my isp. I have semi-resolved the problem by doing a complete reinstall. I will never know if my original problem was debris left by first installing the modem driver for the 2.4 kernel, of (more likely) something I did when I was in 'Stupid Mode'! Cone to think of it, installing the wrong driver was pretty stupid of me, too.
Anyway, I want to thank everyone who kindly offered advice and encouragement, and also LQ for providing the forum.
vern
 
Old 06-16-2007, 01:28 AM   #15
Sepero
Member
 
Registered: Jul 2004
Location: Tampa, Florida, USA
Distribution: Ubuntu
Posts: 734
Blog Entries: 1

Rep: Reputation: 32
With the 536ep modem and wvdial, I find it mandatory to have this "Stupid Mode = 1".

I don't know why, I just know it works.
 
  


Reply

Tags
fedora 6


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
softmodem v92 no dials trifonasb Linux - Hardware 2 02-18-2006 04:53 PM
softmodem v92 no dials trifonasb Linux - Networking 1 02-18-2006 04:15 PM
pppd timeout before pppd interface could start! bioagentice Linux - Software 6 03-27-2005 11:24 AM
pppd died: pppd options error (exit code 2 taveirac Linux - Networking 1 02-12-2004 10:17 AM
pppd died: pppd options error (exit code 2) ianwest Linux - Newbie 2 07-31-2002 08:29 AM


All times are GMT -5. The time now is 11:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration