LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-30-2001, 10:08 AM   #1
frazz
LQ Newbie
 
Registered: Aug 2001
Location: not in the real world thats 4 sure
Distribution: Mandrake 8
Posts: 11

Rep: Reputation: 0
ppp blues


hmm i have got a problem with something to do with my PPP.
I try to connect to the net using kppp an i jus get an error 16 saying that ppp deamon dies unexpectedly.
so i have tried to update my latest version to 2.1.4 (kppp) an still the problem occurs.
I have tried Wvdial commandline app an also i still get no joy.
here are the results i have got
kppp:

ATZJ
OK
ATM0L0

OK
ATDT<phone number>

CONNECT 38666/ARQ


Sep 30 14:29:47 localhost pppd[2645]: pppd 2.4.1 started by root, uid 0
Sep 30 14:29:47 localhost pppd[2645]: Using interface ppp0
Sep 30 14:29:47 localhost pppd[2645]: Connect: ppp0 <--> /dev/ttyS1
Sep 30 14:30:11 localhost pppd[2645]: Hangup (SIGHUP)
Sep 30 14:30:11 localhost pppd[2645]: Modem hangup
Sep 30 14:30:11 localhost pppd[2645]: Connection terminated.
Sep 30 14:30:11 localhost pppd[2645]: Exit.

and using wvdial i get this;

Sep 30 14:29:47 localhost pppd[2645]: pppd 2.4.1 started by root, uid 0
Sep 30 14:29:47 localhost pppd[2645]: Using interface ppp0
Sep 30 14:29:47 localhost pppd[2645]: Connect: ppp0 <--> /dev/ttyS1
Sep 30 14:30:11 localhost pppd[2645]: Hangup (SIGHUP)
Sep 30 14:30:11 localhost pppd[2645]: Modem hangup
Sep 30 14:30:11 localhost pppd[2645]: Connection terminated.
Sep 30 14:30:11 localhost pppd[2645]: Exit.

I get an error 16 at this point when using kppp 2.1.4 , another interesting thing is the kppp
configuration tab under About kppp it says its version 2.0.3 when i have updated to the above
Yet in the misc tab it says pppd version 2

ALSO when i try to execute wvdial thro the commandline i get this

--> WvDial : Internet dialer version 1.42
--> initializing modem
--> Sending ATZ
ATZ
OK
--> Sending ATQ0 V1 E1 SO= &C1 &D2 S11=55 +FCLASS=0
ATQ0 V1 E1 SO=0 &C1 &D2 S11=55 +FCLASS=0
OK
--> MODEM INITIALISED
--> Sending: ATDT <phone number>
--> Waiting for carrier
ATDT <phone number>
CONNECT 38666/ARQ
--> CARRIER DETECTED. WAITING FOR PROMPT

(THEN LOTS OF NOTHING)

Returning not OK!!
Disconnecting

I know my isp uses Chap authentification if thats anyhelp but it seems to be down to the ppp deamon maybe??
I have tried this both as user and as root too an no joy.

Ok if you could explain in idiot language if u got an answer TX
 
Old 10-01-2001, 02:35 AM   #2
harrygraham
Member
 
Registered: Apr 2001
Location: Ottawa, Canada
Distribution: Mint Cinnamon AMD64
Posts: 155

Rep: Reputation: 18
problem with Kppp

There are a lot of things that could be wrong, even without going too deep. Sometimes it is easier to edit the ppp files directly rather than trusting the Kppp program. In your case, it might be that your computer is not identifying itself to the server. This happened to me many times until I manually edited the etc/ppp/pap-secrets file. In your case it would be the etc/ppp/chap-secrets file since you are using chap. I found that Kppp sometimes writes these files incorrectly, especially if you change the values and try again a few times. Seems like it's disconnecting right when it's supposed to authenticate the password.

Hope this helps.

Keep trying. It's only a matter of time before you get things working.

Harry
 
Old 10-01-2001, 11:46 PM   #3
rolf
Member
 
Registered: Jul 2001
Location: Oakland, CA
Distribution: Mageia 5 x86_64
Posts: 186

Rep: Reputation: 33
If you're still stymied....

....Try this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to link linux ppp client to windows ppp server? cyz Linux - Networking 2 12-11-2008 06:01 AM
ENS1371 blues again!!!! Sorry!!! vijayind Debian 3 03-05-2005 03:33 PM
Looking for man ppp-on and info ppp-on pages. rvijay Linux - General 1 02-26-2005 09:49 PM
'ps' Blues Odd_Bloke Linux - Newbie 3 08-30-2003 01:03 AM
CD-Rom blues.... r_jensen11 Linux - Newbie 5 05-06-2003 10:13 PM


All times are GMT -5. The time now is 04:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration