LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-09-2004, 10:27 AM   #1
SGFHK321
Member
 
Registered: Jul 2004
Location: Hong Kong
Posts: 78

Rep: Reputation: 15
Power off in Mandrake 10


Hi. This is only a small problem but it really bugs me: My Mandrake Linux 10 does not cut power automatically when I commanded it to power off like Windows does. I have to push the power button in the end. I wonder how do I make mandrake shut down like Windows?
 
Old 07-09-2004, 10:45 AM   #2
linux_ub
Member
 
Registered: May 2004
Location: NY
Distribution: fedora core 1
Posts: 65

Rep: Reputation: 18
even i have the same problem. i am running Fedora core 1 on dell Latitude D500
 
Old 07-09-2004, 11:57 AM   #3
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
I know this is not helpful, but I am running Mandrake 10 and DO NOT have that problem...

Could this be a machine-specific problem? Is there perhaps something in the BIOS that needs changing?

Just a thought...
 
Old 07-09-2004, 12:10 PM   #4
linux_ub
Member
 
Registered: May 2004
Location: NY
Distribution: fedora core 1
Posts: 65

Rep: Reputation: 18
i donnno ... because it does auto power off when shutting down windows
 
Old 07-09-2004, 09:16 PM   #5
SGFHK321
Member
 
Registered: Jul 2004
Location: Hong Kong
Posts: 78

Original Poster
Rep: Reputation: 15
Yeah and even Fedora 2 does.
 
Old 07-09-2004, 09:30 PM   #6
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
i think there might be some software that u need to install before it works. though i forgot which...hehe. i have a laptop and it didnt' shut down til i install some acpi drivers.
 
Old 07-09-2004, 09:47 PM   #7
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Rep: Reputation: 31
I think it's machine specific sometimes...certain jumper setting on the motherboard or something. My FC2 shuts down just fine. My Windows Server box doesn't but that's just the way it is...it's older.
 
Old 07-09-2004, 10:25 PM   #8
SGFHK321
Member
 
Registered: Jul 2004
Location: Hong Kong
Posts: 78

Original Poster
Rep: Reputation: 15
I fixed the problem.
You just need to enable ACPI .
 
Old 07-10-2004, 08:15 AM   #9
Skankpuss
Member
 
Registered: Nov 2003
Location: England
Distribution: mandriva 2005 le
Posts: 37
Blog Entries: 1

Rep: Reputation: 15
Yeah, I stuggled with this lots.

Different motherboards (I think) will respond differently to the default settings in linux.

on mine I had to edit /etc/lilo.conf and include
acpi=force or acpi=ht
in the append line for the kernel I was booting with.

**Don't forget to run lilo-v before rebooting!!!***

This worked fine in mandrake 10, but I had to recompile the kernel with mdk9.2 in order for the machine to turn off, and believe me that was no picnic, and I didn't get everything back up to scratch until I reinstalled mdk 10,

Short answer: try acpi=force, then if that doesn't work deal with the fact that you'll be pressing the power button until 'they' sort it out

 
Old 07-10-2004, 11:48 AM   #10
coopns
Member
 
Registered: Jan 2004
Location: Scituate, MA
Distribution: Mandrake 10
Posts: 94

Rep: Reputation: 15
I am having the same problem.

When you say "I fixed the problem. You just need to enable ACPI".

I am using Man 10, so how would I do that?


Thanks.
 
Old 07-10-2004, 12:17 PM   #11
SGFHK321
Member
 
Registered: Jul 2004
Location: Hong Kong
Posts: 78

Original Poster
Rep: Reputation: 15
I ran the installation again and selected Enable ACPI when it asked.
 
Old 07-10-2004, 09:59 PM   #12
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Same deal for me when I started using the latest 2.6 kernels, especially when I started playing with Gentoo. My solution (which should be 1/2 done with any Mandrake install anyways - the kernel is full of stuff) was to do the acpi=force in the bootloader. I'm using grub now (I suggest it....it really is better) and the same rule applies.

So for lilo, you'd out in the acpi=force in the append= line and for grub you'd add acpi=force to the end of the kernel= line. Good luck.
 
Old 07-11-2004, 11:37 AM   #13
coopns
Member
 
Registered: Jan 2004
Location: Scituate, MA
Distribution: Mandrake 10
Posts: 94

Rep: Reputation: 15
"So for lilo, you'd out in the acpi=force in the append= line and for grub you'd add acpi=force to the end of the kernel= line."

So the acpi is in /etc/lilo.conf is it?

/etc/lilo.conf and include acpi=force or acpi=ht

and I do have to run lilo -v before rebooting as mentioned below, and what do that do?

Also, if I did want to change to grub bootloader, is that a big process.

Keep'er simple please.
 
Old 07-11-2004, 12:30 PM   #14
amon
Member
 
Registered: May 2004
Location: UK
Distribution: Debian, Ubantu, CentOS
Posts: 146

Rep: Reputation: 17
Mandrake 10 solution

this is the easy way of doing it in mandrake 10
while there are millions of benifits to learning to edit text files for a noob (i'm still one) that isn't the friendliest way of doing it.

ok in your graphical user interface (KDE or Gnome probably)

{start/K button/Applications button} > System > Configuration > configure your computer

it will ask you for your ROOT password

select the "boot" icon

select "boot loader"

and tick the box labled "Enable ACPI"

then click the "next" button

then "finnish"

then when you reboot all will be working and it will power off when you turn you computer off.
NOTE: you may need to reboot to make this work.
 
Old 07-11-2004, 12:34 PM   #15
amon
Member
 
Registered: May 2004
Location: UK
Distribution: Debian, Ubantu, CentOS
Posts: 146

Rep: Reputation: 17
Quote:
Originally posted by Basslord1124
I think it's machine specific sometimes...certain jumper setting on the motherboard or something. My FC2 shuts down just fine. My Windows Server box doesn't but that's just the way it is...it's older.
older hardware doesn't allow the automatic power controle on any operaiting system. i think that it only cam in 5 - 7 years ago. although some servers didn't bother to put it in till a little later
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Power Off in Mandrake 10.0 hacchan Mandriva 1 05-31-2005 09:36 PM
No power down after shutdown (Mandrake) JohnA Linux - Hardware 14 02-24-2005 01:47 AM
Mandrake and power down eqxro Mandriva 2 09-18-2004 11:14 AM
Mandrake 10 doesn't auto power off vas_dee Linux - Laptop and Netbook 12 05-27-2004 08:39 PM
Power Manager on Mandrake 9.2 blandman Linux - Laptop and Netbook 8 04-16-2004 11:22 AM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration