LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2004, 10:13 AM   #1
dhruiz
LQ Newbie
 
Registered: Sep 2003
Distribution: DEBIAN WOODY
Posts: 7

Rep: Reputation: 0
Postgress TCP/IP connection at Startup


Hi,
I'm beginning to work with Postgres (7.4) and I have a silly question. I can't connect with my database through TCP/IP immediately after start my system. I need to shutdown postmaster and restart it with the "-i" option.After that, everything works fine, what means that the configuration files are OK. My question is:
How can I do in order to start postmaster with "-i" option during my system startup ???

Thanks

D
 
Old 10-22-2004, 10:19 AM   #2
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
sounds like you have to add the -i option to the bootscript where the postgresql server is started. I see you have debian woody wich I don't know, but on most distro's the bootscripts are located at /etc/rc.d or /etc/init.d. search there for a script wich starts postgresql.

greetz,
.-=~ iluvatar ~=-.
 
Old 10-28-2004, 09:30 AM   #3
dhruiz
LQ Newbie
 
Registered: Sep 2003
Distribution: DEBIAN WOODY
Posts: 7

Original Poster
Rep: Reputation: 0
Hi,
I found this line in the script postgresql under /etc/init.d, should I add a "-i" option after --start ?.

(/sbin/start-stop-daemon --pidfile $PGDATA/postmaster.pid --chuid postgres --startas /usr/lib/postgresql/bin/postgresql-startup --start 2>&1
 
Old 10-28-2004, 11:01 AM   #4
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
I think you should add it before the --start...

greetz,
.-=~ iluvatar ~=-.
 
Old 10-29-2004, 10:05 AM   #5
dhruiz
LQ Newbie
 
Registered: Sep 2003
Distribution: DEBIAN WOODY
Posts: 7

Original Poster
Rep: Reputation: 0
Actually,
it should be after --start and without anything just i, because parameter format for the start-stop daemons in Debian.

Thank you so much for your help !!!!!

D
 
Old 10-29-2004, 10:09 AM   #6
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
Quote:
because parameter format for the start-stop daemons in Debian.
sorry, didn't know that....

greetz,
.-=~ iluvatar ~=-.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hijacking tcp connection atul_mehrotra Linux - Networking 4 04-30-2005 01:50 AM
enabling tcp/ip connection via pg_ctl vickr1z Linux - Newbie 3 10-19-2004 07:21 AM
MySQL connection over TCP/IP fails Rukawa Linux - Software 4 11-30-2003 12:30 AM
Unable to get TCP/IP connection kgunnar Linux - Newbie 9 05-01-2002 05:24 AM
Bridging subnet over tcp-connection ? lhm Linux - Networking 0 06-30-2001 05:38 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration