LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-20-2010, 04:04 AM   #1
pra838
Member
 
Registered: Feb 2010
Location: Sri Lanka
Posts: 47

Rep: Reputation: 0
Post Postfix status = sent but not received to Maildir


[root@mail ~]# tail -f /var/maillog

from=<prasad@asasas.com>
Feb 20 11:48:42 mail postfix/qmgr[31233]: A32CE1691E7: from=<prasad@asasas.com>, size=1384, nrcpt=1 (queue active)
Feb 20 11:51:42 mail postfix/pickup[22619]: 624AD1691B5: uid=12347

[root@mail ~]# cat /var/log/maillog | grep A32CE1691E7 (<-- Que ID)

Feb 20 11:51:42 mail postfix/pickup[22619]: A32CE1691E7: uid=12347 from=<prasad@asasas.com>
Feb 20 11:51:42 mail postfix/cleanup[18307]: A32CE1691E7: message-id=<20100220115142.23082mi2hoxj0eck@mail.asasascom>
Feb 20 11:51:42 mail postfix/qmgr[31233]: A32CE1691E7: from=<prasad@asasas.com>, size=1384, nrcpt=1 (queue active)
Feb 20 11:51:42 mail postfix/local[23395]: A32CE1691E7: to=<kithsiri@bg.asasas.com>, relay=local, delay=0.07, delays=0.06/0/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)
Feb 20 11:51:42 mail postfix/qmgr[31233]: 624AD1691B5: removed


But user "kithsiri" didn't received mail.
This server has morethan 100 users. Kithsiri is only one user and work fine 2 days ago.Did not do any configurations last week.
Please help to resolve this issue.

Thanks
Pra838
 
Old 02-20-2010, 04:45 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,299

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
How have you configured delivery?
postfix will throw stuff into /var/spool, but then if you have set a delivery agent (e.g. procmail) it will deliver that way.
 
Old 02-21-2010, 01:21 AM   #3
pra838
Member
 
Registered: Feb 2010
Location: Sri Lanka
Posts: 47

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by business_kid View Post
How have you configured delivery?
postfix will throw stuff into /var/spool, but then if you have set a delivery agent (e.g. procmail) it will deliver that way.
Thanks/

Configured all users same manner.
Why one user not received mails from same domain.But he received mails from other domains.Also he can send mails to his domain and other domains.

What is "postfix/pickup" in maillog.

Please explain.

Thanks
pra838
 
Old 02-21-2010, 03:23 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,299

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
I've done this, but I'm not a mail expert. Usual thing there is this: postfix has a few separate processes - last one is to queue the mail. The mailbox must be perms 0600 and the last process (maildrop?) is started as receiving user. Root cannot receive mail - and you need to use an alias. In my experience, once the main config file is ok, mistakes are down to you. Postfix will not drop into a mailbox that isn't 0600, IIRC. Did that user run a chmod -R?
 
Old 02-23-2010, 09:44 PM   #5
pra838
Member
 
Registered: Feb 2010
Location: Sri Lanka
Posts: 47

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by business_kid View Post
I've done this, but I'm not a mail expert. Usual thing there is this: postfix has a few separate processes - last one is to queue the mail. The mailbox must be perms 0600 and the last process (maildrop?) is started as receiving user. Root cannot receive mail - and you need to use an alias. In my experience, once the main config file is ok, mistakes are down to you. Postfix will not drop into a mailbox that isn't 0600, IIRC. Did that user run a chmod -R?

Thanks your help.

Permission are same as other users and also 0600.
sendmail use to mail delivery.

Thanks
 
Old 08-07-2012, 06:53 AM   #6
chidhambaram7
LQ Newbie
 
Registered: Oct 2010
Posts: 25

Rep: Reputation: 0
Hi,
I have same problem, can u any help me to fix this issue.
I'm using postfix and cyrus imap server


Thanks,
Chidhambaram
 
  


Reply

Tags
postfix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel: usbhid: input irq status -75 received Spoof Linux - Hardware 2 12-10-2008 06:39 AM
Postfix and Maildir h725 Linux - Server 3 07-18-2008 09:50 AM
Postfix and Maildir help dalrq79 Linux - Server 5 12-13-2007 08:22 PM
New to Postfix and Maildir kevlarmcc Linux - Server 5 03-17-2007 09:35 PM
postfix dovecot Maildir Danny Regan Debian 3 11-15-2005 04:08 PM


All times are GMT -5. The time now is 03:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration