LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2009, 02:45 AM   #1
PankajRasuni
LQ Newbie
 
Registered: Nov 2009
Posts: 18

Rep: Reputation: 0
postfix mail server


iam configuring my postfix mail server. Every thing is running fine...
clamd
amavisd
postfix
dovecot
when iam sending mail from a user to another user..it always showing a error message of being deferred..
I have setup all mx records correctly...but then the problem is prevailing
plz help
Dec 7 13:12:58 mail sendmail[8202]: nB77gwlV008202: Authentication-Warning: mail.phk.com: apache set sender to pappu@phk.com using -f
Dec 7 13:12:58 mail sendmail[8202]: nB77gwlV008202: from=pappu@phk.com, size=518, class=0, nrcpts=1, msgid=<2048.192.168.0.248.1260171778.squirrel@192.168.0.118>, relay=apache@localhost
Dec 7 13:12:58 mail sendmail[8202]: nB77gwlV008202: to=pappu@phk.com, delay=00:00:00, mailer=esmtp, pri=30518, dsn=4.4.3, stat=queued
Dec 7 13:15:30 mail sendmail[15061]: nB77jUQK015061: Authentication-Warning: mail.phk.com: apache set sender to pappu@phk.com using -f
Dec 7 13:15:30 mail sendmail[15061]: nB77jUQK015061: from=pappu@phk.com, size=514, class=0, nrcpts=1, msgid=<2078.192.168.0.128.1260171930.squirrel@192.168.0.118>, relay=apache@localhost
Dec 7 13:15:30 mail sendmail[15061]: nB77jUQK015061: to=ram@phk.com, delay=00:00:00, mailer=esmtp, pri=30514, dsn=4.4.3, stat=queued

after some time it show deferred
 
Old 12-08-2009, 02:45 AM   #2
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
The logs you have posted are not postfix logs they are sendmail logs, it seems like sendmail is still your default mta.
 
Old 12-08-2009, 03:53 AM   #3
eth1
Member
 
Registered: May 2008
Posts: 97

Rep: Reputation: 20
Stop sendmail,

Quote:
/etc/init.d/sendmail stop

Disable sendmail from starting on boot,

Quote:
chkconfig sendmail off
Quote:
/etc/init.d/postfix start
Quote:
chkconfig postfix on
 
Old 12-09-2009, 05:21 AM   #4
PankajRasuni
LQ Newbie
 
Registered: Nov 2009
Posts: 18

Original Poster
Rep: Reputation: 0
Dec 9 04:31:24 mail postfix/smtp[32633]: ADC701C816F: to=<user1@jhol.com>, relay=none, delay=0.24, delays=0.22/0.01/0.01/0, dsn=5.4.6, status=bounced (mail for jhol.com loops back to myself)
now iam facing this error .
however i had stopped the sendmail service. also configured the dns mx records properly..plz help
 
Old 12-09-2009, 05:27 AM   #5
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
Mail loops back to u because you have confgured the MX to point to your address but not configured postfix to accept mail for that domain.

To fix add your domain name to mydestinations in your main.cf file.
 
Old 12-10-2009, 03:48 AM   #6
PankajRasuni
LQ Newbie
 
Registered: Nov 2009
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by datopdog View Post
Mail loops back to u because you have confgured the MX to point to your address but not configured postfix to accept mail for that domain.

To fix add your domain name to mydestinations in your main.cf file.

i had already done all this
..but some times Im getting a deferred message
message is being queued for a long time..after then it gets deferred.
i have configured amavis, dovecot, postfix ...up to the mark & restarted all their services.
Dec 10 13:21:27 mail sendmail[27219]: nBA7pRnV027219: to=pr@example.com, delay=00:00:00, mailer=esmtp, pri=60541, dsn=4.4.3, stat=queued
Dec 10 13:21:28 mail sendmail[27219]: nBA7pRnV027219: to=ramkumar@example.com, delay=00:00:01, mailer=esmtp, pri=60541, dsn=4.4.3, stat=queued

after some time it gets deferred
plz help
 
Old 12-10-2009, 03:51 AM   #7
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
Seems like you are back to running sendmail again, did you use alternative --set-mta to change your default mta ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix,Open web mail Mail Server Hostname /FQDN Porblem farrukhndm Linux - Server 7 02-18-2009 06:35 PM
Ubuntu server with postfix. My mail goes to Spam in Gmail and Yahoo Mail. Ideeas? bob808 Linux - Server 4 02-07-2009 04:11 PM
Postfix Mail server to relay mail for dynamic IP clients seventy-7 Linux - Server 2 01-28-2009 02:59 AM
LXer: Debian Mail Server Setup with Postfix + Dovecot + SASL + Squirrel Mail LXer Syndicated Linux News 0 03-12-2008 10:50 PM
Postfix mail server not accepting incoming mail from the external interface rexmundi Linux - Networking 7 12-22-2003 03:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration