LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2006, 09:19 PM   #31
squirtle
Member
 
Registered: Jun 2006
Posts: 55

Original Poster
Rep: Reputation: 15

cat sample-spam.txt | sendmail bing@mailv6.fsktm.upm.edu.my
Oct 11 15:37:59 mailv6 postfix/qmgr[2223]: A30A887ED2: removed
Oct 11 15:38:34 mailv6 sendmail[7146]: k9B7cRS8007146: from=root, size=4656, class=0, nrcpts=1, msgid=<N1msdrbJXNPfV4wg9>, relay=root@localhost
Oct 11 15:38:34 mailv6 postfix/smtpd[7116]: connect from localhost.localdomain[127.0.0.1]
Oct 11 15:38:34 mailv6 postfix/smtpd[7116]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Oct 11 15:38:35 mailv6 postfix/smtpd[7116]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Oct 11 15:38:35 mailv6 sendmail[7146]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Oct 11 15:38:35 mailv6 postfix/smtpd[7116]: 189A987ED7: client=localhost.localdomain[127.0.0.1], sasl_sender=root@mailv6.fsktm.upm.edu.my
Oct 11 15:38:39 mailv6 postfix/cleanup[7119]: 189A987ED7: message-id=<N1msdrbJXNPfV4wg9>
Oct 11 15:38:39 mailv6 postfix/qmgr[2223]: 189A987ED7: from=<root@mailv6.fsktm.upm.edu.my>, size=5142, nrcpt=1 (queue active)Oct 11 15:38:39 mailv6 sendmail[7146]: k9B7cRS8007146: to=bing@mailv6.fsktm.upm.edu.my, ctladdr=root (0/0), delay=00:00:12, xdelay=00:00:05, mailer=relay, pri=34656, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 189A987ED7)
Oct 11 15:38:39 mailv6 postfix/smtpd[7116]: disconnect from localhost.localdomain[127.0.0.1]
Oct 11 15:38:39 mailv6 amavis[5296]: (05296-06) Blocked SPAM, [63.10.249.142] <root@mailv6.fsktm.upm.edu.my> -> <bing@localhost.localdomain>, quarantine: spam-0iQPKg+HAaVS.gz, Message-ID: <N1msdrbJXNPfV4wg9>, mail_id: 0iQPKg+HAaVS, Hits: 11.698, 399 ms
Oct 11 15:38:39 mailv6 postfix/smtp[7120]: 189A987ED7: to=<bing@localhost.localdomain>, relay=127.0.0.1[127.0.0.1], delay=4, status=sent (250 2.5.0 Ok, id=05296-06, BOUNCE)
Oct 11 15:38:39 mailv6 postfix/qmgr[2223]: 189A987ED7: removed

Oct 11 15:45:15 mailv6 sendmail[7268]: k9B7j5Xx007268: from=root, size=6493, class=-30, nrcpts=1, msgid=<v0421010eb70653b14e06@[208.192.102.193]>, relay=root@localhost
Oct 11 15:45:18 mailv6 postfix/smtpd[7275]: connect from localhost.localdomain[127.0.0.1]
Oct 11 15:45:18 mailv6 postfix/smtpd[7275]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Oct 11 15:45:18 mailv6 postfix/smtpd[7275]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Oct 11 15:45:18 mailv6 sendmail[7268]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Oct 11 15:45:19 mailv6 postfix/smtpd[7275]: 255A387ED8: client=localhost.localdomain[127.0.0.1], sasl_sender=root@mailv6.fsktm.upm.edu.my
Oct 11 15:45:24 mailv6 postfix/cleanup[7280]: 255A387ED8: message-id=<v0421010eb70653b14e06@[208.192.102.193]>
Oct 11 15:45:25 mailv6 sendmail[7268]: k9B7j5Xx007268: to=bing@mailv6.fsktm.upm.edu.my, ctladdr=root (0/0), delay=00:00:20, xdelay=00:00:10, mailer=relay, pri=90493, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 255A387ED8)
Oct 11 15:45:25 mailv6 postfix/qmgr[2223]: 255A387ED8: from=<root@mailv6.fsktm.upm.edu.my>, size=7079, nrcpt=1 (queue active)Oct 11 15:45:25 mailv6 postfix/smtpd[7275]: disconnect from localhost.localdomain[127.0.0.1]
 
Old 10-11-2006, 09:20 PM   #32
squirtle
Member
 
Registered: Jun 2006
Posts: 55

Original Poster
Rep: Reputation: 15
cat sample-nonspam.txt | sendmail bing@mailv6.fsktm.upm.edu.my
Oct 11 15:45:24 mailv6 postfix/cleanup[7280]: 255A387ED8: message-id=<v0421010eb70653b14e06@[208.192.102.193]>
Oct 11 15:45:25 mailv6 sendmail[7268]: k9B7j5Xx007268: to=bing@mailv6.fsktm.upm.edu.my, ctladdr=root (0/0), delay=00:00:20, xdelay=00:00:10, mailer=relay, pri=90493, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 255A387ED8)
Oct 11 15:45:25 mailv6 postfix/qmgr[2223]: 255A387ED8: from=<root@mailv6.fsktm.upm.edu.my>, size=7079, nrcpt=1 (queue active)Oct 11 15:45:25 mailv6 postfix/smtpd[7275]: disconnect from localhost.localdomain[127.0.0.1]
Oct 11 15:45:39 mailv6 postfix/smtpd[7295]: connect from localhost.localdomain[127.0.0.1]
Oct 11 15:45:40 mailv6 postfix/smtpd[7295]: 082B387ED7: client=localhost.localdomain[127.0.0.1]
Oct 11 15:45:40 mailv6 postfix/cleanup[7280]: 082B387ED7: message-id=<v0421010eb70653b14e06@[208.192.102.193]>
Oct 11 15:45:40 mailv6 postfix/qmgr[2223]: 082B387ED7: from=<root@mailv6.fsktm.upm.edu.my>, size=7515, nrcpt=1 (queue active)Oct 11 15:45:40 mailv6 postfix/smtpd[7295]: disconnect from localhost.localdomain[127.0.0.1]
Oct 11 15:45:41 mailv6 amavis[5295]: (05295-06) Passed CLEAN, [208.192.102.199] <root@mailv6.fsktm.upm.edu.my> -> <bing@localhost.localdomain>, Message-ID: <v0421010eb70653b14e06@[208.192.102.193]>, mail_id: uSA5Jy53ITTQ, Hits: 0.976, queued_as: 082B387ED7, 11417 ms
 
Old 10-12-2006, 05:17 AM   #33
squirtle
Member
 
Registered: Jun 2006
Posts: 55

Original Poster
Rep: Reputation: 15
I can't login into squirrelmail
Error opening ../data/default_pref
Default preference file not found or not readable!
Please contact your system administrator and report this error.
What is this problem?
Thanks.
 
Old 10-12-2006, 05:27 AM   #34
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally Posted by squirtle
I can't login into squirrelmail
Error opening ../data/default_pref
Default preference file not found or not readable!
Please contact your system administrator and report this error.
What is this problem?
Thanks.
That would probably be a) file is missing or b) permissions issue.
 
Old 10-12-2006, 05:51 AM   #35
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Looks to me like your spam is working OK - it seems to be delivered to the quarantine account.

try

#postqueue -p

because I suspect everything is stuck in the queue

Did you set squirrelmail up? There's a config program you need to run
 
Old 10-12-2006, 06:00 AM   #36
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
To configure squirrlemail, under FC5, the relevant files are in

/usr/share/squirrelmail/config.

There should be a file called conf.pl. You run this by typing

#perl conf.pl

And follow the instructions
 
Old 10-12-2006, 06:02 AM   #37
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
btw, what imap server are you using? If you're using dovecot, choose courier-imap in the setup for squirrelmail
 
Old 10-13-2006, 10:04 PM   #38
squirtle
Member
 
Registered: Jun 2006
Posts: 55

Original Poster
Rep: Reputation: 15
Thanks so much.
However, I format my PC and setup the mail server again because after problem "can't login" occur the Imap server down.
May be the problem occur after I compile the kernel so maybe some files are missing.

The spam can work in my home's PC but the real mail server can't.
The non spam can't deliver to user's Inbox but the spam only deliver to quarantine folder(this folder is not user specific).It mean user not receive the spam message in Spam or Trash folder in Squirrelmail.

Last edited by squirtle; 10-13-2006 at 10:16 PM.
 
Old 10-14-2006, 04:16 PM   #39
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I'd try setting up the mail server from scratch, and get the most basic setup working, then add bits one by one. That way you'll know where you've gone wrong
 
Old 10-16-2006, 04:10 AM   #40
squirtle
Member
 
Registered: Jun 2006
Posts: 55

Original Poster
Rep: Reputation: 15
Hai,
May I ask how the postfix know which user sholud it deliver the mail?Where can I check how the Postfix work?Because now I want send the spam to the specified user.

The subject of the spam messages does not change to "SPAM" thath set in sa_spam_subject_tag="SPAM",


Thanks

Last edited by squirtle; 10-16-2006 at 04:13 AM.
 
Old 10-16-2006, 06:02 AM   #41
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Typically if your domain is example.com, then mail sent to user1@example.com will be delivered to user1's inbox/other folder unless you are using aliases or similar
 
Old 10-18-2006, 09:21 PM   #42
squirtle
Member
 
Registered: Jun 2006
Posts: 55

Original Poster
Rep: Reputation: 15
Hai,
My spam can success send to the sender's spam folder.However,I installed the razor-agent and razor -agent-sdk,occur this problem Can't locate auto/Digest/MD5/clone.al

when I run amavisd debug have an errot
[root@mailv6 razor-agents-sdk-2.03]# amavisd debug
Time::HiRes version 1.49 required--this is only version 01.20 at /usr/local/sbin/amavisd line 1496.
BEGIN failed--compilation aborted at /usr/local/sbin/amavisd line 1496.

I install Time::HiRes(1.87) and Digest::MD5(2.36) from perl -MCPAN -e shell

Version in razor is Time::HiRes (1.20) and Digest::MD5 is 2.20.

This are some part of my/var/log/maillog
Oct 19 09:22:24 mailv6 amavis[14643]: (14643-01) (!!) TROUBLE in process_request: Can't locate auto/Digest/MD5/clone.al in @INC (@INC contains: lib /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.6/i386-linux-thread-multi /usr/lib/perl5/5.8.6) at /usr/local/sbin/amavisd line 1747
Oct 19 09:22:24 mailv6 amavis[14643]: (14643-01) (!) Requesting process rundown after fatal error
Oct 19 09:22:24 mailv6 amavis[14643]: (14643-01) (!) TempDir removal: tempdir is to be PRESERVED: /var/amavis/tmp/amavis-20061019T092224-14643
Oct 19 09:22:24 mailv6 postfix/smtp[14640]: 52CF778102: to=<bing@localhost.localdomain>, relay=127.0.0.1[127.0.0.1], delay=59122, status=deferred (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to end of DATA command))

Then now my mail fail to send !!!!!!!!!!

Last edited by squirtle; 10-18-2006 at 09:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix - cannot send e-mail abapdr Linux - Software 13 08-13-2013 05:47 AM
not able to send mail using postfix Robin01 Linux - Software 4 12-28-2007 03:41 PM
just send mail using postfix shipon_97 Linux - Networking 1 08-10-2006 06:01 AM
Postfix send mail problem(In RH9, kernal 2.4.20, postfix 2.1.5) minor Linux - General 4 07-11-2005 09:12 PM
Postfix will not send mail antken Linux - Networking 1 10-05-2003 06:28 PM


All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration