LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-22-2005, 04:28 AM   #1
cjae
Member
 
Registered: Mar 2004
Distribution: bouncing
Posts: 277

Rep: Reputation: 30
possible mount issue; cant see anything on ntfs


Hi,

I recently have converted my windows partition from ntfs to fat32, I used to be able to see (read) it. I used Partition Tragic to do it, as it is a laptop and therefore has a Norton Ghosted recovery disc which auto converts to ntfs.

Why can't I see my win partition now, I believe I must amend etc/fstab, or could it be another problem. I can open the c: but it shows nothing, like all the files are hidden.
 
Old 07-22-2005, 07:02 AM   #2
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
I think the problem is you've chosen FAT32 rather than FAT16 - I think (but I'm not certain) that the Linux kernels only support FAT16.

If you solve that problem, yes, you would have to change /etc/fstab: you would replace the ntfs in the type column with vfat. If the type column shows auto though, leave it like it is as it should be able to auto-detect.
 
Old 07-22-2005, 08:19 AM   #3
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
The Linux kernel does support both FAT16 and FAT32 filesystems (read for yourself here: http://bmrc.berkeley.edu/people/chaffee/fat32.html).
Post your /etc/fstab contents to see if there's where the trouble is.
 
Old 07-22-2005, 10:17 AM   #4
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
? mount -t vfat /dev/hd(x) /blabla?
did u try that?
 
Old 07-22-2005, 03:34 PM   #5
cjae
Member
 
Registered: Mar 2004
Distribution: bouncing
Posts: 277

Original Poster
Rep: Reputation: 30
/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C auto ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvdram /media/dvdram subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0


I edit the file to say auto though also when I tried to open it with vi it said that I had to fstab.swp files so I deleted one, know how do I know it works.
 
Old 07-22-2005, 04:10 PM   #6
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
the line
/dev/hda1 /windows/C auto ro,users,gid=users,umask=0002,nls=utf8 0 0
change auto to vfat (if u have fat32) or ntfs (if u hav ntfs)

#man mount, to see the excact type, cause i run freebsd for the moment. i blast the suse staff, so i dont remember the name
 
Old 07-22-2005, 05:04 PM   #7
cjae
Member
 
Registered: Mar 2004
Distribution: bouncing
Posts: 277

Original Poster
Rep: Reputation: 30
I edited fstab with vi and saved it. This is the file now:

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C vfat ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvdram /media/dvdram subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0


What am I doing wrong? doesn't the ro after the vfat stand for read only, defeating the original reason for the conversion to fat.

Also my tty1,2,3,4,5,6 consoles like when I switch by pressing crtl+alt+f1 etc... my screen goes to *hit. I has a scrambled color picture looks like abstract atari graphics.

Should I be posting in the suse forum?

Also when I reboot I get the atari syndrome and cannot see the verbose mode
 
Old 07-23-2005, 03:12 AM   #8
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
for frisbie :
#mount_ntfs -m 750 -C iso8859-7 /dev/ad1s6 /mnt/wini

in fstab could be
/dev/ad1s6 /mnt/wini -t ntfs -m 750 -C iso8859-7

just test it from a console , what i said before. and if iit works, put it in the proper way to the fstab

a line in my fstab is
/dev/ad1s2f /var/ftp/pub/bsdf ufs rw 2 2
 
Old 07-23-2005, 03:14 AM   #9
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
hey

take a look in manual page of mount

cause the options u pass may be wrong (uid gid etc)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
USB drive mount double mount issue pazzport Ubuntu 3 10-10-2005 08:28 PM
NTFS Issue in Fedora Core 2 lordrain Linux - Software 6 10-22-2004 09:09 AM
NTFS issue JROCK1980 Linux - Hardware 9 07-08-2004 11:07 AM
can't access ntfs mount through nfs mount bezoomny Linux - Networking 9 04-14-2004 10:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration