LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2003, 06:06 PM   #1
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Possible DNS problem?


Hello all! I'm 90 minutes into Ret Hat 9.0. I'm having a problem getting my Linux machine online, and I'd greatly appreciate whatever help anyone can give me.

Here's the situation - I have 2 machines at home. The new machine is running Windows 2000, and has the cable modem directly attached. I have enabled internet connection sharing on it. The second network card in that machine has the static local IP of 192.168.0.1/24.

The old machine was formatted and Red Hat 9.0 has been on it a short while. I gave the Linux box the static IP of 192.168.0.2/24. I set the route correctly as 0.0.0.0 through the gateway of 192.168.0.1.

The Windows box has DHCP for both its outside IP and DNS machines. An NSLOOKUP command reveals that earthlink's DNS machines ae 208.69.188.185 - 208.69.188.187. I have given those 3 DNS addresses to the Linux box.


The Problem:
From the terminal in Linux, I can ping both the other local machine, as well as the mail and web server at my work, so it has internet connection. It can only do this by IP address. If I ask the Linux box to ping those same computers by name, I get no response. I have tried using both the DNS machines from my ISP as well as the DNS machines for my work computers ISP, and both have this result. Interestingly enough, I can't get the traceroute command to do anything. I can ping my work machines, but asking it to traceroute to that same IP it just was able to ping gives the result

1 * * *
2 * * *

all the way up to 30 if I let it sit that long. That same result happens when I try to traceroute from the Linux box to the Windows box over the local network. I would expect I am simply missing a single option somewhere, but I'm clueless at to what that might be, and also where I might find it in Linux. Thanks for your time!

Peace,
Jim
 
Old 10-03-2003, 06:29 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Are you actually putting your ISP's DNS entries in the /etc/resolv.conf file?
 
Old 10-03-2003, 06:48 PM   #3
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 49
No, not directly, I use the system tools -> network in xwindows. So when I looked in /etc/resolv.conf It had the 3 DNS IPs that I had given it. It is using the correct DNS addresses, unless they are found somewhere other than /etc/resolv.conf

question part 2: I went to /etc in the terminal, and entered pico resolv.conf to read the file, it said pico couldn't be found. My boss at work uses pico to read everything (he hates xwindows). Does pico need to be downloaded or specifically installed?

Thanks again,
Jim
 
Old 10-03-2003, 06:54 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
You don't need pico installed, its just an easier to use editor.

You can use vi or vim to edit the file.

man vi for more details, etc.

Can you post your resolv.conf file here for clarification? Also can you post your output of the command 'route' ?
 
Old 10-03-2003, 07:16 PM   #5
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 49
contents of /etc/resolv.conf
search jimlinux
nameserver 207.69.188.185
nameserver 207.69.188.186
nameserver 207.69.188.187


and the results of route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface
deafult 192.168.0.1 255.255.255.0 UG 0 0 0 eth0
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth 0


Sorry, I had to manually copy it down, I don't have file sharing enabled yet. I don't know why default is listed 2 times, and with different Genmasks each time. That might be the source of the problem?

Thanks again for your help
Jim
 
Old 10-03-2003, 08:17 PM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
In your resolv.conf file, remove the line: search jimlinux
And then see if you can resolve names. I personally don't put that in as it's given me problems before, etc.
 
Old 10-03-2003, 08:25 PM   #7
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Another possibility could be the good 'ole redhat firewall settings which using seem to have a dislike for DNS. If your firewall/Lokkit is seems to stop DNS prevent resolution.

If you've got the firewall on turn it off and see it it starts working, if you don't well...then it isn't that then
 
Old 10-03-2003, 08:57 PM   #8
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 49
Trickykid got it, it was that initial line in the resolv.conf file. The minute I got that out everything was golden. Of course, I almost needed to post again on how to save and exit a file with vim, but google gave me that answer without too much difficulty. As soon as I get the Red Hat updates, I'm going for pico, my limited experience with vim has already shown me that I don't care for it. Thanks again Trickykid, I'll clikc the icon to give you points for walking me through this!

Take Care,
Jim
 
Old 10-03-2003, 11:23 PM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Glad that worked for ya. I always leave that out myself as its done the same thing to me in the past.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS problem. Please help! auroratrading Linux - Networking 1 04-05-2005 03:14 AM
problem with DNS bglad Linux - Networking 9 10-20-2003 06:39 AM
DNS problem with RH 8.0 datamisc Linux - Newbie 2 12-20-2002 01:37 PM
DNS problem Cubiq Linux - Networking 12 09-06-2002 04:42 AM
A DNS Problem ktamit Linux - Networking 0 04-28-2002 08:45 AM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration