LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2004, 07:45 AM   #1
Pacemaker
LQ Newbie
 
Registered: Mar 2004
Location: Amman/Jordan
Posts: 9

Rep: Reputation: 0
plz help: monitor turns off


after being throught alot of problems dealing with Red Hat 9.0, because the screen was turning off everytime i started linux, so i made it boot into runlevel 3 so i can work on the shell to configure my monitor.
As i know i can configure the monitor by typing: Redhat-config-xfree86 on the shell screen after login as root.
The problem that when i type "Redhat-config-xfree86" on the shell screen the monitor turns off again, it seems there is a conflict between my monitor and the operating system.
how can i configure my monitor from the shell so i can enter the GUI ??
if anyone can help me i would be appreciated. thanx
 
Old 03-26-2004, 08:08 AM   #2
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Try running 'xfree86setup' or 'xf86config' as root.
 
Old 03-26-2004, 10:46 AM   #3
Pacemaker
LQ Newbie
 
Registered: Mar 2004
Location: Amman/Jordan
Posts: 9

Original Poster
Rep: Reputation: 0
negative

the same problem occured...
what shall i do?
 
Old 03-26-2004, 12:41 PM   #4
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Try looking up your monitor specs online and editing your XF86Config to suit. Searching LQ should bring up a way to do that.
 
Old 03-26-2004, 02:01 PM   #5
Pacemaker
LQ Newbie
 
Registered: Mar 2004
Location: Amman/Jordan
Posts: 9

Original Poster
Rep: Reputation: 0
i know all the specification of my monitor, u mean i should pass the monitor specification to the XF86Config using the vi editor?
thank u
 
Old 03-26-2004, 07:49 PM   #6
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
You can manually edit XF86Config if you prefer, but it's probably simpler to just run the xf86config program, which, for each configuration option, typically gives a set of standard choices plus the ability to specify your own value. To use a real life example, you will need to specify the horizontal sync range and the vertical sync range for your particular monitor. You'll be given roughly half a dozen common values, plus an option to specify your own.

Overall it's a pretty simple program to run and as long as you correctly provide it with the appropriate values for your exact monitor model, it should give you good results. Obviously you can also achieve equally good results via manual editing, however, the potential for input errors or typos would be higher. -- J.W.
 
Old 03-27-2004, 12:17 AM   #7
kdepa
Member
 
Registered: Feb 2004
Posts: 73

Rep: Reputation: 15
I had the same problem - its due to a screen resolution or refresh rate that is too high for the monitor. Lower the setting to a more suitable level supported by the monitor, and it should be fixed.
 
Old 03-29-2004, 03:45 AM   #8
morado
LQ Newbie
 
Registered: Mar 2004
Location: Costa Rica
Posts: 5

Rep: Reputation: 0
Quote:
Originally posted by Pacemaker
i know all the specification of my monitor, u mean i should pass the monitor specification to the XF86Config using the vi editor?
thank u
can some body explain me how to do this....PLEASE!!! i am really new in linux and i need redhat 9 right now...i think that i have the same problem, i know how to log as root....i already tried to run xfree86setup and xf86config and none of them worked....

i dont know how to use the vi editor...please somebody help me....give as many solutions as oyu can cause i gotta try everything till i see the penguin on my computer!
 
Old 03-29-2004, 06:41 PM   #9
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
Well, as already described, the best way "to do this" would be to run the xf86config program, as that avoids the potential for manual editing errors, especially if you are not familiar with using vi. When you say that xf86config didn't work, what exactly do you mean? Did it give you an error message? If so, what was it? Perhaps if you describe your situation in more detail other people can make better suggestions.

As another alternative, if Redhat currently has not successfully been installed on your machine, then maybe the best thing for you to do is to just start over, and reinstall it. Towards the end of the process, you will have the option of specifying the make and model of your monitor. Redhat supports a pretty extensive list of monitors, and most likely the one you use is in there. Select the model you are using, and the vertical and horizontal sync rates will be correctly set automatically. If you are brand new to Linux and aren't having success with manual tweaks, then maybe doing a reinstall might be the fastest way to get the penguin up on your desktop. Good luck with the project -- J.W.
 
Old 04-07-2004, 07:04 PM   #10
mfries
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Rep: Reputation: 0
Hi,

I am facing a similar problem (using fedora), although I am not sure how I can even log in as root, as the log in screen never shows up since the monitor sync rate is out of range. (Had to get a new monitor, not sure how to reset the rate without the old monitor...?)

Is there a way to get a command line prompt to show up using some keystrokes at some appropriate time during the boot? I see some of the messages that I used to see during the boot, about things being successfully turned on and such.

If I could get to a command line, at least I could try using the configuration tool, (is it XF86Config on Fedora as well?).

Thanks,
Mike
 
Old 04-07-2004, 07:11 PM   #11
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Rep: Reputation: 30
You could try ctrl + alt + backspace. That shuts down the X server on my distro and just goes to the regular command prompt. I guess do the keystrokes right when your monitor begins to flicker and go black.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Turns off wescrock Linux - Newbie 4 09-23-2005 01:42 AM
Monitor turns off by itself sometimes... juanbobo Linux - General 4 08-26-2005 05:06 PM
My monitor just turns off and doesn't get to the desktop (SUSE 9.3). Hrothgar15 SUSE / openSUSE 3 08-22-2005 07:01 AM
ICEWM :Monitor Turns off.. Tried everything.... UsualTuxpect Linux - Software 8 10-31-2004 04:47 AM
monitor continuously turns off and on epihammer Mandriva 1 05-21-2004 06:22 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration