LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2005, 02:47 AM   #1
kool124
LQ Newbie
 
Registered: Aug 2004
Location: India
Posts: 17

Rep: Reputation: 0
plz help..


hi.

i use red hat 9 and win xp...

now i just tried out mandake..8.2 old version... but its boot loader lilo took over my mbr where windows boot loder was...

now how to replace lilo and how to get my windows boot loader back to mbr...

any help...

plz...


thanks
abhi.
 
Old 08-29-2005, 02:55 AM   #2
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Boot from the WinXP Install CD, select to boot into the 'Recovery Console', when prompted, then type help and find the option to re-install the Windows boot loader on the MBR (sorry, I don't remember the exact option.).

You should consider using GRUB if yuo want to have a Windows _AND_ Linux box.
 
Old 08-29-2005, 03:33 AM   #3
Spooled
LQ Newbie
 
Registered: Aug 2005
Location: Memphis, TN
Distribution: Mandriva 2006
Posts: 19

Rep: Reputation: 0
Hello,
I don't know if this helps or not, but it is possible for lilo to boot windows. If your question is strictly how to restore the boot loader, you can try to boot to your mandrake install cd. Don't go to the install section, I think you need to hit F1 when the boot spash screen pops up. From there you can type rescue and it should bring up a menu that gives you the option to restore either lilo or the windows boot loader.(This is how it is with 10.2. I'm not sure about 8.2).

If your question is that windows is not working with lilo then:
When I first started with Mandrake, I used 8.2 with lilo. When I installed it, it recognized windows XP Pro and would boot it without a problem. now I use Mandrake 10.2 with lilo and Win XP Pro and it also works. I'm not sure why the windows partition was not recognized by the installer.
I don't know if this is an issue or not, but is your windows partition below the 4gb mark. As I recall, there used to be a problem with booting when it is above the 4gb mark(Don't quote me on this though).
You may need to manually add the windows boot info into lilo. You can do that through the mandrake control center->Boot(I think that is what it is called, its been a while since I used 8.2).

Like I said, I'm not sure if this helps or not, I just wanted to give you my thoughts.

Good Luck!

Last edited by Spooled; 08-29-2005 at 03:53 AM.
 
Old 08-29-2005, 04:12 AM   #4
Mejc
LQ Newbie
 
Registered: Aug 2005
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by exit3219
Boot from the WinXP Install CD, select to boot into the 'Recovery Console', when prompted, then type help and find the option to re-install the Windows boot loader on the MBR (sorry, I don't remember the exact option.).

i think the command when ur in recovery mode for xp is fixmbr, but i have heard it can screw up your partition tables
 
Old 08-29-2005, 04:14 AM   #5
Mejc
LQ Newbie
 
Registered: Aug 2005
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by exit3219
Boot from the WinXP Install CD, select to boot into the 'Recovery Console', when prompted, then type help and find the option to re-install the Windows boot loader on the MBR (sorry, I don't remember the exact option.).

You should consider using GRUB if yuo want to have a Windows _AND_ Linux box.
Hey i just read your from Moldova that's kool there's a bunch of Hungarians up there Csango's great bunch they are
 
Old 08-29-2005, 08:20 AM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Moderator Note: Please read this thread in regards to your thread title: http://www.linuxquestions.org/questi...95#post1730795
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PLZ, PLZ help - need some info kevmif Linux - General 9 12-17-2007 06:12 AM
plz plz help me regarding route mapping nedian123 Programming 1 07-13-2004 08:17 AM
plz plz solve my route mapping problem nedian123 Linux - Networking 1 07-12-2004 09:41 PM
plz, help me (plz realy ) h4ng4m3 Linux - General 10 08-18-2003 06:07 AM
redhat problems plz plz help sap666 Linux - Newbie 5 07-30-2003 10:57 AM


All times are GMT -5. The time now is 08:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration