LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2009, 05:28 PM   #16
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898

did you entered telnet also?

telnet ip 5900

the windows computer is outside the network, right?

Last edited by repo; 02-22-2009 at 05:29 PM.
 
Old 02-22-2009, 05:36 PM   #17
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
oh hehe didnt know to enter it outside the network. I tried again and its trying to connect now but it returned this msg.

clould not open connection to the host, on port 5900: connection failed
 
Old 02-22-2009, 05:41 PM   #18
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
could you connect from the debian computer?
telnet 127.0.0.1 5900 ?

Seems to me there is a problem with

the port forwarding at the router
or
a firewall at the debian box

so make sure the portforwarding is correct.

also make sure you use the correct ip for the router, not the internal ip
 
Old 02-22-2009, 05:46 PM   #19
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
the debian computer connected with no problem.

I have a firestarted as firewall but in the event screen i didnt see any attemps blocked
I checked the IP too.

So i think the problem is the port forwarding.
I have for the external and internal port 5900
And to the internal ip of debian. Is this correct?
 
Old 02-22-2009, 05:48 PM   #20
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
i disabled the firewall firestarter and it works now . So i guess this is working now but with minimal security?
 
Old 02-22-2009, 05:48 PM   #21
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
So i think the problem is the port forwarding.
I have for the external and internal port 5900
And to the internal ip of debian. Is this correct?
yes

Quote:
I have a firestarted as firewall
try to disable the firewall
 
Old 02-22-2009, 05:49 PM   #22
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
So i guess this is working now but with minimal security?
add port 5900 to the firewall
 
Old 02-22-2009, 05:59 PM   #23
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
i also have to add specific ip's ???
Im using my phone shared internet for my laptop for testing.
I also added 5900
 
Old 02-22-2009, 06:03 PM   #24
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
if you open the port it should be OK
make sure to use a good password for the remote login.

However, it is better to use ssh to connect, since it is encrypted.
 
Old 02-22-2009, 06:05 PM   #25
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
if i want to connect with ssh then i have to install ssh on my windows xp?
 
Old 02-22-2009, 06:06 PM   #26
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
if i want to connect with ssh then i have to install ssh on my windows xp?
putty will do the trick
 
Old 02-22-2009, 06:09 PM   #27
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
im so happy now its all working well, i have spend 2 days getting this to work :P and it works now thanks very much repo
 
Old 02-22-2009, 06:11 PM   #28
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
no problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed setting up remote desktop or VNC mlfricke Puppy 3 02-19-2009 11:08 PM
Setting Up a Remote Desktop Server Abnoba12 Linux - Newbie 3 08-03-2006 11:05 AM
accessing remote linux desktop- pls. help arunsri Linux - Networking 1 09-17-2005 03:34 AM
setting up remote desktop watts3000 Linux - Newbie 4 09-25-2004 12:29 PM
Setting up a Remote Desktop Connection over Dial-up? Huezo Linux - Networking 1 01-30-2004 02:48 PM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration