LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2007, 02:12 AM   #1
zax
LQ Newbie
 
Registered: Apr 2007
Posts: 5

Rep: Reputation: 0
Unhappy PLease somebody help with linux-headers


Good morning everybody. I have a kind of stupid problem about installing some packages under Debian etch. So i tried to install linuxheaders package ( linux-headers-2.6.18-4 ) with module-assistant way, but when i tried:

module-assistant prepare
Getting source for kernel version: 2.6.18-4-686
Kernel headers available in /lib/modules/2.6.18-4-686/build
apt-get install build-essential
Reading package lists... Done
Building dependency tree... Done
build-essential is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
linux-headers-2.6.18-4-686: Depends: linux-headers-2.6.18-4 (= 2.6.18.dfsg.1-12) but it is not going to be installed
skype: Depends: libqt4-core (>= 4.2.1) but it is not going to be installed
Depends: libqt4-gui (>= 4.2.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Done!
ZaxNode:/home/zax# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libqt4-core libqt4-gui linux-headers-2.6.18-4
Recommended packages:
qt4-qtconfig
The following NEW packages will be installed:
libqt4-core libqt4-gui linux-headers-2.6.18-4
0 upgraded, 3 newly installed, 0 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 3163kB/8880kB of archives.
After unpacking 34.7MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Err http://ftp.bg.debian.org etch/main linux-headers-2.6.18-4 2.6.18.dfsg.1-12
404 Not Found
Err http://ftp.us.debian.org etch/main linux-headers-2.6.18-4 2.6.18.dfsg.1-12
404 Not Found [IP: 204.152.191.7 80]
Failed to fetch http://ftp.us.debian.org/debian/pool....1-12_i386.deb 404 Not Found [IP: 204.152.191.7 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
ZaxNode:/home/zax#

I thought that the problem maybe is from sources list but no i tried a lot of mirors but every time the result is the same.But however my sources list is:

deb http://ftp.bg.debian.org/debian/ etch main
deb-src http://ftp.bg.debian.org/debian/ etch main

#USA
deb http://ftp.us.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ etch main contrib non-free
 
Old 09-07-2007, 04:07 AM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Yes, the package it was looking for does not exist any more. Question is? why are you using module assistant to install headers?
I think what you should do is run the command: apt-get upgrade, and enter (y) when asked to confirm and upgrade your installation first, which should upgrade the kernel to version 2.6.18-5, as version 2.6.18-4 is in the past. Once your installation is upgraded, re-boot to the new kernel, then try installing headers with command: apt-get install linux-headers.

Last edited by Junior Hacker; 09-07-2007 at 04:10 AM.
 
Old 09-07-2007, 07:00 AM   #3
zax
LQ Newbie
 
Registered: Apr 2007
Posts: 5

Original Poster
Rep: Reputation: 0
yeah

yeah man 10x a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux-headers for 2.6.12 lilohatea Debian 4 02-13-2006 02:36 AM
old linux kernel headers guysoft Debian 4 01-30-2006 07:34 AM
linux headers reejadb04 Programming 1 10-20-2004 12:28 PM
Linux 2.4.26 headers toucents Linux From Scratch 1 09-22-2004 10:46 PM
Linux headers problem znif Linux From Scratch 4 06-26-2004 01:02 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration