LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2014, 08:10 PM   #1
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Rep: Reputation: 8
Please, I need help setting up the FEDORA 20 server? unable to access server


I have configured everything on my FEDORA 20 server.

I have installed LAMP.

apache, mysql, and php, I have all the services runnig.

My laptop is in the same network with the Fedora server. when I type in the local IP 192.168 on my laptop browser. I can't access the web files stored on my server.

I am unable to access the web pages from my laptop on the browser?

In my Router I have forwarded port 80.

I have so confused.

I have already got a domain name from no-ip website.

I am so confused. I don't know what else could be wrong.
what am I doing please, any help is appreciated.
 
Old 03-08-2014, 08:54 AM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,506

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Assuming you're running Apache on port 80 of the server, is port 80 open in the server's firewall?
 
Old 03-08-2014, 10:18 AM   #3
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Also, 192.168 is not an IP address -- an IPv4 address has 4 octets, e.g. 192.168.1.2.

Please check the results of "ifconfig -a" and "iptables -L" on the server (the latter checks if a firewall is running). Can you connect to the server via port 22 for SSH?
 
Old 03-08-2014, 11:54 AM   #4
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by btmiller View Post
Also, 192.168 is not an IP address -- an IPv4 address has 4 octets, e.g. 192.168.1.2.

Please check the results of "ifconfig -a" and "iptables -L" on the server (the latter checks if a firewall is running). Can you connect to the server via port 22 for SSH?
Sorry, that was a typo, it is actually 192.168.1.5 on the server. ifconfig displays correct internal LAN IP 192.168.1.15 gateway 192.168.1.1. I can access the web pages locally via localhost or 127.0.0.1. but unable to access externally. Definitely something with the Iptables. where is the Iptables file located in the FEDORA 20 server. I tried doing cat iptables in /etc/sysconfig , it shows nothing but jibberish. when I try to view the contents. its all garbles.
 
Old 03-08-2014, 12:12 PM   #5
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531
Generally speaking if you would want to see the current active firewall rules you'd just execute 'iptables-save'. But IIRC Fedora nowadays installs a 'firewalld' service by default which aims to confuse those accustomed to the old bare 'iptables' interface (just as much as having to look at the monstrosity that is an UFW rule set). If you want old school behaviour you can install the 'iptables-services' package, disable firewalld.service and enable iptables.service through systemctl and then configure /etc/sysconfig/iptables.
 
Old 03-08-2014, 03:40 PM   #6
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by unSpawn View Post
Generally speaking if you would want to see the current active firewall rules you'd just execute 'iptables-save'. But IIRC Fedora nowadays installs a 'firewalld' service by default which aims to confuse those accustomed to the old bare 'iptables' interface (just as much as having to look at the monstrosity that is an UFW rule set). If you want old school behaviour you can install the 'iptables-services' package, disable firewalld.service and enable iptables.service through systemctl and then configure /etc/sysconfig/iptables.
thanks. I had to open port 80 on my server, I had to add port 80 on the iptables config file.

thanks everyone for the response and comments.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to access any server through Filezilla. Satyaveer Arya Linux - Software 3 07-18-2012 11:31 PM
Unable to access ip address of server amritpalpathak Linux - Software 4 01-11-2011 09:16 AM
Unable to access the server with static IP narendravijayarao Ubuntu 20 10-02-2009 12:31 PM
Unable to see shares on samba server - no authentication access desired (open access) neoelf Linux - Networking 1 06-14-2009 04:18 PM
Unable to access my ssh server and ftp server from the Internet, but smtp works foxone Linux - Networking 1 05-28-2004 06:17 PM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration