LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2003, 08:34 PM   #1
notslim
Member
 
Registered: Aug 2003
Distribution: RH9
Posts: 63

Rep: Reputation: 15
Angry PLEASE help with NVIDIA driver


hey:

i'm trying to install a driver for my GeForce 4. and YES, i read chad's FAQ.. i installed the driver as per the readme and edited xf86config.. and then started x and...

no.

i get an error message that i dont recall (i had to change xf86config back to vesa to boot x to post this thread.. ).. but its something like

device not found.. /something/nvidia1 does not exist.. something else..
screens found, but can't something..

i realise i havent been very helpfull, but i hope someone can help me anyway.

if someone NEEDS me to get the message, could they tell me how to access a log of errors?


thanks,
--Dave
 
Old 08-16-2003, 08:39 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
cat /var/log/XFree86.0.log

should do it, if not then

locate XFree*log
 
Old 08-16-2003, 09:03 PM   #3
notslim
Member
 
Registered: Aug 2003
Distribution: RH9
Posts: 63

Original Poster
Rep: Reputation: 15
(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)

i think that was it.


but that doesnt solve my problem..

sorry to sound spoiled, im just a little anxious to solve this...



--Dave
 
Old 08-16-2003, 10:13 PM   #4
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
ok, make sure glx is loading? maybe that is the problem?

try reinstalling the driver (make sure u say to remove the old one) and recheck your XF86Config making sure you have the driver "nvidia" loading, not "vesa" or "nvidia1" or such

just recheck that u did everything the faq at the top of this forum says

also, if u still can't get it to work, post your /etc/X11/XF86Config here
 
Old 08-16-2003, 10:39 PM   #5
notslim
Member
 
Registered: Aug 2003
Distribution: RH9
Posts: 63

Original Poster
Rep: Reputation: 15
Code:
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        # Modified by mouseconfig
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/mouse"
        Option      "Protocol" "PS/2"
Option      "Emulate3Buttons" "yes"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Dell M992"
        DisplaySize  350        260
        HorizSync    30.0 - 96.0
        VertRefresh  50.0 - 160.0
ModeLine     "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +
hsync +vsync
        ModeLine     "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +
hsync +vsync
        ModeLine     "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +
hsync +vsync
        ModeLine     "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +
hsync +vsync
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
        Identifier "Screen0"
Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Modes    "800x600"
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode         0666
EndSection



--There ya go.


Dave

(i did all your other steps.. lol)


--note that the driver is set to vesa so i can boot x.. i know it should be nvidia
 
Old 08-17-2003, 01:01 AM   #6
tearinox
Member
 
Registered: Aug 2003
Location: you dont want to know
Distribution: Gentoo 2004.2, Slackware 10, Windows XP, Windows 2003 Server
Posts: 348

Rep: Reputation: 30
Okay, I have a suggestion for you... I had troubles with my Nvidia (yes i have a geforce 4 Ti4200) and Steven1080 saved the day... here's what he told me:

You need to download Linux Drivers from nvidia ( http://www.nvidia.com/object/linux_...y_ia32_1.0-4496 ).

1. After downloading hit control+alt+f1 or f2
2. Login as root
3. Type telinit 1
4. change the directory where the drivers are at
5. Type sh NVIDIA-Linux-x86-1.0-4496-pkg2.run or whatever the files called
6. hit accept, and it should install
7. type telinit 5 and everything should restart up

Then you got to edit a file. Open up a console, su into root.. use gedit or whatever word processor you like... gedit /etc/X11/XF86Config-4

Go down to Section "Device" and under there you should see Driver "nv"... change that to "nvidia" and hit control+alt+backspace, should restart X and see the nvidia splash screen

edit: btw keep the -opengl, makes it faster (for me anyways)

Last edited by Steven1038 on August 12th, 2003 at 02:49 PM
 
Old 08-17-2003, 12:16 PM   #7
notslim
Member
 
Registered: Aug 2003
Distribution: RH9
Posts: 63

Original Poster
Rep: Reputation: 15
i don't mean to be rude, but i did that already. the problem is that once i change the driver code (vesa to nvidia), i cant boot X.
 
Old 08-17-2003, 01:07 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
How's about just trying a modprobe first:
modprobe nvidia &&
startx

Of course you'll have to be root

Can you post up your /etc/modules.conf



Cool
 
Old 08-17-2003, 01:23 PM   #9
notslim
Member
 
Registered: Aug 2003
Distribution: RH9
Posts: 63

Original Poster
Rep: Reputation: 15
alias parport_lowlevel parport_pc
alias eth0 e100
alias usb-controller ehci-hcd
alias usb-controller1 usb-uhci
alias char-major-195 nvidia
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&$
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 $

it says 'can't locate nvidia' when i run modprobe.. thoughts?

--dave
 
Old 08-17-2003, 01:27 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Any major problems during the driver install? Which version is it?

Check your modules directory:
First, find out which kernel you are running:
uname -r
Then:
cd /lib/modules/kernel-version/kernel/drivers/video
And then:
ls
Is the nvidia module there? If so, run:
depmod -ae
And then:
modprobe nvidia (use the full path maybe)
Finally, check:
lsmod
See if 'nvidia' is listed. If not, and it's not listed in /lib/modules/kernel-version..
Then it sounds like it didn't get installed properly?

Cool
 
Old 08-17-2003, 01:39 PM   #11
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
add:
alias char-major-195 nvidia
to the /etc/modules.conf file...
then:
modprobe nvidia
then type:
startx
also, make sure assign irq to vga is also set in your bios.
....and see if you have any luck with that..
 
Old 08-17-2003, 01:58 PM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
DrOzz

Check out the thread buddy! He's got that listed in there, he's tried modprobing, and he's definitely given startx a try

Thanks for the insight though, much appreciated! If nothing else, it's a "yeah, that's what you should do" second

Cool
 
Old 08-17-2003, 02:16 PM   #13
notslim
Member
 
Registered: Aug 2003
Distribution: RH9
Posts: 63

Original Poster
Rep: Reputation: 15
hey, guys. i really appreciate your help. we can lick this (fingers crossed )

2.4.20-19.9 is my kernel,
and, well, the driver doesn't seem to be installed.

darned if i know why, though.. i re-dled the driver from nvidia.com, reinstalled it using sh whateverisis.run.. and checked again in those spots.. still nothing.

is it possible that it doesnt show up because the driver in xf86config is still VESA? again, i only switched it back so i could boot X.. that's the problem.



thanks again,

--Dave

Last edited by notslim; 08-17-2003 at 02:28 PM.
 
Old 08-17-2003, 02:35 PM   #14
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
oh ok, whatever...i just thought i saw him saying, i can't locate the nvidia modules not that modprobe didn't find it....just got home from a bender on the weekend, the mind is a little slow

it may be trying to load an older kernel module (this is if you are upgrading, otherwise disregard this) and if so, you can find the new kernel module nvidia.o, and try: insmod nvidia.o from within the directory...

anyways i will have to assume that you must of put another kernel on your machine, right?
if that does stand true, your probably better off removing the traces of whatever you have installed right now, and re-install passing the kernel include argument to the installer...its more than likely picking up the wrong kernel headers
so run the installer like so:
sh NVIDIA-drivers.run --kernel-include-dir
and you can use:
sh NVIDIA-drivers.run --advanced-options
for more information if need be.
 
Old 08-17-2003, 02:36 PM   #15
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Nah, it should be listed regardless. Make sure you've got the sources for your kernel in /usr/src and they are symlinked to /usr/src/linux Any errors during the install this time?

You can **optionally** manually extract the files, and run them on your own (check the README for info) should things get bottomed out everywhere else.

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 07:31 AM
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 03:42 PM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 10:45 AM
nvidia fx5600 loads vesa driver instead of nvidia driver saburo62 Linux - Hardware 3 05-04-2004 04:59 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 06:38 AM


All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration