LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2008, 10:56 AM   #1
HarryBoy
Member
 
Registered: Apr 2008
Distribution: MontaVista Linux Version 4.0.1, Professional Edition
Posts: 215

Rep: Reputation: 16
Please help with glib


Hi, I have copied glib-2.12.12 to my version of Linux.

I ran ./configure --prefix=/usr &&
and then:
make

After about 30 mins everything seemed to go well then I typed:
make check

and I got the following error:

make check-TESTS
make[5]: Entering directory `/opt/glib-2.12.12/glib'
PASS: abicheck.sh
Checking .libs/libglib-2.0.so for local PLT entries
0009e2dc 00006016 R_ARM_JUMP_SLOT 0000fab0 g_atomic_pointer_get
0009e3c8 00025016 R_ARM_JUMP_SLOT 0000fa18 g_atomic_int_set
0009e4ac 0003f816 R_ARM_JUMP_SLOT 0000fb40 g_atomic_pointer_set
0009e4b8 00042616 R_ARM_JUMP_SLOT 0000f988 g_atomic_int_get
FAIL: pltcheck.sh
=====================================================================
1 of 2 tests failed
Please report to http://bugzilla.gnome.org/enter_bug.cgi?product=glib
=====================================================================
make[5]: *** [check-TESTS] Error 1
make[5]: Leaving directory `/opt/glib-2.12.12/glib'
make[4]: *** [check-am] Error 2
make[4]: Leaving directory `/opt/g


Does anyone know why I am getting this error??

PLease help
 
Old 06-02-2008, 11:36 AM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 972

Rep: Reputation: 117Reputation: 117
Hi
This won't probably help at all, but I found for 2.12.11 the same error-report for my distribution (Gentoo) saying:
Quote:
Is 2.12.12 working better? Tests succeed for that version on x86 for me.
Haven't tested 2.12.7 tests on x86 myself yet


------- Comment #2 From Daniel Gryniewicz 2007-06-13 22:19:28 0000 [reply] -------

2.12.11 fails, but 2.12.12 passes. I declare this fixed.
I personally have 2.14.3 working on my amd64-architecture (Intel Core 2 duo, compiled with flags "-march=nocona -O2 -pipe").
 
Old 06-02-2008, 11:42 AM   #3
HarryBoy
Member
 
Registered: Apr 2008
Distribution: MontaVista Linux Version 4.0.1, Professional Edition
Posts: 215

Original Poster
Rep: Reputation: 16
Thanks for your reply Pearlseattle. Do you think I need to compile mine with flags specific to the ARM chip? If so, what do you think these flags would be?

Thanks again.
 
Old 06-02-2008, 12:45 PM   #4
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 972

Rep: Reputation: 117Reputation: 117
You're welcome!
But, pfff...., no clue about ARM. But it would for sure be worth giving it a try! In "man gcc" I read:
Quote:
-march=name
This specifies the name of the target ARM architecture. GCC uses this name to deter-
mine what kind of instructions it can emit when generating assembly code. This option
can be used in conjunction with or instead of the -mcpu= option. Permissible names
are: armv2, armv2a, armv3, armv3m, armv4, armv4t, armv5, armv5t, armv5te, armv6,
armv6j, iwmmxt, ep9312
And this in conjunction with "-O0" (no optimizations - default) or "-O2" (optimized code).
But give it first a try with a different version of glib.

Btw, which "gcc --version" are you using? I have 4.1.2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
'pkg-config --modversion glib-2.0' returned 2.16.3, but GLIB (2.14.6) pgb205 Linux - Software 7 05-17-2008 03:21 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4 MadSkillzMan Linux - Newbie 3 07-10-2004 04:10 AM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration