LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2002, 12:07 PM   #1
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Rep: Reputation: 0
Please Help.. Unable to mount Root


Hi, I'm a complete newbie to linux so i thought i'd try winlinux 2003, i installed it but then as i boot it up from dos it says..



VFS:Cannot open root device "sda1" or 08:01

Please append a correct "root="boot option

Kernel Panic: VFS: Unable to mount root fs on 08;01


Any help would be greatly appreciated, thanks!
 
Old 10-20-2002, 12:37 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Could you write more? Where you installed it, which options, everything you remember.
 
Old 10-20-2002, 12:43 PM   #3
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Original Poster
Rep: Reputation: 0
umm, all I did was click on the .exe file and it installed to C:\Linux and everything seemed to go ok. On the configuration panel the only thing that i had to force was my mouse.
 
Old 10-23-2002, 12:10 PM   #4
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Original Poster
Rep: Reputation: 0
I just looked at advanced options and there's nothing in the sections below..

Boot Winlinux from userdefined hard drive
Partion:

Specify Aditional Boot Parameters
Boot Parameters:

Boot Alternate Kernel Image
Kernel Image File:

Disable PCMCIA and Use XFree 4 options are ticked, So I wondered if my problem's anything to do with the stuff on the advanced option page?

Thanks.
 
Old 10-23-2002, 12:33 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Yes, it looks it's something connected with advanced options. "sda1" is the first partition of SCSI drive. Is it correct? It looks it's not...
 
Old 10-23-2002, 12:43 PM   #6
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Original Poster
Rep: Reputation: 0
umm, I don't know if this is right but I went into dos and typed

C:\Linux\winlinux>winlinux.exe


and this came up..

Letter2Partition v1.0 by Gustavo Scotti
(C)1999, WinLinux.net
You have 1 harddrives.
sda: sda1[0c]
sda1 is C


is that of any help?

thanks.
 
Old 10-23-2002, 12:59 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Hmmm... It shows only the device winlinux is configured for. It doesn't show your system setting. From the error message it looks the setting is incorrect.
 
Old 10-23-2002, 01:01 PM   #8
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Original Poster
Rep: Reputation: 0
any idea on how to correct the setting please?
 
Old 10-23-2002, 01:45 PM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Do you have a startup disk? Can you boot from it?
 
Old 10-23-2002, 01:49 PM   #10
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Original Poster
Rep: Reputation: 0
for winlinux? Nope, 'cos when i tried to make one it just went to the windows 98 start up disk bit.
 
Old 10-23-2002, 02:46 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Please browse the C:\Linux directory and search for any *.bat files (or maybe there's one you use to boot it). Look if there's "sda1" string mentioned anywhere. If there is, please post the contents of the file.
 
Old 10-23-2002, 04:28 PM   #12
Skibz
LQ Newbie
 
Registered: Oct 2002
Location: England
Posts: 13

Original Poster
Rep: Reputation: 0
Yeah, the one i use to boot it, winlinux.bat says..

C:\Linux\winlinux\winlinux.exe C C:\Linux\winlinux\loadlin.exe C:\Linux\vmlinuz

and then I noticed a file that was called linux.bat which says..

\linux\winlinux\loadlin \linux\vmlinuz root=/dev/hda1 rw

so I booted up with that and I got an error like the first but it was 03:01 instead of 08:01
 
Old 10-24-2002, 01:07 PM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
The second one (linux.bat) looks correctly. The only thing is that the root= parameter must point to the partition Windlinux is installed on. /dev/hda1 stands for first primary partition of your primary master hard disk. If it's incorrect (possible only when you have more than one hard disk or first partitition of first disk is occupied by another OS), correct the settings. Second primary partition of the first drive is /dev/hda2, first extended is /dev/hda5, first partition on primary slave drive is /dev/hdb1 and so on...
If the path is correct and it's still wrong it may mean that there was something wrong with the installation (corrupted files etc). It's a good idea to try again. Unfortunatelly there are also machines where Winlinux won't work (it depends on the Windows version, too), but "regular" distribution (those that require partitioning), do.
 
Old 04-19-2004, 11:54 PM   #14
gdivens51
Member
 
Registered: Aug 2003
Location: Asheville,NC
Distribution: Vector
Posts: 58

Rep: Reputation: 15
from: Start/Programs/WinLinux 2003/Winlinux 2003 Release Notes

Kernel panic: VFS: Unable to mount root fs on 08:01
That happens because our loader was unable to automatically find the hard drive
partition where WinLinux 2003 is installed on. It may be caused by the presence
of multiple IDE and SCSI hard drives on the same computer, by IDE hard drives
connected only to the secondary IDE interface or by the use of an offboard (PCI)
disk controller. To boot properly you must run WinLinux Configuration Utility,
answer No to the question about setting users and passwords and click on the
Advanced... button of Device Configuration screen. On the Advanced window check
the box "Boot WinLinux from user defined hard drive partition" and fill in the
hard drive Partition Name.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount root fs King4lex Debian 3 09-01-2004 08:09 PM
unable to mount root fs (again) EcceVery Debian 12 07-31-2004 03:00 PM
unable to mount root fs awreneau Debian 3 06-11-2004 12:51 PM
unable to mount root recon2 Linux - Software 18 10-13-2003 05:55 PM
Unable to mount root fs on 16:03 mvbashyam Linux - Newbie 3 12-14-2002 04:22 PM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration