LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-18-2004, 03:00 PM   #1
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Rep: Reputation: 30
Please help me find a solution...I've tried for days. (network problem)


I can't connect to many ports, and have been trying to work this out for days. However, the ports I can't connect to with linux, I can connect to with windows, on the same cumputer. Believe me, I don't want to go back to MS...I've grown to love linux over the months, but if it's my only resort, I will. I love linux, and have been learning it steadily...but this is driving me crazy. Recently, I upgraded from a standard dial up connection do DSL ...yay. My qwest DSL works in linux, and is fast, but as I said above, I'm having trouble with ports. For instance, I'm trying to run my own personal ftp server on linux. No one can connect to it, because it's blocking them. It has something to do with port 21. I can't send files on amsn. It just says "listening on port 6891" forever. However, I can recieve files on linux through amsn...but on Windows, I can send AND recieve files on windows through msn. I can't connect to p2p clients through tcp. For example I use Azureus quite often. I always get the error that it can't connect to the tracker port...TCP/6969 and TCP/6881 and UDP/6881. I also run several other programs that just can't connect to the ports. I take it since I can do all these things on windows, it has SOMETHING to do with linux.

I did some reading, and heard that I need to assign myself an "internal ip address"..or local, not sure...I'm new to networking totally...and anyway, forward ports to the local ip. I'm on SLACKWARE 10, so I did a netconfig. I put it 192.168.1.10 as an ip, put in the correct gateway and nameservers. I could still browse...and I'm guesing it worked. I tried forwarding ports to this IP on both the router and modem port forwarding setup pages...but no luck. I also tried enabling "DMZ"...with this ip "192.168.1.10"...and still no luck. I have no firewall installed. I even tried installing a firewall and opening the ports.

So I ask...could anyone possibly help me find a solution? I really need to be able to have people connect to my FTP server...and I also really want to be able to send files via AMSN..because I do this allot between people I know

Just some information.

My modem is connected to a router and into my computer. Another computer is also connected to the router and share's an internet connection.

OS: Slackware 10
Router: "Network everywhere linksys": IP: 192.168.1.1
Modem: "Actiontec DSL gateway": IP 192.168.0.1

I get my IP address assigned through DHCPCD I believe.

If anyone can help me sort this out, I will be VERY apreciative. Thanks again.

-RoaCh
 
Old 11-18-2004, 03:08 PM   #2
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
are you sure this is not a firewall problem?

also try dissabling ipv6 support

Last edited by perfect_circle; 11-18-2004 at 08:16 PM.
 
Old 11-18-2004, 06:48 PM   #3
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Hey thanks for the reply. I think I'm using ipv4..i'm not really familiar with what the programs are or do though. Could you please tell me how I disable this? Thanks.

-RoaCh
 
Old 11-18-2004, 07:00 PM   #4
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
You want to check that qwest isn't blocking these ports. You can try using alternative ports if this is a case. But I think you will find the basics blocked by your isp http(80) mail(110, 24 145) and possibly others like 22 and some common p2p ports. You should call them and check with them.
 
Old 11-18-2004, 07:11 PM   #5
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Okay I'll do that...but I know the port for msn works fine in windows and not in linux. Not sure about ftp..but it seems allot of ports work in windows, and they dont work in linux =\
 
Old 11-18-2004, 08:11 PM   #6
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
As far as i know you have to add the lines "alias net-pf-10 off" and "alias ipv6 off" in your modprobe.conf, module.conf or conf.module or whatever you use. (Why do they keep changing the name?).
I don't really think that this will fix your problem, but it will significantly increase browsing speed by decreasing DNS lookup time. You may try it if you want.
 
Old 11-18-2004, 11:06 PM   #7
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
thanks. Tried that..but still no luck
 
Old 11-18-2004, 11:15 PM   #8
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
When you use Windows, do you connect your PC directly to the DSL, or does it sit behind the router as well? It's a little unclear based on what you said. But if you're behind a DSL router, you will be assigned a private "nonroutable" IP address. This is true regardless of the OS you're using. So I imagine what you are doing is plugging your Windows PC directly into your DSL connection? Or am I wrong on that?

If you're behind a router, in any case, you need to enable port forwarding to forward ports 21 etc. to the private IP of your Linux machine. Your router's documentation should tell you how to do this.
 
Old 11-18-2004, 11:31 PM   #9
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
I have my modem plugged into the router at all times. Even on windows.

-edit

How exactly would i assign my linux os a "private ip"? Through netconfig? If so..I've tried that as well

Last edited by RoaCh Of DisCor; 11-18-2004 at 11:32 PM.
 
Old 11-18-2004, 11:56 PM   #10
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Interesting ... anyhow, run "ifconfig eth0" to get your current IP address. This is your internal, private IP address. Now go into your router configuration and make sure that port 21 etc. is forwarded to that address (although if everything really does work in Windows, it all should be set up properly). Also, make sure you're not running a firewall -- you can do "iptables -L" to see what firewall rules, if any, are in place. Also check your /etc/hosts.allow and /etc/hosts.deny to ensure you're not denying traffic based on TCP wrappers.

Also, all 196.168. IP addresses are non-routable. You should try to figure out your public IP address you get from your ISP. you can always run a ShieldsUp test from grc.com on that address to see which ports are open (and hopefully being forwarded by your router).
 
Old 11-19-2004, 12:05 AM   #11
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Okay thanks for your suggestions. I will try these things. I have a question. Would getting a static IP make things easier?

-RoaCh
 
Old 11-19-2004, 12:09 AM   #12
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
ack this is odd...I tried that shields up..and like EVERY port i try says "Stealth There is NO EVIDENCE WHATSOEVER that a port (or even any computer) exists at this IP address!"

Basically everything is stealth..and I installed no firewall..and there are no iptable rules =\

here is this from ifconfig

eth0 Link encap:Ethernet HWaddr 00:C0:A8:87:0D:7A
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3485 errors:0 dropped:0 overruns:0 frame:0
TX packets:3373 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1953341 (1.8 Mb) TX bytes:451989 (441.3 Kb)
Interrupt:11 Base address:0x8800

192.168.1.100 would be my personal ip?

Last edited by RoaCh Of DisCor; 11-19-2004 at 12:24 AM.
 
Old 11-19-2004, 07:54 AM   #13
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
Quote:
Okay thanks for your suggestions. I will try these things. I have a question. Would getting a static IP make things easier?
with a static IP you you need more security. It's easier for people to attack your PC I think
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
If I start a thread and meantime I find out the solution, what should I do? zahadumy LQ Suggestions & Feedback 3 11-28-2005 09:00 PM
another mplayer sound problem. cant find pertinent solution. roller24 Linux - General 3 11-02-2005 04:07 PM
Quick regex problem, can't find solution R00ts Programming 3 05-25-2005 03:55 PM
Going CRAZY trying to find a solution... haku Linux - Software 6 05-01-2004 08:42 AM
Backup Solution for whole network davidm Linux - Software 3 08-25-2002 10:19 AM


All times are GMT -5. The time now is 01:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration