LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-13-2006, 12:08 PM   #1
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Rep: Reputation: 0
Please help I'm Linux challenged!


OK, I have a small problem here. I loaded Linux on an unused laptop so I can learn Linux as I need to for work.

I don't recall selecting a sign on username/password but it asks for on after boot up. I've tried everything I believe I may have come up with but nothing works.

Is there a backdoor entry to reset a username/password?

I also experienced another problem (when I was able to log on) When web surfing I found that simply moving my mouse around on a web page would act as if I clicked on the "back page" button. VERY frustrating. It make me want to just use my windows box for anything I need online.

Lazer

Last edited by Lazer; 12-13-2006 at 12:22 PM.
 
Old 12-13-2006, 12:22 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
A backdoor would defeat the whole notion of system security, wouldn't it?

Since you just installed, and can't login, you don't have personal files to loose.

Re-install, paying attention to prompts for names and passwords. Write them down if you have to in order to remember them.
 
Old 12-13-2006, 12:22 PM   #3
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
i think for most user-friendly distros they will go through the process and ask you about setting up your user account. if this wasnt the case try to login to the console (or even the GUI if you have to!) as 'root' and create another account, then always use this new 'regular' user account, as root can be dangerous to work as because you have unlimited power and one command can ruin your install.
 
Old 12-13-2006, 12:24 PM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
What distribution?

Depending on the distro, it sometimes installs with password off. Did you try logging in a s root with no password?

You can boot from the install CD in rescue mode--or from a "live CD" such as Knoppix. You can disable the root password by opening the /etc/password file and editing the root entry to remove the first "x".....The entry will wind up looking something like this:
root::0:0:root:/root:/bin/bash


Now when you re-boot, you can log in to the root account with no password.
 
Old 12-13-2006, 12:26 PM   #5
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bigrigdriver
A backdoor would defeat the whole notion of system security, wouldn't it?

Since you just installed, and can't login, you don't have personal files to loose.

Re-install, paying attention to prompts for names and passwords. Write them down if you have to in order to remember them.
This was my first thought as well, but I thought I'd check to see if there was another way first. I had trouble with my first install attempt and had to do it a second time. I usually do write down any usernames/passwords. I just don't remember setting one up. Perhaps re-installing may help with the second issue I added to my original post? Or is this a bug?

Thanks
Lazer
 
Old 12-13-2006, 12:29 PM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by bigrigdriver
A backdoor would defeat the whole notion of system security, wouldn't it?

Since you just installed, and can't login, you don't have personal files to loose.

Re-install, paying attention to prompts for names and passwords. Write them down if you have to in order to remember them.
There is ALWAYS a backdoor if you have physical custody of the hardware. Locks and passwords are for honest people (and passwords are useful on networks)

If I want your data, all I have to do is boot your machine from my own CD distro---or just throw the whole thing in the trunk of my car.
 
Old 12-13-2006, 12:29 PM   #7
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
Quote:
I also experienced another problem (when I was able to log on) When web surfing I found that simply moving my mouse around on a web page would act as if I clicked on the "back page" button. VERY frustrating. It make me want to just use my windows box for anything I need online.
is this a USB mouse? this happens everytime i install slackware, and i have to prevent a mouse driver from loading to get it to work. if it is USB, then this may be one solution.
if it is not USB (or even if it is) the more likely solution will have to do with editing a file, /etc/X11/xorg.conf, under the InputDevice section for your mouse. the solution will be to change your 'Protocol', 'Device', 'Buttons' or just one of them. search around here for more help if you need to.
 
Old 12-13-2006, 12:30 PM   #8
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Question

Quote:
Originally Posted by pixellany
What distribution?

Depending on the distro, it sometimes installs with password off. Did you try logging in a s root with no password?

You can boot from the install CD in rescue mode--or from a "live CD" such as Knoppix. You can disable the root password by opening the /etc/password file and editing the root entry to remove the first "x".....The entry will wind up looking something like this:
root::0:0:root:/root:/bin/bash


Now when you re-boot, you can log in to the root account with no password.
Well this is a bit over my newbie head. I ordered a Linux fundamental course and loaded what came with it. All I see anywhere is Fedora Core 4. Does that answer the distro question?
 
Old 12-13-2006, 12:32 PM   #9
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nadroj
is this a USB mouse? this happens everytime i install slackware, and i have to prevent a mouse driver from loading to get it to work. if it is USB, then this may be one solution.
if it is not USB (or even if it is) the more likely solution will have to do with editing a file, /etc/X11/xorg.conf, under the InputDevice section for your mouse. the solution will be to change your 'Protocol', 'Device', 'Buttons' or just one of them. search around here for more help if you need to.
No, this was just using the touchpad mouse (laptop).
 
Old 12-13-2006, 12:35 PM   #10
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
ok, still, editing the file i mentioned is most likely the solution to that problem.
 
Old 12-13-2006, 12:44 PM   #11
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Still can't get past the username entry. I put the install CD in and rebooted. It still brings me to the same sign on screen with no options to re-install the OS.
 
Old 12-13-2006, 12:48 PM   #12
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
i dont imagine there is a problem with the boot order, as you got it to install off the cd in the first place, right?
when booting see if there are any messages to boot from cd or other media.
 
Old 12-13-2006, 12:51 PM   #13
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Yes I set the CD drive to first boot device when I originally loaded it. I'm not getting any options at all during the boot process.
 
Old 12-13-2006, 12:53 PM   #14
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
check the bios and verify CD is the first boot device.
 
Old 12-13-2006, 12:56 PM   #15
Lazer
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Original Poster
Rep: Reputation: 0
I'm such a friggin ID10T! I had the wrong CD in.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
LXer: Blackboard Patents Challenged LXer Syndicated Linux News 0 12-01-2006 09:54 AM
Linux For Mentally Challenged Person VernerVonTux Linux - General 3 11-01-2006 03:56 PM
absolute newbie/technologically challenged MikhailRahl Linux - Newbie 8 07-20-2006 02:37 PM
Redhat 9 - Win XP - Dual Boot - Am I mentally challenged? 8webguy8 Linux - Newbie 5 03-12-2004 07:19 PM


All times are GMT -5. The time now is 10:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration