LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-05-2005, 02:41 PM   #1
sendas4
Member
 
Registered: May 2004
Location: Tacoma, Wa
Distribution: Gentoo
Posts: 94

Rep: Reputation: 15
PLease help cannot enable DMA


Hi im using gentoo with 2.6.10-r6 with the Asuse A7N8X-E Deluxe which using nforce 2.
I compiled the kernel to use the amd and nforce ide. Here is what i get

bash-2.05b# hdparm -i /dev/hda

/dev/hda:

Model=WDC WD800JB-00FMA0, FwRev=13.03G13, SerialNo=WD-WCAJ91445553
Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=58
BuffType=unknown, BuffSize=8192kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=156301488
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=no WriteCache=enabled
Drive conforms to: device does not report version:

* signifies the current active mode


bash-2.05b# hdparm -tT /dev/hda

/dev/hda:
Timing cached reads: 1748 MB in 2.00 seconds = 873.26 MB/sec
Timing buffered disk reads: 12 MB in 3.57 seconds = 3.36 MB/sec


<code>bash-2.05b# hdparm -d 1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
 
Old 03-06-2005, 07:59 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
when you compiled your kernel, did you enable "AMD and nvidia IDE chipset support" ?
(it's under device drivers->ATA/ATAPI/MFM/RLL support).

Last edited by __J; 03-06-2005 at 08:00 AM.
 
Old 03-06-2005, 04:58 PM   #3
sendas4
Member
 
Registered: May 2004
Location: Tacoma, Wa
Distribution: Gentoo
Posts: 94

Original Poster
Rep: Reputation: 15
Ya i did as built in, not as module.
 
Old 03-08-2005, 06:34 PM   #4
sendas4
Member
 
Registered: May 2004
Location: Tacoma, Wa
Distribution: Gentoo
Posts: 94

Original Poster
Rep: Reputation: 15
bump
 
Old 03-18-2005, 04:50 AM   #5
karl007
LQ Newbie
 
Registered: Mar 2005
Posts: 1

Rep: Reputation: 0
What das "bump" mean ?

Do you have a Solution for your Problem ??


:thorsten
 
Old 03-19-2005, 09:29 AM   #6
mysterio
Member
 
Registered: Sep 2003
Location: Springfield Ma.
Distribution: Mandrake 9.2,Knoppix 3.7,Slackware 10.0, FreeBSD. 5.3, OpenBSD 3.6, NetBSD 2.0, Debian
Posts: 275

Rep: Reputation: 30
Quote:
Originally posted by karl007
What das "bump" mean ?

Do you have a Solution for your Problem ??


:thorsten
Bump just puts it back at the top of the threads, so it has a better chance of being read again.
 
Old 03-19-2005, 04:27 PM   #7
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
I'm working on the same problem right now with the 2.6.11-r4 kernel. Am currently recompiling it with a few minor changes. I'll let you know if I get it figured out. Please do likewise.
 
Old 03-19-2005, 07:41 PM   #8
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
OK, problem solved. I reconfigured my kernel without the generic IDE support and recompiled. DMA sets fine now.
 
Old 06-22-2006, 07:33 PM   #9
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
Quote:
Originally Posted by masonm
OK, problem solved. I reconfigured my kernel without the generic IDE support and recompiled. DMA sets fine now.
Hey Dude, I was having exactly the same Problem with DMA not being enabled for AMD and Nvidia Chipset.

Can you post your kernel config if possible?

Thanks
 
Old 06-23-2006, 09:37 AM   #10
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
I'm on the road right now and that machine is at home. Like I said, just disable the generic IDE support in the kernel config and it should work for you after you compile the kernel. Did for me anyway.

BTW, I was unable to reply to the email you sent me as you had chosen in your account specifics to not accept emails.
 
Old 06-23-2006, 02:20 PM   #11
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
Quote:
Originally Posted by masonm
I'm on the road right now and that machine is at home. Like I said, just disable the generic IDE support in the kernel config and it should work for you after you compile the kernel. Did for me anyway.

BTW, I was unable to reply to the email you sent me as you had chosen in your account specifics to not accept emails.
Extremely Sorry Dude, I wasn't aware that by default that thing was turned off. Nways I have gone ahead and enabled it.

Thanks for the support. I will try what you have suggested and will get back if It does not work. HOpe that;s not a problem to you.

Thank you once again.
 
Old 06-23-2006, 05:18 PM   #12
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
Quote:
Originally Posted by masonm
I'm on the road right now and that machine is at home. Like I said, just disable the generic IDE support in the kernel config and it should work for you after you compile the kernel. Did for me anyway.

BTW, I was unable to reply to the email you sent me as you had chosen in your account specifics to not accept emails.
Well I tried that option and I got a kernel Panic error. Actually there are two similar options:

1.generic/default IDE support.
and
2.default PCI IDE support.


Can you please tell me what were the status of both the options in the kernel config? Acutally I have experimented loads of time with all those IDE options so right now my kernel config is badly screwed, therefore I had asked you to post the Kernel Config of yours.
 
Old 04-09-2007, 01:36 PM   #13
chaosinmind
LQ Newbie
 
Registered: Oct 2004
Location: Florida
Distribution: Gentoo, Fedora, Slackware, FreeBSD, CentOS
Posts: 4

Rep: Reputation: 0
Post Gentoo Linux DMA Permission Denied

I just removed the one for Generic IDE... I think, and it now seems to be working perfect for me. I also added ide0=dma and ide1=dma to my grub.conf

If you tell me how to copy and paste my kernel config here, I'll post it ASAP.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't enable DMA Timeturtle Linux - Hardware 9 06-03-2004 06:34 PM
Enable DMA ust Linux - General 1 02-09-2004 02:28 AM
cant enable DMA! håkon Linux - Hardware 1 08-08-2003 04:11 PM
How to enable DMA? Piero Linux - Hardware 14 07-21-2003 07:05 AM
enable DMA? Alinuxnoob Linux - Newbie 1 02-28-2002 04:58 PM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration