LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-10-2005, 08:29 PM   #1
Vitalka
LQ Newbie
 
Registered: Nov 2005
Location: Canada
Distribution: CentOS 5.0 & Suse 10.3
Posts: 26

Rep: Reputation: 15
Playing with autofs.


Now I have been playing with "autofs" for two days (just for my own enjoyment) and I can't get it to work or I just don't understand something.

I made an entry in "/etc/auto.master":
Code:
/windows          /etc/auto.fat
Then I created file "auto.fat" in /etc and made following entry in it:
Code:
fat                   -fstype=vfat        :/dev/hda5
I took a look at a few tutorials and one of them says that:
- "/windows" will be my mounting point
- "fat" is my key to invoke automount action
So as far as I understand only "/windows" folder needs to be created.

Now when I start "autofs", my windows folder stays the empty. If I type
Code:
cd /windows/fat
it says that this folder doesn't exist.
If I create "fat" folder inside "/windows" and type
Code:
ls -al /windows/fat
, fat folder stays empty.

How do I make that when I go into that folder I would be able to see files on that partition.

Last edited by Vitalka; 11-10-2005 at 10:33 PM.
 
Old 11-10-2005, 09:53 PM   #2
Nawar
Member
 
Registered: Nov 2005
Location: Midwest America
Distribution: SuSE, RedHat
Posts: 39

Rep: Reputation: 15
After you made your changes to the config files, did you restart the autofs daemons?

If not, then more than likely, your daemons are not running with up-to-date config info.

Try restarting the service, or if you're having difficulty locating it, restart the system.


HTH,

Nawar
 
Old 11-10-2005, 10:18 PM   #3
Vitalka
LQ Newbie
 
Registered: Nov 2005
Location: Canada
Distribution: CentOS 5.0 & Suse 10.3
Posts: 26

Original Poster
Rep: Reputation: 15
I do restart the service every time I make changes.

I also solved my problem:

1. I created /windows/fat folder manually
2. I changed this:
Code:
fat                   -fstype=vfat        :/dev/hda5
to this:
Code:
fat                   -fstype=auto,rw,users,exec        :/dev/hda5
3. Restarted autofs, and finally it worked.

I just don't know if timeout option works, which i specified in "auto.master":

/windows /etc/auto.fat --timeout=10

I assume that 10 means 10 seconds and not 10 minutes, right?

Last edited by Vitalka; 11-10-2005 at 10:24 PM.
 
Old 11-10-2005, 10:22 PM   #4
Nawar
Member
 
Registered: Nov 2005
Location: Midwest America
Distribution: SuSE, RedHat
Posts: 39

Rep: Reputation: 15
Now that makes sense.

It's always the simple things that cause problems, isn't it.

Like forgetting to have a directory available as a mount point.... <DOH!>

I know I've done it before, and WILL do it again.


Glad to hear you solved your problem.

Good work!
 
Old 11-10-2005, 10:41 PM   #5
Vitalka
LQ Newbie
 
Registered: Nov 2005
Location: Canada
Distribution: CentOS 5.0 & Suse 10.3
Posts: 26

Original Poster
Rep: Reputation: 15
Directory thing was not the biggest problem. Because I tried creating it and autofs still wouldn't mount fat partition.

Now this apperantely caused all the problem:

fat -fstype=vfat :/dev/hda5

- for some reason it would not take "vfat" value so I replaced it with "auto" and also added a bunch of other options.

I also found this link:
http://www.linux-consulting.com/Amd_.../autofs-6.html
It states some of the mounting options, maybe it will come useful to someone, on this forum, one day.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
autofs kemkem42 Linux - Software 1 09-22-2005 02:22 PM
Totem playing off of network, Xine playing local iammike Ubuntu 0 04-30-2005 12:43 PM
Autofs tefal Linux - Software 4 07-20-2004 11:58 AM
Autofs...help please yourcompadre Linux - Networking 0 06-03-2003 10:07 PM
Please help! autofs foetus66 Linux - General 1 03-25-2003 08:47 AM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration