LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-07-2002, 07:07 PM   #1
natesch
Member
 
Registered: May 2002
Posts: 36

Rep: Reputation: 15
Angry Playing an Audio CD


OK~Please forgive me for what is probably a dumb question as I am new to Linux. I just installed SuSe Linux 8.0. I want to play an Audio CD but when I put it in and click on my cdrom drive it says:
"Error Could Not Mount Device. Ther reported error was: /dev/cdrom: No such file or directory mount: you must specify the filesystem type."

I have tired lotsa thing but no luck! If I type audiocd:/ it takes me to the CD and I can click a song which will then copy to a temp file before playing but there must be a better way. thanx for any help!

Nate
 
Old 05-07-2002, 07:11 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
well, in linux you can't mount audio cd's. usually you insert the cd, then start whatever program you want to use to listen with, like xmms is usually always a default program that comes with most linux distro's.
 
Old 05-07-2002, 07:17 PM   #3
natesch
Member
 
Registered: May 2002
Posts: 36

Original Poster
Rep: Reputation: 15
I am using XMMS. It is like it is not understanding there is an audio CD in the drive. I told it to play cdrom/ but there are no files there! What might I be doing wrong? thanx again
 
Old 05-07-2002, 07:21 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
can you play any type of audio file, like mp3 or wav to deterime if your sound card is working properly ? and is this with a regular user account or with root ? if its a regular user account, try root and see if you get the same type of error or no playback, might be a permissions type thing.
 
Old 05-07-2002, 07:25 PM   #5
natesch
Member
 
Registered: May 2002
Posts: 36

Original Poster
Rep: Reputation: 15
Yes I can play audio no problem! If I go to audiocd:/ it will bring up the contents of the CD and if I click on one of the .wav files it will play only inside Konqueror which is the browser I am using and copy the whole file to a temp folder or somethin 1st. I am doin all of this under root. I made sure root had access to the disk group so that can't be it either! Grr! Thanx for all the help man!

Last edited by natesch; 05-07-2002 at 07:33 PM.
 
Old 05-07-2002, 07:46 PM   #6
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
so do you get anytype of errors when trying with xmms ? and it does play within konquerer you said right ? is it just this one cd or any others that you try ?
 
Old 05-07-2002, 08:16 PM   #7
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
does the cd player located at >multimedia >cd >KsCD work?
 
Old 05-07-2002, 08:29 PM   #8
natesch
Member
 
Registered: May 2002
Posts: 36

Original Poster
Rep: Reputation: 15
No KsCD does not work either! It tells me there is no disk in drive. I don't get that~it does it with all CD's also! As for XMMS it gives no error just dosen't show any CD iles when I try to find them. It will play under konqueror but it copies the file from CD to a temp file 1st~is that supposed to happen? Thanx again!
 
Old 05-07-2002, 08:50 PM   #9
Haldir
LQ Newbie
 
Registered: Jan 2002
Distribution: Mandrake 8.2
Posts: 26

Rep: Reputation: 15
Do you have two drives that can play a CD?
I was getting the exact same message with Madrake 8.2 and found out that the DVD drive would play the CD fine but my CD-RW driver would not. I haven't figured out how to get the CD-RW drive to work yet but the DVD drive works fine. It would just not see the CD in the CD-RW drive (said it was ejected even if a CD was in there).
 
Old 05-07-2002, 08:57 PM   #10
natesch
Member
 
Registered: May 2002
Posts: 36

Original Poster
Rep: Reputation: 15
Well WOOT WOOT! That was it! just told it to look at dvd instead of CD-R Drive! Don't get that but glad it works now! One more quick question~How do I play a DVD. Not sure if I have program already for that or no! Any recomendations? Thanx for the help guys!
 
Old 05-14-2002, 02:30 PM   #11
slovin
Member
 
Registered: Nov 2001
Location: Kuwait
Distribution: Suse 8.0
Posts: 30

Rep: Reputation: 15
I have a similar problem. Xmms, grip, ksCD and other programs cannot play audio CD. I can play audio files without any problems. The internal wire connecting the CDROM to my sound card is connected. Playing CD works fine under windows.

I was able to play the audio CD however in Xmms in one weird way. Instead of adding tracking from /cdrom, I got to /dev/cdrom and I add tracks from there. Even though the tracks were added both way and the CDROM was playing, but from /cdrom no sound was coming out, and with /dev/cdrom it played fine.

I set ksCD CDROM device to /dev/cdrom but it can't play it, I mean it plays it but there is no sound.

The only way now is to use Xmms and go to /dev and then choose cdrom.... any ideas on the causes of this odd behavior?!
 
Old 05-20-2002, 08:37 PM   #12
johnm1957
LQ Newbie
 
Registered: Sep 2001
Location: USA, West Los Angeles
Distribution: SuSE 8.2 Pro, WindowsXP Home
Posts: 8

Rep: Reputation: 0
Playing audio cd's on thru a cd-rw under SuSE 8.0

I just found the answer to my trouble with playing audio cd's on my cd-rw.
I have just got SuSE 8.0 and I love it. I first used YAST2, and got all the updates. I opened XMMS and clicked on the drop down menu and selected
options, then preferences. I highlighted preferences, then the first tab called audio i/o pludins. I highlighted AudioCD Reader 0.11d (libcdread.so), then I hit the Configure button, from there I hit the Output Tab, and selected (play Audio CD Directly) , then hit OK, it worked. Then I opened the CD Player, and hit the Preferences button and at the top I changed this entry to (CDROM device) /dev/sro. Insted of /dev/cdrom. Did the same for Kcd;s player.
Yes! it feels good to finally get something right.
Hamster1
I hope this info will help someone with the same problem.
 
Old 05-28-2002, 02:43 PM   #13
johnm1957
LQ Newbie
 
Registered: Sep 2001
Location: USA, West Los Angeles
Distribution: SuSE 8.2 Pro, WindowsXP Home
Posts: 8

Rep: Reputation: 0
Cool Can't play audio cd's

I just did some online searching at SuSE Linux online. I found this info to help all of us who are having trouble playing audio cd's under SuSE 8.0. Here's the latest from SuSE. First open up the YaST2 program, then go to hardware, then click on "Hardware Info". YaST2 will probe your hardware, then when it's done, click on the "CD-ROM' entry, then click on the specific entry for your CD-ROM, CD-RW,etc. Notice the "Device Name" for your particular drive. Also click on the SCSI entry to see any other device you may have. Write it down if you need to. Then Log in as "Root", and open up a Konsole, and type this command to make a link to your device.
ln -sf /dev/sr0 /dev/cdrom Note the (sr0). This is the Device name found in YaST2 Hardware Info, substitute the name of your particular drive.
Here is the link to SuSE page on this topic. http://sdb.suse.de/sdb/en/html/dstark_combilw.html

I hope this helps also, as I thought it would be better if I got more specific
info for everybody. Hamster1













 
Old 09-20-2002, 11:09 AM   #14
john588
LQ Newbie
 
Registered: Sep 2002
Location: Ohio
Distribution: Debian 3.0 "woody"
Posts: 2

Rep: Reputation: 0
Post Mount an audio cd.

If you would like to mount an audio cd under linux you can check out the cddafs module. Go to your favorite search engine type: cddafs homepage.
Go to the home page. Download the source and follow the instructions to
compile(make and make install). After the module is compiled type: insmod
cddafs to insert the module into the kernel. If you still cannot mount the
audio cd edit your /etc/fstab file and replace iso9660 with cddafs and that
will do it. To read data cd's from that drive again you will have to change cddafs back to iso9660 in your /etc/fstab file. I hope this helped. There is plenty of information at the home page along with links to similar projects. Need more help send me some mail.
 
Old 09-20-2002, 07:29 PM   #15
FloatRed
LQ Newbie
 
Registered: Aug 2002
Distribution: Red Hat 7.3
Posts: 12

Rep: Reputation: 0
kscd problem

I am having a similar problem. Any help would be appreciated.

I am running Red Hat 7.3. I get system sounds in both Gnome and KDE.

I can play a cd that has mp3's burned on them in both environments.

I cannot seem to play an audio cd in either KsCD or the Cd player in Gnome. The app will start, it will read the cd tracks properly. The track will supposedly start playing as I watch the time tick, but no sound whatsoever.

I am using KDE right now.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
playing audio cd 5.1 alizta Linux - General 2 10-25-2004 03:20 AM
playing an audio CD malbery Debian 10 08-23-2004 12:53 PM
Help with playing audio CD... Dickey Peterson Linux - Newbie 5 01-13-2004 09:04 AM
Playing an audio CD fredws Linux - General 2 03-18-2003 03:56 PM
Audio CD not playing Relja Linux - General 6 01-22-2003 05:31 AM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration